Apache läuft, aber es können keine Objekte gefunden werden.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Sarah19 » 14. May 2007 21:33

Darf ich auch mal kurz was dazu fragen?
Ich meine htdocs ist unter folgendem Pfad gespeichert: C/Progrm Files/ Apachefriends/Xampp/htdocs

Wenn ich jetzt im Browser localhost eingebe funktioniert Xampp einwandfrei. Wenn ich allerding localhost/auto eingebe, dann bekomme ich die gleiche Meldung wie Rene. Den ordner auto gibt es.

Möglicherweise Dateien in den richtigen ordner kopieren? Oder Alternativ den Doc-Root vom Apachen auf den vermeintlich richtigen Ordner anpassen.

Tu die Datei in den DocumentRoot des laufenden Apachen und du kannst sie mit dieser URI aufrufen.

Wie finde ich herraus auf welchen Ordner der Apache ausgerichtet ist? Bzw wie kann ich den Apache aendern, so dass er auf den richtigen Ordner zeigt. (Macht fuer mich aber keinen Sinn, da es ja der htdocs sein muss weil Xampp unter localhost super funktioniert. Koennt ihr mir das bitte erklaeren?)
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby Wiedmann » 14. May 2007 21:57

Sarah19 wrote:Wie finde ich herraus auf welchen Ordner der Apache ausgerichtet ist?

Sofern man sich sicher ist in der richtigen "httpd.conf" nachzuschauen, schaut man dort nach der Directive "DocumentRoot".

Sarah19 wrote:Wenn ich jetzt im Browser localhost eingebe funktioniert Xampp einwandfrei.

Mal ganz abgesehen davon, dass die XAMPP Demoseiten nicht direkt unter "http://localhost/" sind, sondern unter "http://localhost/xampp/", hat dies natürlich den Vorteil ein funktionierendes phpinfo() zu haben...

Rufe dieses auf mit "http://localhost/xampp/phpinfo.php" und schau dort nach "DOCUMENT_ROOT".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sarah19 » 14. May 2007 22:00

Rufe dieses auf mit "http://localhost/xampp/phpinfo.php" und schau dort nach "DOCUMENT_ROOT".
da steht dann no value. Was beduetet dies? (Ja ich weiss das Document root keinen Wert hat aber wohl einen haben sollte, jedoch was ist der Wert und wie setze ich ihn?)

Sofern man sich sicher ist in der richtigen "httpd.conf" nachzuschauen, schaut man dort nach der Directive "DocumentRoot".

woher weiss ich, dass es die richtige httpd.conf ist?

Danke dir
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby René GER » 14. May 2007 22:08

Und jetzt erkläre ich dir, warum
Wiedmann hat Folgendes geschrieben:
René GER hat Folgendes geschrieben:
Habe mal einen Screenshot von meinem "htdocs"-Ordner gemacht.

Hilft leider so nicht unbedingt weiter.

Auf diesem Bild sieht man nämlich nicht, welcher Order da genau gezeigt wird. (Order mit dem Namen "htdocs" kann es ja mehrere auf deiner Platte geben)


Wiedmann wrote:
Dann könntest du ja mal so
Code: Select all
dir C:\xampp\htdocs

nachschauen, welche Dateien da sind.


Was macht das für ein Unterschied, ob ich abtippe was die Eingabeaufforderung ausgibt oder ich ein Bild davon reinstelle?
René GER
 
Posts: 15
Joined: 14. May 2007 15:34
Location: Oldenburg

Postby Wiedmann » 14. May 2007 22:12

Sarah19 wrote:
Wiedmann wrote:Rufe dieses auf mit "http://localhost/xampp/phpinfo.php" und schau dort nach "DOCUMENT_ROOT".

da steht dann no value. Was beduetet dies?

Das ist tatsächlich seltsam und dürfte gar nicht vorkommen. Ist das bei beiden "DOCUMENT_ROOT" Einträgen so?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wiedmann » 14. May 2007 22:16

René GER wrote:Was macht das für ein Unterschied, ob ich abtippe was die Eingabeaufforderung ausgibt oder ich ein Bild davon reinstelle?

Ich hab nie gesagt dass du ein Bild davon reinstellen sollst...

"Davon" ist die Ausgabe von: "dir C:\xampp\htdocs".

Aber:
René GER wrote:Diese Dateien sind da:
http://www.rm-industries.com/shot.bmp

Auf diesem Bild sieht man nicht, ob dies der Order "C:\xampp\htdocs" ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby René GER » 14. May 2007 22:22

Wiedmann wrote:
Die Eingabeaufforderung sagt auch, dass die Datei nicht da ist.

Dann könntest du ja mal so
Code: Select all
dir C:\xampp\htdocs

nachschauen, welche Dateien da sind.


Nagut, aber ich weiß sonst nicht, was ich da nachgucken soll. Deshalb habe ich gedacht, dann poste ich das einfach mal, in der Hoffnung, dass du oder jemand anderes dort einen Fehler erkennt.

Der Ordner "Document_root" existiert auf meinem System nicht
René GER
 
Posts: 15
Joined: 14. May 2007 15:34
Location: Oldenburg

Postby Wiedmann » 14. May 2007 22:34

René GER wrote:Nagut, aber ich weiß sonst nicht, was ich da nachgucken soll.

Sorry, da hatte ich die falsche Bild-URI zitiert.
René GER wrote:Habe mal einen Screenshot von meinem "htdocs"-Ordner gemacht.
http://www.rm-industries.com/screenshothtdocs.bmp

Natürlich wollen wir wissen, ob dieses Bild denn wirklich den Ordner "C:\xampp\htdocs" darstellt. (sieht man eben auf diesem Bild nicht)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby René GER » 14. May 2007 22:38

Aber auf http://www.rm-industries.com/shot.bmp sieht man's doch, dass es das Verzeichnis C:xampp/htdocs ist.

Oder habe ich noch immer was nicht so recht mitbekommen? :(
René GER
 
Posts: 15
Joined: 14. May 2007 15:34
Location: Oldenburg

Postby Wiedmann » 14. May 2007 22:42

René GER wrote:Aber auf www.rm-industries.com/shot.bmp sieht man's doch, dass es das Verzeichnis C:xampp/htdocs ist.

René GER wrote:Habe mal einen Screenshot von meinem "htdocs"-Ordner gemacht.
http://www.rm-industries.com/screenshothtdocs.bmp
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingCrunch » 14. May 2007 23:14

Geduld ist eine Tugend ^^

Also, in der httpd.conf (in der Regel unter c:/path/to/xampp/apache/conf/httpd.conf zu finden) sollte irgendwo eine DocumentRoot-Directive ähnlich dieser hier stehen.
Code: Select all
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "c:/path/to/xampp/htdocs"
(Jede Zeile, vor der eine Raute steht, ist Kommentar und wird später ignoriert.)

So, nun hat man zwei Möglichkeiten:
1. Man verschiebt alle Dateien, die man anzeigen lassen möchte, in das Verzeichnis oder ein Unterverzeichnis davon (dann aufzurufen per http://localhost/subdir/file.php), oder
2. Man setzt die DocumentRoot auf das Verzeichnis, wo sich die anzuzeigenden Dateien befinden (oder von wo aus diese in einem Unterverzeichnis liegen). Dann muss man allerdings noch etwas tiefer in der httpd.conf die zugehörige Directory-Direktive anpassen, die etwa so ähnlich aussieht
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "path/to/xampp/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI
   
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

</Directory>
Dort muss man nur das Verzeichnis ein zweites mal angeben. Apache neustarten und es sollte es tun.
Sonst noch Fragen?


@Rene: Wiedmanns Problem war, dass dein erster Screenshot keine Pfadangabe beinhaltete. Du kannst beliebig viele htdocs-Verzeichnisse auf deiner Festplatte verteilen, aber normalerweise wird nur eins davon vom Apache angesprochen ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby René GER » 15. May 2007 07:13

Das habe ich verstanden. Aber der zweite Screenshot zeigt es doch an.
René GER
 
Posts: 15
Joined: 14. May 2007 15:34
Location: Oldenburg

Postby Sarah19 » 15. May 2007 17:59

Wiedmann wrote:
Sarah19 wrote:
Wiedmann wrote:Rufe dieses auf mit "http://localhost/xampp/phpinfo.php" und schau dort nach "DOCUMENT_ROOT".

da steht dann no value. Was beduetet dies?

Das ist tatsächlich seltsam und dürfte gar nicht vorkommen. Ist das bei beiden "DOCUMENT_ROOT" Einträgen so?


Sorry hatte auf doc_root geschaut und nicht DOCUMENT_ROOT.
Ich habe folgendes stehen:
DOCUMENT_ROOT C:/Program Files/xampp/htdocs
was nicht richtig ist.
es sollte so lauten: C:/Program Files/apachefriends/xampp/htdocs und ist in der httpd.conf so auch angegeben.

Wie kann ich es aendern?
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby Wiedmann » 15. May 2007 18:09

Sarah19 wrote:
Code: Select all
DOCUMENT_ROOT C:/Program Files/xampp/htdocs

was nicht richtig ist.

Naja, für den Apachen der dann gerade läuft ist das korrekt! Der Apache setzt ja diesen Wert anhand der DocumentRoot Directive in seiner Config.

Sarah19 wrote:es sollte so lauten: C:/Program Files/apachefriends/xampp/htdocs und ist in der httpd.conf so auch angegeben.

Dann solltest du den Apache starten der sich in "C:/Program Files/apachefriends/xampp/apache/bin" befindet, und nicht den Apachen in "C:/Program Files/xampp/apache/bin".

BZW:
Wenn wirklich der Apache aus "C:/Program Files/apachefriends/xampp/apache/bin" läuft, dann schau nach, wie dessen DocumentRoot in "C:/Program Files/apachefriends/xampp/apache/conf/httpd.conf" eingestellt ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sarah19 » 15. May 2007 18:24

Danke :!:

Ich hatte offensichtlich als eines der ersten Sachen Xampp installiert auf dem neuen PC, und es dann vergessen was dazu fuehrte, dass ich es nochmal installiert hatte.

Danke nochmals.
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

PreviousNext

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests