in XAMPP 1.6.1 INNODB aktivieren ?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

in XAMPP 1.6.1 INNODB aktivieren ?

Postby CiD » 13. May 2007 19:53

Hallo,

Ich habe XAMPP 1.6.1 zum Experimentieren installiert.
In einem Tut werden Tabellen das Types INNODB angelegt aber laut phpMyAdmin ist dieser Typ nicht verfügbar.

Wie kann ich diesen TabellenTyp aktivieren ?
Wo finde ich die my.ini oder my.cnf bei XAMPP ?

Ich weiss es gibt schon mehrere Threads dazu aber in keinem eine Lösung die ich nachvollziehen kann da ich besagte .ini´s nicht auffinden kann.

Danke.
CiD
 
Posts: 34
Joined: 30. January 2007 23:34

Postby Wiedmann » 13. May 2007 20:20

Wo finde ich die ... my.cnf bei XAMPP ?

\xampp\mysql\bin

http://www.apachefriends.org/de/xampp-windows.html#1114
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CiD » 13. May 2007 20:51

Hallo Wiedmann :)

Danke für den Link aber dort hab ich auch schon gelesen um herrauszufinden wo sich besagte Datein befinden.

Im Ordner \xampp\mysql\bin befinet sich zwar eine Verknüpfung mit dem Namen "my.cnf" aber wenn ich diese anklick passiert rein garnichts.

Der MySQL-Server läuft, habe auch über den mysqladmin.exe versucht an eine cofig bzw. ini zu kommen aber nichts :?
Ich find nicht mal auf meinem ganzem System eine my.ini oder ähnliches, die sich editieren lässt.
Wie schon erwähnt, ich hab schon einige Threads hier im Forum durchgelesen , aber bis dato noch kein vernünftigen Lösungsvorschlag den ich Nachvollziehen kann, endeckt !

gruss CiD
CiD
 
Posts: 34
Joined: 30. January 2007 23:34

Postby Wiedmann » 13. May 2007 21:56

aber wenn ich diese anklick passiert rein garnichts.

Zieh diese Datei einfach aus dem Explorer in den Editor deiner Wahl.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CiD » 13. May 2007 22:19

Aha ... lach ... so einfach geht des also .... vielen Dank :) 8)

Muss man erstmal wissen :roll:

OK der rest hat auch nun funktioniert. Einfach in der my.cnf (die man per drag&drop in einen Editor zieht) folgende Zeilen so umkommentieren:


Code: Select all
skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = D:/aServer/xampp/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = D:/aServer/xampp/mysql/data/
innodb_log_arch_dir = D:/aServer/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50


hat prima geklappt... Danke euch nochmal :)

gruss CiD
CiD
 
Posts: 34
Joined: 30. January 2007 23:34


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests