Apache geht immer aus ?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache geht immer aus ?

Postby Lanak » 11. May 2007 12:38

Hi Mal ne frage ich hab Mir Xampp Neu Installiert und den wollte ich ihm Control Panel Apache Starten den steht kurz

"Running" ihn Hell Grün Makiert und auch der Admin Boutten ist anklick bar uns nach ca. 5 sek Geht er den wieder weg ? also Geht aus ...
Ich hab Schon Neu installasion Probiert usw. geht aber immer noch nich ? woran kan das Liegen ???

MFG
Lanak
 
Posts: 3
Joined: 11. May 2007 12:35

Postby KingCrunch » 11. May 2007 12:56

error.log geprüft?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Lanak » 11. May 2007 13:02

wo finde ich dne ? ^^ sry bin Laie
Lanak
 
Posts: 3
Joined: 11. May 2007 12:35

Postby KingCrunch » 11. May 2007 13:47

path/to/apache/logs/error.log
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Lanak » 11. May 2007 15:55

[Thu May 10 19:39:01 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Thu May 10 19:39:01 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Thu May 10 19:39:02 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Thu May 10 19:39:02 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Thu May 10 19:39:04 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.1 configured -- resuming normal operations
[Thu May 10 19:39:04 2007] [notice] Server built: Mar 5 2007 11:23:00
[Thu May 10 19:39:04 2007] [notice] Parent: Created child process 2380
[Thu May 10 19:39:06 2007] [notice] Child 2380: Child process is running
[Thu May 10 19:39:06 2007] [notice] Child 2380: Acquired the start mutex.
[Thu May 10 19:39:06 2007] [notice] Child 2380: Starting 250 worker threads.
[Thu May 10 19:39:06 2007] [notice] Child 2380: Starting thread to listen on port 443.
[Thu May 10 19:39:06 2007] [notice] Child 2380: Starting thread to listen on port 80.
Lanak
 
Posts: 3
Joined: 11. May 2007 12:35

Postby hagezussa » 01. July 2007 16:57

Den Fehler hatte ich auch. Er hat mich viele Stunden gekostet. Erst die richtige Anfrage bei Google: "unable to replace stderr with error_log apache" hat mich dann zu Beiträgen geführt, die helfen den Fehler beseitigen: Die einfachste Lösung - einfach das Verzeichnis mit dem ZendOptimizer umbenennen. Alternativ kommt auch in Frage, den Zendoptimizer zu aktualisieren. Als eine kritische Version wurde 3.2.4 genannt.

ZendOptimizer ist also die Ursache, zumindest wenn es sich um erprobte Anwendungen handelt, z.B. Drupal:

http://drupal.org/node/131076

Ich benutze Xampp 1.6.2 unter Vista Home Premium. Natürlich war ein Verdacht das neue Betriebssystem. Allerdings funktionierte eine Webanwendung (Wikindx - PHP und MySQL) einwandfrei, während Mediawiki 1.8.2 Apache ständig aussteigen liess. Nachdem ich das Verzeichnis umbenannt habe, funktioniert nun auch Mediwiki.[/url]
hagezussa
 
Posts: 1
Joined: 01. July 2007 16:37


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests