Webdav einrichten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Webdav einrichten

Postby southy » 08. May 2007 15:33

Hallo,

ich habe hier ein kleines Problem mit webdav.
Ich will auf meinem Rechner ein webdav haben, um mit virtuellen Maschinen (vmware) Daten austauschen zu können.
Normale Netzwerkfreigabe kommt nicht in Frage, weil die virtuellen nicht in meiner AD-Domäne liegen.

Also eigentlich ganz einfach: XAMPP 1.6.1, apache und MySQL laufen (nicht als Dienst) und ich will einfach nur von den virtuellen aus hin und her Daten übertragen.
Die beiden Webdav-Module in der httpd.conf sind ja schon standardm. aktiv.

Leider komme ich jetzt nicht weiter. Wenn ich aus dem IE "als Webordner öffnen" mache oder auch in der Netzwerkumgebung eine Ressource hinzufügen will, kommen immer eine user/Passwort-Abfrage, aber ich komme nicht weiter und ich habe auch nicht so die Riesen-Ahnung davon; ich dachte einfach, WEBDAV sei der einfachste und schnellste Weg.

Kann vielleicht mal jemand eine Beschreibung geben, was in einem fabrikfrischen XAMPP zu tun ist, daß webdav geht und wie man das auf einem zweiten Rechner dann einbindet (http://192.168.x.x/webdav/ oder http://192.168.x.x/webdav/:81 oder https://192.168.x.x/webdav/ oder https://192.168.x.x/webdav/:81 oder wie oder was?)

Vielen Dank Euch und viele Grüße.
southy
 
Posts: 1
Joined: 08. May 2007 15:21

Postby eichi1967 » 14. May 2007 11:54

Hi,
ich habe grade ein Webdav am laufen.
Mit http;//192.168.x.x/webdav kommt man im Explorer oder im IE
als Webordner auf das Verzeichnis.
Allerdings nnur mit Win2k.
Seit WinXP SP2 kann man wohl nur noch über https connecten.

Ich versuche grade SSL zu konfigurieren, blicke aber noch nicht so recht durch, wie das mit Webdav beim XAMPP geht.

Falls Du das hinbekommst, kannst Du mal kurz die Konfiguration erklären?

Achja, Webdav einrichten habe ich mit folg. Leseprobe gemacht:
http://www.edv-buchversand.de/productin ... pe=3&lng=0
Hat gut gefunzt.

Gruß
eichi1967
eichi1967
 
Posts: 4
Joined: 25. February 2007 13:52

Postby eichi1967 » 14. May 2007 16:03

Bei XAMPP ist ssl standartmäßig aktiv für DocumentRoot.

Unter WinXP als Netzwerklaufwerk https://192.168.x.x/Alias angeben.
Dann evtl. noch das Zertifikat (abgelaufen) akzeptieren oder auch installieren.
Ich hatte Fehlermeldungen, kann aber trotzdem Files kopieren.

Im IE6 gehts noch nicht.
Man sollte erst mal ssl vernünftig mit gültigen Zertifikaten für den Wbdav-Ordner einrichten.

Fruß
eichi1967
eichi1967
 
Posts: 4
Joined: 25. February 2007 13:52


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests