http://localhost/xampp ?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

http://localhost/xampp ?

Postby Bort » 07. May 2007 18:51

Hallo!
Ich habe ein (vermutlich simpel zu lösendes) Problem mit meiner XAMPP Installation.
Die Installation verlief fehlerfrei, und auch XAMPP läuft im Moment ohne eine Fehlermeldung. Wenn ich nun auf http://localhost zugreife über einen Browser, dann lande ich immer bei der Seite http://localhost/xampp/ , auch wenn nur http://localhost eingetippt wurde. Eigentlich sollte ich doch dann im "htdocs" bzw. bei der darin liegenden index.htm/html landen, oder?
Warum lande ich dort nicht?
Ich habe keinerlei Firewall installiert, die Windows XP Firewall ist deaktiviert, und kann mir das irgendwie nicht erklären.
Kann mir einer weiterhelfen?
Bort
 
Posts: 3
Joined: 07. May 2007 18:40

Postby Wiedmann » 07. May 2007 18:55

Gibt es noch die Datei "index.php" im "htdocs"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bort » 07. May 2007 19:19

Ja!
In ihr steht folgendes:

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(


Was mir jetzt zu denken gibt, aber da ich nur Grundlagen in Programmierung, geschweige denn Ahnung von PHP habe, leider nicht weiterhilft. :-(
Naja gut, etwas doch. Ich habe geblickt, dass diese Datei mich wieder ins xampp verzeichniss schickt. Aber nicht warum.
Bort
 
Posts: 3
Joined: 07. May 2007 18:40

Postby Wiedmann » 07. May 2007 20:16

Ja!

Dann lösche diese.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 07. May 2007 22:17

Also ich bin nun glaub ich weiter gekommen. Skype nimmt sich den Port 80 jetzt hab ich es mal aus gemacht und wenn jetzt andere User im Internet diesen Link klicken http://hell-971ab30b73/ kommen sie auf dieses Forum hier Oo ich bin ziemlich durcheinander. Aber ich glaub ein bisschen weiter.
Wie kommt man denn wie bei Xampp beschrieben in das Konfigurations Programm ?
So wie da http://www.apachefriends.org/de/xampp-windows.html#628

Image
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 07. May 2007 22:28

Wie kommt man denn wie bei Xampp beschrieben in das Konfigurations Programm ?

Welches "Konfigurations Programm"?

So wie da

Unter diesem Links wird jedenfalls kein solches Programm beschrieben. *grübel*
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 07. May 2007 22:30

So wie auf dem Bild was ich gepostet habe Oo
Naja das Programm ist egal, aber warum kommen andere Internet User in dieses Forum hier wenn sie auf http://hell-971ab30b73/ klicken ?
Sie sollten auf die index.html kommen die ich bereitgestellt habe
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby KingCrunch » 07. May 2007 22:32

Naja das Programm ist egal, aber warum kommen andere Internet User in dieses Forum hier wenn sie auf http://hell-971ab30b73/ klicken ?
Kann ich nicht bestätigen.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Wiedmann » 07. May 2007 22:34

So wie auf dem Bild was ich gepostet habe Oo

Ach so, du meinst die Demoseiten. Na eben mit der URL:
http://name-oder-ip-von-deinem-server/xampp/

Was dann, wenn du das machst, eben wie auf der Bild diese ist:
http://localhost/xampp/
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 07. May 2007 22:47

welche IP ?

http://127.0.0.1/
http://192.168.1.33/
http://127.0.0.4/

?

Ich will nur das andere Internet User auf die html´s zugreifen können aber das geht net.
Ist es so schwer seinen PC als Server laufen zu lassen ?
http://localhost/xampp/ <--- geht net, kommt Fehlerseite
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby KingCrunch » 07. May 2007 22:53

http://localhost/xampp/ <--- geht net, kommt Fehlerseite
Aha, und welche?
Hmm? Woher kommt denn die letzte? Oo
Ich nehme mal an, dass die zweite deine lokale IP ist. Insofern müssten die ersten beiden funktionieren, ebenso wie localhost.

Ich will nur das andere Internet User auf die html´s zugreifen können aber das geht net.
Dafür brauchste wiederum deiner externe (oder auch "Internet-") IP. Da du ja scheinbar in einem lokalen Netzwerk bist, solltest du die externe IP von deinem Router erfahren. Allerdings ändert die sich bei jeder Einwahl.

Ist es so schwer seinen PC als Server laufen zu lassen ?
Ich gehe davon aus, dass du dich um die Sicherheitsaspekte noch selber informiert, falls dies nicht bereits geschehen ist.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby LaVey » 07. May 2007 22:59

Das kommt bei http://localhost/xampp/

Not Found

The requested URL /xampp/ was not found on this server.

Die anderen funktionieren aber net Oo bei mir funktioniert es nur bei den andern im Internet net.
Ja ich weiss bescheid wegen der Sicherheit.
Woher bekomm ich die externe IP beim Router ?
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 07. May 2007 23:42

Hm, schwere Geburt...

Das kommt bei http://localhost/xampp/

not Found

Also diese URL tut nicht.
- Das Verzeichnis ist "htdocs\xampp" ist noch da?

Die anderen funktionieren aber net

Welche Anderen?
- Andere Hostnamen mit diesem Pfad?
- Oder dieser Hostname und ein anderer Pfad?

bei mir funktioniert es

Ich dachte bei dir tut "http://localhost/xampp/" nicht (siehe oben). Und jetzt tut es plötzlich?

Woher bekomm ich die externe IP beim Router ?

Das verrät dir die Konfigurationsoberfläche von deinem Router. Es gibt aber auch Seiten wie z.B. "What's my IP" wo du das siehst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 08. May 2007 07:41

Also mitlerweile funktioniert bei mir http://localhost/xampp/
Musste einige Einstellungen machen.
So und welche Nummer muss ich den Internet Usern geben damit sie zugriff darauf bekommen ?
Diese funktionierten nicht
http://127.0.0.1/
http://192.168.1.33/
Mitlerweile funktionieren aber auch diese.
Aber wie gesagt nur bei meinem Rechner.
Jetzt möchte ich nur noch das anderee Internet User das auch sehen können was ich an html anlege.


EDIT: Also die Demoseite funktioniert nun auch, wie muss ich weiter machen jetzt ?
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Bort » 09. May 2007 12:07

Wiedmann wrote:
Ja!

Dann lösche diese.


Danke, jetzt geht es! :)
Bort
 
Posts: 3
Joined: 07. May 2007 18:40


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests