Eigenen Server erstellen !?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Eigenen Server erstellen !?

Postby LaVey » 01. May 2007 17:12

Hallo

Ich habe nun XAMPP auf meinem PC installiert, im Kontrollpanel ist folgendes Aktiviert und läuft.

Apache
MySql
FileZilla

Image

Hier noch ein Screen davon.
Ich selbst sehe die Testseite wenn ich auf
http://127.0.0.1/
http://127.0.0.2/

oder so gehe, aber andere nicht.
Bei anderen kommt nur eine weisse Seite.Wie mache ich das damit andere die Seite auch sehen ?
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 01. May 2007 17:45

aber andere nicht.

Welche "andere"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 01. May 2007 18:06

Ja andere User meine ich, ich will es ja öffentlich machen das jeder die Website dann sehen kann. Bei den andern Usern denen ich den Link gebe kommt nur Fehler.
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 01. May 2007 18:11

Bei den andern Usern denen ich den Link gebe kommt nur Fehler.

Welchen Link gibst du denn den Anderen?

"localhost" darf das natürlich nicht sein, da "localhost" immer der eigene Rechner ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 01. May 2007 18:13

http://127.0.0.2/
http://127.0.0.1/
http://127.0.0.3/
und den
http://hell-971ab30b73/

Alle funktionieren nicht.
Mit meiner IP funktioniert es auch nicht.
Habe auch diese Domain registriert
http://lavey.dyndns.org/

funktioniert genauso wenig.

Was muss ich denn den anderen geben damit sie die Inhalten sehen können ?
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby LaVey » 01. May 2007 21:13

Kann mir denn keiner weiter helfen ?
Ich müsste ja eigentlich nur wissen welche Adresse ich den Usern geben muss damit sie die Site sehen können. Oder wie ich das anstelle
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 01. May 2007 21:49

Habe auch diese Domain registriert http://lavey.dyndns.org/ funktioniert genauso wenig.

Siehe dazu in der "XAMPP FAQ": XAMPP übers Internet erreichbar machen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 01. May 2007 22:12

Ich hab irgendwie nur die Englische Readme, wo finde ich denn die FAQ wo dieser Beitrag steht ? Sorry aber ich bin neuling auf diesem Gebiet.
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 02. May 2007 01:23

wo finde ich denn die FAQ wo dieser Beitrag steht ?

http://community.apachefriends.org/f/viewtopic.php?t=24350#top
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 02. May 2007 07:05

:shock: :shock:
Aber das ist doch dieser Beitrag hier und nicht die FAQ ?!
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby martinpre » 02. May 2007 16:50

Schau mal rauf, da steht das:

Wichtig: XAMPP FAQ
Schaut bitte - bevor Ihr hier eine Frage stellt - auch in die XAMPP FAQ. Dort könnt Ihr übrigens sogar selbst Beiträge schreiben.
Bitte benutzt auch diese Möglichkeit. Andere Benutzer werden es Euch danken!

...
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby LaVey » 02. May 2007 18:08

Ok hab es mir durchgelesen.

XAMPP erreichbar aus dem Internet

Je nach Aufbau des eigenen Internetzuganges muss entsprechend der Geräte ein sogenanntes PORTFORWARD
eingerichtet werden, damit die http://-Abfragen auch auf den PC, wo XAMPP läuft, geschickt werden und dementsprechend
beantwortet werden können.

Das selbe gilt auch für eine laufende Firewall; darin muss der Port auch freigegeben werden.

Viele der Nutzer haben einen Router, der die Interneteinwahl steuert (auch Accesspoints von WLAN).
Diese Geräte haben bei Ihrer Grundinstallation kein “Forward” eingerichtet und somit würde eine http://-Anfrage
zwar aus dem Internet an den Router gelangen aber nicht weitergeleitet an den PC, wo der eigentliche XAMPP drauf läuft.

Bei der Vielzahl der verschiedenen Geräte ist hier eine eindeutige Beschreibung unzugänglich, von daher
bitte die Anleitung des Gerätes lesen. Diese Geräte besitzen ein Webinterface, was man durch die Installation
schon kennen sollte; darin sind weitere Einstellungen möglich in Bezug auf PORTFORWARD.
(manchmal auch Port Redirection oder NAT-Konfiguration genannt)

Generell geht es aber um den PORT 80 (HTTP), der auf die LAN-IP des PC geleitet werden sollte, worauf der XAMPP läuft.

weitere Ports wären:
TCP PORT 21 für FTP-Zugriff
TCP PORT 3306 FALLS man den MySQL-Zugriff von außen freigeben will (HIGH Security hole)
TCP PORT 143 für einen IMAP-Zugang
TCP PORT 25 für eigenen Mailserver (SMTP)
TCP PORT 110 für eigenen Mailserver (POP)

)


Wo stelle ich das ein ?
Hier meine Router Konfiguration

www.abload.de/img/unbenannt-2it4.png
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 02. May 2007 19:32

In der Dokumentation deines Routers sollte das beschrieben sein.

In der Zyxel Faq findest du auch Hilfe dazu, wie man Ports weiterleitet.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby LaVey » 02. May 2007 20:34

Ich hab das jetzt so gemacht wie in der Anleitung.
Welche Nummer muss ich jetzt den andern Usern geben ? Die, die ich bei der Konfiguration angegeben habe ?
Das wäre diese http://192.168.1.34/ aber es funktioniert immernoch nicht.
Bin ich einfach nur zu blöd dafür ?
Ich bin langsam am verzweifeln...
User avatar
LaVey
 
Posts: 21
Joined: 01. May 2007 17:06

Postby Wiedmann » 02. May 2007 20:40

Welche Nummer muss ich jetzt den andern Usern geben ?

User die aus dem LAN zugreifen, oder User die aus dem WAN (Internet) zugreifen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests