VHOST - never Ending Story ;)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

VHOST - never Ending Story ;)

Postby TommiH » 22. April 2007 13:58

Hallöchen,

nachdem die Grundkonfiguration meiner VHOSTS einwandfrei läuft wollte ich eben nochmal per

http://localhost/xampp/splash.php

auf das XAMPP-Frontend zugreifen, nur, das geht nicht mehr. Ich habe versucht einen VirtualHost für XAMPP zu setzen und stoße auf folgendes Problem. Es kommt immer Zugriff verweigert.

Ich habe diese 2 Einträge in der httpd.conf

----------
DocumentRoot "E:/internet"
<Directory "E:/internet">
----------

und die VHOSTS danach laufen einwandfrei mit

------------------------
<VirtualHost *:80>
ServerName www.links.hier
DocumentRoot e:/internet/links
</VirtualHost>

usw.
------------------------
davon gibt es 6 und alle klappen.

XAMPP liegt aber nicht auf e:/internet sondern auf d:/inet - also habe ich folgendes probiert.

<VirtualHost *:80>
ServerName www.xampp.hier
DocumentRoot d:/inet/xampp/htdocs
</VirtualHost>

aber damit kommt wie gesagt immer Zugriff verweigert.

Nun Frage ich mich überhaupt, warum gibt es in der httpd.conf ein DocumentRoot UND in den VHOSTS? Eines würde doch reichen. Und wenn das in den VHOSTS das in der httpd.conf 'überschreibt', warum geht es nicht mit xampp?

Oder muss ich xampp neu installieren, das unter e:internet wo auch die anderen internetsachen liegen?
Irgendwie etwas verwirrend das Ganze. Kann mir da jemand weiterhelfen?

Tommi
TommiH
 
Posts: 8
Joined: 24. March 2007 18:17

Ursache für Zugriff verweigert! 403-header

Postby xyzdata » 24. July 2007 18:52

ganz allgemein zu dem thema sag ich folgendes:
zuerst, zuallererst, ganz am anfang da MUSS die sache einfach mal funktionieren.

erst später MUSS man sich um die Absicherung des Systems kümmern und dass in kleinen schritten, weil die überschaubar sind.
ist aber auch Sache eines HostingProviders des Vertrauens.

da mittlerweile viele ihre eigenen konfiguration mit xampp am laufen haben ist dieser eintrag als standard nur nervig. (wie passwörter auf privatrechnern)

# dieser eintrag
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>
wird getauscht zu

<Directory />
# Options FollowSymLinks
# AllowOverride None
# Order deny,allow
# Deny from all
</Directory>

ich habe ja zuerst gedacht dass die pfade nicht stimmen aber die selben pfade haben ja bei der alten installation funktioniert.



meine config:
http.conf
# braucht man nicht mehr
# DocumentRoot "q:/files/inproc/workdirs/www/server3"


NameVirtualHost *:80

<VirtualHost *:80>
ServerName *.local
DocumentRoot "q:/files/inproc/workdirs/!projekte/!cmsx/!fertige_webs"
</VirtualHost>


<VirtualHost *:80>
ServerName server3
ServerAlias server3 *.server3
DocumentRoot "q:/files/inproc/workdirs/www/server3"
ErrorDocument 404 /error/error404.php
</VirtualHost>


<VirtualHost *:80>
ServerName *.localhost
ServerAlias localhost *.localhost
DocumentRoot "q:/files/inproc/workdirs/www/localhost"
</VirtualHost>

C:\WINDOWS\system32\drivers\etc\hosts

127.0.0.1 localhost
127.0.0.1 server3
127.0.0.1 local
127.0.0.1 myweb.local
127.0.0.1 books.local
127.0.0.1 help.local
127.0.0.1 ruby.local

ihr solltet den port 80 am internet-router nach aussen sperren dann könnt ihr innerhalb eures netzwerks trotzdem von jedem rechner auf die webseiten zugreifen.

zb mit 192.168.0.3/index.php

was natürlich auch geht ist eine angepasste version der hosts
auf jeden rechner kopieren

127.0.0.1 localhost
192.168.0.3 server3
192.168.0.3 local
192.168.0.3 myweb.local
192.168.0.3 books.local
192.168.0.3 help.local
192.168.0.3 ruby.local

und dann in mit server3/index.php zugreifen
oder myweb.local/
oder help.local
xyzdata
 
Posts: 4
Joined: 24. July 2007 18:05


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 8 guests