Apache stürzt ab, wenn man zu schnell ist!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache stürzt ab, wenn man zu schnell ist!

Postby Woosh » 31. March 2007 12:45

Hi Leute,

ich habe hier XAMPP auf Windows laufen und habe folgendes Problem mit dem Apache 2.2.3, auf welchen über den Service von DynDNS.org zugegriffen werden kann:

Jedes Mal, wenn man auf meiner Homepage zu schnell hintereinander Hyperlinks betätigt, hängt sich der Apache auf. Konnte nichts über Google oder die Forumsuche finden, deshalb dieser Thread.
Wisst ihr weiter?

MfG Woosh

PS: Wenn ich dann über den ControlPanel von XAMPP auf "Apache stoppen" (oder so ähnlich) klicke, kann ich ihn zwar stoppen, allerdings nicht mehr starten. Wenn ich dann auf "Apache starten" klicke (er ist ja dann abgeschaltet), steht kurz "Apache is running" (oder so ähnlich da), schaltet aber sofort wieder ab und "Apache is running" verschwindet sofort wieder. Auch wenn ich versuche, XAMPP neuzustarten mit dem Programm "xampp_restart.exe", schließt er das CMD-Fenster mit "Apache and MYSQL is starting now" gleich wieder nachdem das Fenster folgendes Ausgibt:
Please wait [Bitte warten] (OS 10048)Normalerweise darf jede Socketadresse (Prot
okoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : m
ake_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Diese Ausgabe verstehe ich nicht ganz, denn vorher lief der Apache ja auch auf dem gleichen Port, da dieser Port aber jetzt wieder leer ist, stellt sich mir die Frage, wieso er ihn nicht einfach wieder benützt. Außerdem dachte ich eigentlich, dass er nicht 0.0.0.0:80 benützt sondern viel eher 127.0.0.1!

[EDIT:] Was ich ganz vergessen habe: Wenn ich einen Rechnerneustart mache, klappt alles wie vorher. Sobald man wieder zu schnell die Hyperlinks anklickt, ist wieder alles wie oben beschrieben.
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby KingCrunch » 31. March 2007 20:58

Klingt eher danach, als wenn du den Apache nicht stoppst ;) Die Meldung sagt dir, dass da quasi noch ein anderes Programm lauscht. Einfach danach mal portcheck machen und/oder im Panel mal auf "Refresh" klicken, ob der Apache wirklich beendet ist. Gerne auch mal in den Prozessen nach den Häuptling schaun.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Woosh » 01. April 2007 00:45

Laut dem ControlPanel HAB ich ihn aber definitiv gestoppt. Was genau soll ich jetzt machen? Weiß ned, wie das geht. Sorry, bin noch ziemlich Noob.

lg Woosh
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby martinpre » 01. April 2007 09:16

stoppe ihn mal und mache dann einen portcheck
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby Woosh » 01. April 2007 11:44

portcheck? nie gehört, sry
kann jemand sagen, wie das geht bitte?
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby Woosh » 02. April 2007 20:29

keiner da, der weiterweiß? *hoff* büdde mäldäd euch *hilfslosgugg*
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby KingCrunch » 04. April 2007 22:25

Kommandozeile, dann zum xampp-verzeichnis und dort dann "portcheck.bat" (oder so ähnlich).
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Woosh » 05. April 2007 12:23

aaaalso... die portcheck.bat sagt garnix... öffnet sich, und schließt sich wieder... allerdings die xampp-portcheck.exe sagt folgendes (was meiner meinung eigentlich eh passt):

***************************************************************
* XAMPP PortCheck v1.2 *
* *
* (c) 2005 Carsten Wiedmann <info@wiedmann-online.de> *
* *
* This script uses openport.exe: *
* (c) 2003 DiamondCS <http://www.diamondcs.com.au/openports/> *
***************************************************************

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 443 free

MySQL 3306 C:\Programme\xampp\mysql\bin\mysqld-nt.exe

FileZilla (FTP) 21 C:\Programme\xampp\FileZillaFTP\FileZillaServer.exe
FileZilla (Admin) 14147 C:\Programme\xampp\FileZillaFTP\FileZillaServer.exe

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby Woosh » 08. April 2007 12:01

Weiß keiner mehr weiter? :(
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby Woosh » 10. April 2007 15:23

ich hab jetz nochmal bisschen nachgeforscht und bin darauf gekommen, dass es vllt garnicht daran liegen könnte, ob jemand zu schnell klickt, sondern liegt es viel eher daran, dass manchmal mehrere ips gleichzeitig auf meinen apache zugreifen... ganz logisch bei einer normalen homepage... bringt euch das wieter?

lg woosh
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27

Postby Woosh » 12. April 2007 16:56

öhm... ha-llo? ^^
Woosh
 
Posts: 14
Joined: 31. March 2007 12:27


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests