InnoDB-Aktivierung unter Vista (Xampp 1.6.0a)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

InnoDB-Aktivierung unter Vista (Xampp 1.6.0a)

Postby silviofreih » 26. March 2007 22:07

Hallo miteinander,

bis vor einer Stunde lief auf einem Testrechner noch sehr erfolgreich Xampp 1.5.5 mit aktivierter Storage Engine InnoDB. Nach einem Update auf Version 1.6.0a lässt sich InnoDB nicht mehr aktivieren. Hier der Inhalt der my.cnf:

Code: Select all
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# C:/Program Files/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:/Program Files/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password       = your_password
port            = 3306
socket          = mysql

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
basedir="C:/Program Files/xampp/mysql"
tmpdir="C:/Program Files/xampp/tmp"
datadir="C:/Program Files/xampp/mysql/data"

port            = 3306
socket          = mysql

old-passwords
character-set-server = latin1
collation-server = latin1_general_ci

skip-locking
key_buffer = 16K
max_allowed_packet = 1M
table_cache = 4
sort_buffer_size = 64K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 64K

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (using the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking
server-id   = 1

# Uncomment the following if you want to log updates
#log-bin=C:/Program Files/xampp/mysql/data/mysql-bin

# Uncomment the following if you are NOT using BDB tables
skip-bdb

#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:/Program Files/xampp/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/Program Files/xampp/mysql/data/
innodb_log_arch_dir = C:/Program Files/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 8M
sort_buffer_size = 8M

[myisamchk]
key_buffer = 8M
sort_buffer_size = 8M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server="C:/Program Files/xampp/mysql/bin/mysqld.exe"
#user=root
#password=


Eigentlich wurde an der Config nicht viel geändert, nur die InnoDB-Zeilen auskommentiert. InnoDB lässt sich allerdings mit dieser Config leider nicht mehr verwenden. Vielleicht mache ich einen kapitalen Fehler?

Vielen Dank für eure Hilfe und eure Ideen

Silvio Freih
silviofreih
 
Posts: 2
Joined: 26. March 2007 22:00

Postby Wiedmann » 26. March 2007 23:02

Nach einem Update auf Version 1.6.0a lässt sich InnoDB nicht mehr aktivieren.

- Fehlermeldungen?
- Log?

Hier der Inhalt der my.cnf:

Wird diese "my.cnf" benutzt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby silviofreih » 27. March 2007 12:40

Hi,

danke für die Antwort.

Ja, diese my.cnf wird benutzt. Lösche ich sie, startet der Service nicht mehr. Eine andere gibt es auf dem System auch nicht.

Fehlermeldungen gibt es keine. Alles gut. Bemühe ich phpmyadmin, dann sehe ich, dass die Servervariablen " innodb data file path" & "innodb data home dir" leer sind. Und das, obwohl sie in der cnf angegeben wurden.

Ich bin halbwegs ratlos :? .
silviofreih
 
Posts: 2
Joined: 26. March 2007 22:00

Postby Wiedmann » 27. March 2007 13:21

dass die Servervariablen " innodb data file path" & "innodb data home dir" leer sind.

Wirklich aussagekräftig wäre:
Code: Select all
SHOW VARIABLES LIKE 'have_innodb';


Fehlermeldungen gibt es keine.

Und was steht im auch nachgefragten Log?

Code: Select all
innodb_data_home_dir = C:/Program Files/xampp/mysql/data/
innodb_log_group_home_dir = C:/Program Files/xampp/mysql/data/
innodb_log_arch_dir = C:/Program Files/xampp/mysql/data/

Diese Pfade würde ich, wie die anderen Pfade in der "my.cnf" auch, quoten.

Ansonsten:
diese my.cnf wird benutzt.

Könntest du als Test mal folgendes in die "my.cnf" schreiben:
Code: Select all
default-time-zone = Europe/Berlin

Und schauen, ob den Wert dann so siehst:
Code: Select all
SHOW VARIABLES LIKE 'time_zone';
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests