Zugriff verweigert?!? (Vhosts)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Zugriff verweigert?!? (Vhosts)

Postby TommiH » 25. March 2007 00:30

Hai,

nun habe ich also XAMPP auf meinem XP-Prof-Server installiert. Das ganze scheint auch zu laufen, wenn ich aber versuche meine lokal auf E liegenden Internetsachen einzubinden geht es nicht.
Es kommt immer 'Zugriff verweigert'. Ich hab ja erst WinXP im Verdacht gehabt, aber wenn ich die Firewall aus schalte, ändert sich nichts. Daran liegt es also nicht.

Ich habe in der httpd.conf folgendes eingetragen:

ServerName localhost:80
DocumentRoot "E:/internet"

Unter e:/internet/links ist z.B. eine Linkliste (index.html) unter e:/internet/rezepte ist eine Rezeptsammlung, auch in einer index.html

Es kommt aber einfach immer nur

--------------------------------------------
Zugriff verweigert!

Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
--------------------------------------------

Erstmal gebe ich auf einem anderen Netzrechner beim Browser nur 192.168.1.200 ein.
Das ist die IP des Servers.

In der HOSTS auf dem Netzrechner habe ich sowas wie

192.168.1.200 www.links.hier
192.168.1.200 www.rezepte.hier

usw. eingerichtet. Wenn ich aber in der httpd-vhosts im Verzeichnis EXTRA noch

<VirtualHost *:80>
DocumentRoot e:/internet/links
ServerName www.links.hier
</VirtualHost>

dazufüge bleibt es dabei, kein Zugriff möglich.

Auch nach einigem Googeln, es bleibt dabei, kein Zugriff... :(
Der Apache startet aber problemlos aber im LOG steht nur

[error] [client 192.168.1.32] client denied by server configuration: E:/internet/links/

die 32 ist der Clientrechner, von dem ich den Zugriff probiere.

Hat da jemand noch eine Idee? Muss man im httpd.conf noch irgendwo irgendwas freischalten?

LG,
Tommi
Last edited by TommiH on 25. March 2007 09:29, edited 1 time in total.
TommiH
 
Posts: 8
Joined: 24. March 2007 18:17

Postby Wiedmann » 25. March 2007 00:36

Wenn du das DocumentRoot änderst, musst du auch das Verzeichnis ein paar Zeioen darunter ändern.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby TommiH » 25. March 2007 08:01

MIST! Ich ...

# This should be changed to whatever you set DocumentRoot to.

Das meinst Du?

DANKE!!! Ich könnte jetzt schreiben, 'wer lesen kann ist...'
Nur frage ich mich, warum die einen weiteren Eintrag machen, der IMMER genauso sein muss wie der andere. Komisch.
Egal, nun funktioniert es,
Danke nochmal!

LG,
Tommi
TommiH
 
Posts: 8
Joined: 24. March 2007 18:17

VHosts gehen (fast) richtig

Postby TommiH » 25. March 2007 08:25

Hai,

aber richtig gehen tut es leider immer noch nicht. Ich habe folgende Einträge gemacht, aber beim Aufruf im Browser landet man immer nur auf dem ersten Eintrag. Also egal ob ich den ersten, den zweiten oder den dritten Link eingebe.
Noch erstaunlicher ist, wenn ich 192.168.1.200 eingebe, DANN! lande ich auf dem letzten Eintrag (also der Inhalt von e:/inmternet/hummel)?!? Irgendwie etwas verwirrend...

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
DocumentRoot e:/internet/links
ServerName www.links.hier
</VirtualHost>

<VirtualHost 127.0.0.1>
DocumentRoot e:/internet/rezepte
ServerName www.rezepte.hier
</VirtualHost>

<VirtualHost 127.0.0.1>
DocumentRoot e:/internet/hummel
ServerName www.die-hummels.hier
</VirtualHost>

Weisst dafür auch noch jemand eine Lösung?

Tommi
TommiH
 
Posts: 8
Joined: 24. March 2007 18:17

Postby xyzdata » 24. July 2007 18:50

zum glück hat dass bei mir funktioniert!

# dieser eintrag

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

#wird getauscht zu

<Directory />
# Options FollowSymLinks
# AllowOverride None
# Order deny,allow
# Deny from all
</Directory>
xyzdata
 
Posts: 4
Joined: 24. July 2007 18:05


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 5 guests