Dateien? htdocs? wo?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Dateien? htdocs? wo?

Postby RacZoO » 21. March 2007 18:48

Hallo Leute,

Ich habe ein Problem.
Wenn ich eine php-Datei z.b. mit Notepad++ abspeicher, kann ich es auch über das selbe Programm wieder öffnen.
Aber es sind keine vorhanden, wenn ich über den Windows-Explorer darauf zugreife. Auch kann ich die Dateien nicht im InternetExplorer aufrufen.
Wo liegt das Problem? Das Problem hatte ich schon einmal, als ich bei irgendjemandem XAMPP installiert habe.

Gruß


RacZoO
RacZoO
 
Posts: 4
Joined: 21. March 2007 16:26
Location: Erlangen

Postby KingCrunch » 21. March 2007 19:46

RacZoO wrote:Aber es sind keine vorhanden, wenn ich über den Windows-Explorer darauf zugreife.
Ähm ... Hä?
RacZoO wrote:Auch kann ich die Dateien nicht im InternetExplorer aufrufen.
Wie rufst du sie denn im IE auf?

Also, paar Infos wär net: Wo speicherst du die Dateien? Was meinst du mit "Explorer drauf zugreifen"? Wie rufst du sie auf? Was passiert stattdessen? usw
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby RacZoO » 21. March 2007 20:15

also nochmal ^^

ich schreibe mir in notepad++ nen kleines helloworld programm z.b.
das speicher ich dann unter htdocs/abc ab.
wenn ich jetzt über den explorer in htdocs/abc reingeh, ist der ordner trotzdem leer. auch im internet-explorer http://localhost/abc ist nix zu finden.
wenn ich aber in notepad++ auf öffnen geh und den ordner aufrufe, ist dort die datei vorzufinden.
aber ich weiß nicht warum.
normalerweise sollte die eigentlich auch so im explorer angezeigt werden. ist da irgendein bug von xampp bzw. muss ich da erst noch etwas einstelln? oder bin ich einfach zu blöd dafür?
wobei, das bezweifel ich, da ich schon öfters mit xampp problemlos gearbeitet hatte. nur bei dieser installation nun nicht.

gruß
RacZoO
 
Posts: 4
Joined: 21. March 2007 16:26
Location: Erlangen

Postby Wiedmann » 21. March 2007 20:30

das speicher ich dann unter htdocs/abc ab.
wenn ich jetzt über den explorer in htdocs/abc reingeh, ist der ordner trotzdem leer.

Dann sind das wohl verschiedene "htdocs/abc" Ordner.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RacZoO » 21. March 2007 20:50

nein, ich hab doch nur ein htdocs-verzeichnis... genauso wie ich nur ein xampp verzeichnis hab
RacZoO
 
Posts: 4
Joined: 21. March 2007 16:26
Location: Erlangen

Postby DJ-Galaxy » 24. March 2007 02:15

ähm okee also du hast recht normaler weise wenn man das über der internet explorer bzw firefox öffnet dann erscheint ja das index des ftps was man bei sich angelegt hat und dort sollte normaler weise deine datei über den explorer zu sehen sein.

Also das index erscheint ja nur wenn man keine index.html oder php da liegen hat aber das is ja klar, jedoch sollte eigentlich trzodem die datei zu sehen und aufzurufen möglich sein.

Also einer seits denke ich da das selbe wie du das das ein bug sein kann, weil anders kann ichs mir auch net erklären.

und übrigens auch, soweit ich richtig denke, ist es so wenn man zwei htdocs verzeichnise hat, dann würde man trzodem seine daten erreichen können ob man will oder nicht da die adresse die man für seinen webserver nutzt zu beiden verzeichnissen führen eigentlich.

Also ich kann mir das auch net anders erklären, als das es ein fehler sein kann.


Oder hast du das Problem gelöst?
DJ-Galaxy
 
Posts: 63
Joined: 10. April 2006 09:17


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests