Verzeichnisschutz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Wiedmann » 16. March 2007 12:31

[Fri Mar 16 08:09:48 2007]
Code: Select all
require KHS\visis

[error] [client 10.0.100.141] access to / failed, reason: unknown require directive:"KHS\\visis"
Nach "require" muss man erst einmal angeben, ob man einen User oder eine Gruppe noch speziell angibt:
http://httpd.apache.org/docs/2.2/mod/core.html#require
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 13:26

sspi.conf:
Code: Select all
<Directory "D:/xampp/xampp/htdocs/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
   
    AuthName "restricted area"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
 

    require user KHS\visis
</Directory>


httpd.conf:
Code: Select all
LoadModule sspi_auth_module modules/mod_auth_sspi.so

<IfModule mod_auth_sspi.c>
Include conf/sspi.conf
</IfModule>


Erorlog:

Code: Select all
[Fri Mar 16 13:23:39 2007] [error] [client 10.0.100.121] access to / failed, reason: user 'KHS\\Administrator' does not meet 'require'ments for user/valid-user to be allowed access


was beeutet das ?
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 16. March 2007 13:37

require user KHS\visis

[Fri Mar 16 13:23:39 2007] [error] [client 10.0.100.121] access to / failed, reason: user 'KHS\\Administrator' does not meet 'require'ments for user/valid-user to be allowed access

Der Google-Übersetzter meint dazu:
Der Benutzer "KHS\Administrator" mit dem du dich anmeldest, gehört nicht zu den Benutzern ("KHS\visis"), denen der Zugang erlaubt ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 14:15

das komische ist nur das er mir diese fehlermeldung auch ausgibt wenn ich mich mit dem erlaubten Benutzer anmelde und es mit diesem versuche dann sagt er das benutzer KHS\\visis nicht dem valid-user entspricht.
kann es sein das ich da irgendwo anders nch änderungen vornehmen muss als in den von mir geposteten dateien?
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 16. March 2007 14:23

das komische ist nur das er mir diese fehlermeldung auch ausgibt wenn ich mich mit dem erlaubten Benutzer anmelde

Und wie sieht da die Fehlermeldung genau aus (+ mit welchem Benutzer meldest du dich da an)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 14:26

Code: Select all
[Fri Mar 16 13:58:19 2007] [error] [client 10.1.14.94] access to / failed, reason: user 'KHS\\VISIS' does not meet 'require'ments for user/valid-user to be allowed access


ich melde mich mit dem Benutzer KHS\Visis an

warum stehn im errorlog dort zwei \ zwichen KHS und visis, haben ja in der sspi.conf KHS\visis geschrieben
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 16. March 2007 14:35

require user KHS\visis

user 'KHS\\VISIS' does not meet 'require'ments
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests