Verzeichnisschutz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Verzeichnisschutz

Postby Dadon » 15. March 2007 08:40

Hallo liebe Apachegemeinde,
ich habe zwecks eines Intranets Xampp auf einen unserer Win 2003 Server installiert. HAt soweit alles super funktioniert.
Jedoch stehe ich jetzt vor einem Problem und zwar dem Verzeichnisschutz mit der .htaccess-datei.
Ich erläutere euch es mal an einem kleinen Beispiel:
Ihr habt ein Intranet für eine bestimmte Abteilung in eurer Firma aufgebaut.
Auf die Seiten dieses Intranets sollen auch nur die User der Gruppe "Einkauf" zugreifen können, mit ihren jeweiligen Dömain-Anmeldungen. Jetzt kommt das Problem und zwar benötigt man die Passwörter der einzelnen User.
Jedoch aus sicherheitstechnischen Gründen dürft ihr diese nicht haben.
Jetzt die Frage: Ist es möglich ohne .htaccess-datei zu arbeiten und dabei Die Benutzeranmeldung der Windows-Domäne zu benutzen so wie es auf einem IIS funktioniert?
Ich bin verzweifelt und benötige da dringend Hilfe.
Da muss es doch irgendwas geben.#

Vielen Dank im Vorraus

mfg

Dadon
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby glitzi85 » 15. March 2007 09:41

Hallo,

hab das noch nie ausprobiert, aber probiers mal so:

http://thomas-howard.com/Reference/Articles/Apache+AD/

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Dadon » 15. March 2007 10:56

Hmm danke erstmal für den Tipp, wir haben jedoch noch ne NT4 Domäne haben, daher kein AD ( hätte ich evtl. erwähnen müssen)
gibts evtl. auch ne möglichkeit das in der NT4 Domäne zu realisieren?
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 15. March 2007 11:32

Ist es möglich ohne .htaccess-datei zu arbeiten

Nur mal zur Klarstellung:
Eine ".htaccess" ist nicht direkt (grundsätzlich) für einem Verzeichnisschutz zuständig. Also:
Du kannst jede Art von Verzeichnisschutz (Passwortabfrage) mit oder ohne eine Datei ".htaccess" machen (wenn es dein Server ist).

und dabei Die Benutzeranmeldung der Windows-Domäne zu benutzen so wie es auf einem IIS funktioniert?

Du suchst nach "mod_auth_sspi".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 15. March 2007 14:13

Hallo Wiedmann,
ich habe jetzt mal mod_auth_sspi ausprobiert und es exakt wie in der anleitung installiert
wenn ich jedoch nun an dem Punkt bin wo ich den Apache neustarten soll, wird mir der Fehler ausgegeben, dass das Modul nicht in dem Ordner apache/modules sein soll, obwohl ich es selbst dort hinein kopiert habe.
Kennst du diesen fehler? oder hab ich irgenetwas nicht beachtet?
in die httpd.conf hab ich folgendes eingefügt (ausschnitt):

Code: Select all
LoadModule autoindex_color_module modules/mod_autoindex_color.so
#LoadModule mysql_auth_module modules/mod_auth_mysql.so
#LoadModule auth_remote_module modules/mod_auth_remote.so
#LoadModule sspi_auth_module modules/mod_auth_sspi.so
#LoadModule log_sql_module modules/mod_log_sql.so
#LoadModule log_sql_mysql_module modules/mod_log_sql_mysql.so
#<IfModule ssl_module>
#    LoadModule log_sql_ssl_module modules/mod_log_sql_ssl.so
#</IfModule>
#LoadModule proxy_html_module modules/mod_proxy_html.so
#LoadModule xmlns_module modules/mod_xmlns.so
#LoadModule proxy_xml_module modules/mod_proxy_xml.so
#LoadModule bw_module modules/mod_bw.so
LoadModule sspi_auth_module modules/mod_auth_sspi.so

<IfModule mod_auth_sspi.c>
Include conf/sspi.conf
</IfModule>


und die sspi.conf hab ich so editiert:
Code: Select all
<Directory "D:/xampp/xampp/htdocs/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
   
    AuthName "restricted area"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On

    require KHS\visis
</Directory>
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Dadon » 15. March 2007 14:16

liegt es vielleicht daran das ich es auf nem Win 2003 Server nutze?
weil in der Anleitung steht nur etwas von getestete Syteme Win 2k/ NT
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 15. March 2007 14:50

wird mir der Fehler ausgegeben, dass das Modul nicht in dem Ordner apache/modules sein soll,

Dann wird das jetzige Modul evtl. nicht für diesen Apachen sein.

obwohl ich es selbst dort hinein kopiert habe.

Hast du nicht einen XAMPP?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 15. March 2007 15:25

Ich habe Xampp 1.5.5 und das Modul hier her http://addons.xampp.org/cgi-bin/search.pl?pid=8
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 15. March 2007 15:45

Ich habe Xampp 1.5.5

Und da ist dir beim "obwohl ich es selbst dort hinein kopiert habe" nicht aufgefallen, dass du eine schon vorhandene Datei überschreiben musstest?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 08:49

Doch aber dachte im ersten moment, das wäre schon richtig so, naja mein fehler.
gibt es denn nun keine möglichkeit diese authentifizierung bei der xampp version 1.5.5 vorzunehmen, habe die überschriebene datei wiederhergestellt.^^
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 16. March 2007 12:02

habe die überschriebene datei wiederhergestellt.

Und was passiert jetzt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 12:15

wenn ich nun auf die seite connecten will, kommt eine login abfrage für den server, jedoch komm ich nun mit jeglichen loginnamen nicht rein. lösche oder entferne ich die modul-datei wieder aus dem ordner modules komm ich wieder ohne probs auf die seite jedoch ohne zugangsabfrage.
Irgendwas hängt da quer
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Wiedmann » 16. March 2007 12:18

kommt eine login abfrage für den server, jedoch komm ich nun mit jeglichen loginnamen nicht rein.

Was steht im "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dadon » 16. March 2007 12:21

irgendwie funktioniert das einbinden der sspi.conf nicht denk ich mir mal

Code: Select all
<IfModule mod_auth_sspi.c>
Include conf/sspi.conf
</IfModule>


was ich nicht verstehe, diese abfrage soll in die httpd.conf geschrieben werden, jedoch kann es sein das die schreibweise falsch ist, denn eine mod_auth_sspi.c kenn ich nicht sondern nur eine mod_auth_sspi.so
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Postby Dadon » 16. March 2007 12:24

im error log steht dies
Code: Select all
[Fri Mar 16 07:39:40 2007] [error] [client 10.0.100.141] access to / failed, reason: user KHS\\SKSGateway01 not allowed access
[Fri Mar 16 08:09:48 2007] [error] [client 10.0.100.141] access to / failed, reason: unknown require directive:"KHS\\visis"


Die sspi.conf sieht so aus:
Code: Select all
<Directory "D:/xampp/xampp/htdocs/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
   
    AuthName "restricted area"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIOfferBasic On

    require KHS\visis
</Directory>


KHS ist die Domäne und Visis ein ganz normaler Benutzer
Dadon
 
Posts: 12
Joined: 15. March 2007 08:26

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests