File Uploads laufen nicht mehr unter XAMPP 1.6.0a

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

File Uploads laufen nicht mehr unter XAMPP 1.6.0a

Postby farbanomalie » 14. March 2007 20:18

Hallo,

seit ich vor ein paar Tagen meine alte XAMPP-Version deinstalliert und die neue XAMPP 1.6.0a installiert habe (leider kann ich nicht mehr herausfinden, welches die alte Version war), funktionieren lokal keine Dateiuploads mehr.
In der php.ini ist alles aktiviert, was man dafür brauchen müsste. Ich habe sogar XAMPP noch einmal komplett neu installiert, weil ich dachte, dass ich vielleicht irgendeine Einstellung getan hätte, die die Fileuploads stört. Aber auch mit den Standard-Einstellungen tut sich nichts.

Hat jemand eine Idee, woran das liegen könnte? Irgendwelche Einstellungen?

Danke schon mal.
farbanomalie
 

Postby Wiedmann » 14. March 2007 20:29

Hat jemand eine Idee, woran das liegen könnte?

In 99% der Fälle liegt das an einer unsauberen Programmierung des Scriptes.

Aber auch mit den Standard-Einstellungen tut sich nichts.

Aber um einen Fehler der (Standard-) XAMPP-Installation auszuschliessen:
Tut das FileUpload Beispiel aus dem PHP-Manual?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby farbanomalie » 14. March 2007 21:50

Wiedmann wrote:In 99% der Fälle liegt das an einer unsauberen Programmierung des Scriptes.

Das dachte ich auch. Und habe deshalb mal alle alten Skripte, die einen Fileupload in sich haben, durchprobiert. Die taten in der alten Version alle und tun es auch auf dem Webserver. Aber lokal nimmer.
farbanomalie
 

Postby Wiedmann » 14. March 2007 21:53

Siehe oben:
Wiedmann wrote:Tut das FileUpload Beispiel aus dem PHP-Manual?

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby farbanomalie » 14. March 2007 22:35

Nein, die Datei wird laut $_FILES[userfile][error] zwar hochgeladen, landet aber nicht in $uploaddir.
farbanomalie
 

Postby Wiedmann » 14. March 2007 22:43

Wie sieht den die Ausgabe des Beispiel-Scriptes aus?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby farbanomalie » 14. March 2007 22:49

File is valid, and was successfully uploaded. Here's some more debugging info:
Array
(
[userfile] => Array
(
[name] => 63.jpg
[type] => image/jpeg
[tmp_name] => E:\xampp\xampp\tmp\php25.tmp
[error] => 0
[size] => 11706
)

)
farbanomalie
 

Postby Wiedmann » 14. March 2007 23:01

Wie ist denn "$uploaddir" bei dir definiert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby farbanomalie » 14. March 2007 23:27

Ah, daran lag es wohl. Hochgeladene Dateien sind alle sonstwo gelandet. Aber immerhin gelandet.

Danke für die Hilfe.
farbanomalie
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests