XAMPP 1.6.0a PHP 5.2.1 & eAccelerator

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 1.6.0a PHP 5.2.1 & eAccelerator

Postby DesMas » 09. March 2007 12:49

Moin ich wollte mir im Zuge eines Projektes den eAcceleratorim XAMPP, der ja schon drinnen ist aktivieren.

Also schwupps in der php ini die Zeilen nach [eAccelerator] von den Semikola befreit und Apache neu gestartet......
Jedoch konnte ich keinerleich Performancegewinn feststellen und auch nirgend finden, ob das nun wirklich aktiv ist oder nicht.....

ich hatte die dll auch schon mal gegen die Variante eAccelerator095_5.2.1.dll ausgetauscht, jedoch wiederum nichts positives bemerkt.....

Hat da jemand mal Hilfe für Dumme?
DesMas
 
Posts: 11
Joined: 11. August 2006 11:03

Postby DesMas » 13. March 2007 09:56

ok back to the roots, ich war wohl an der falschen stelle (falsches Verz), oder übereifrig..

gem der faq

extension=eaccelerator.dll
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "1"

auskommentiert.....

jedoch nun startet der Apache nicht wiirklich, er läuft kurz an und geht dann wieder off.

Das log sagt nur
[Tue Mar 13 09:53:05 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Mar 13 09:53:05 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null


wobei er das auch schreib wenn der accelerator auskommentiert ist.... also kommt das nicht von dem

PS:
so sieht die php.ini aus, wenn nicht funktioniert:
;.....
[eAccelerator]
extension=eaccelerator.dll
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "C:\Programme\xamp\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "0"
;eaccelerator.debug = "0"
;eaccelerator.check_mtime = "1"
;eaccelerator.filter = ""
;eaccelerator.shm_max = "0"
;eaccelerator.shm_ttl = "0"
;eaccelerator.shm_prune_period = "0"
;eaccelerator.shm_only = "0"
;eaccelerator.compress = "1"
;eaccelerator.compress_level = "9"
;eaccelerator.keys = "shm_and_disk"
;eaccelerator.sessions = "shm_and_disk"
;eaccelerator.content = "shm_and_disk"
;eaccelerator.admin.name =
;eaccelerator.admin.password =

[Zend]
zend_extension_ts = "C:\Programme\xamp\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\Programme\xamp\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
zend_optimizer.license_path =

; Local Variables:
; tab-width: 4
; End:
DesMas
 
Posts: 11
Joined: 11. August 2006 11:03

Postby DesMas » 13. March 2007 11:06

OK habe eine neue dll gefunden...

eAccelerator095_i284_5.2.1.dll


und die ini angepasst
[eAccelerator]
extension=eAccelerator095_i284_5.2.1.dll
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "C:\Programme\xamp\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "1"
;eaccelerator.debug = "0"
;eaccelerator.check_mtime = "1"
;eaccelerator.filter = ""
;eaccelerator.shm_max = "0"
;eaccelerator.shm_ttl = "0"
;eaccelerator.shm_prune_period = "0"
;eaccelerator.shm_only = "0"
;eaccelerator.compress = "1"
;eaccelerator.compress_level = "9"
;eaccelerator.keys = "shm_and_disk"
;eaccelerator.sessions = "shm_and_disk"
;eaccelerator.content = "shm_and_disk"
;eaccelerator.admin.name = "root"
;eaccelerator.admin.password = ""

[Zend]
zend_extension_ts = "C:\Programme\xamp\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\Programme\xamp\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
zend_optimizer.license_path =

; Local Variables:
; tab-width: 4
; End:


damit startet der Apache und bleibt auch aktiv.

allerdings scheints ada immer noch probs zu geben:
Wenn ich auf der Kommandozeile z.B. php eingebe bekomme ich
PHP Warning: [eAccelerator] This build of "eAccelerator" was compiled for
ersion 5.2.0. Rebuild it for your PHP version (5.2.1) or download precompi
naries.
in Unknown on line 0
PHP Fatal error: Unable to start eAccelerator module in Unknown on line 0

crazy
DesMas
 
Posts: 11
Joined: 11. August 2006 11:03


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests