.htaccess: Mal funktioniert es, mal nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

.htaccess: Mal funktioniert es, mal nicht

Postby drosan » 02. March 2007 16:38

Hallo,
ich habe ein Problem. Ich habe eine .htacess im normalen htdocs Ordner. Diese läuft ohne Probleme.
Weiterhin habe ich eine weitere Partition mit einem Alias "belegt", damit dort der Apache dort auch PHP versteht.

Nun wollte ich dort auch eine htaccess benutzen, mit folgenden Inhalt:

Options -Indexes

Dies klappt allerdings nicht. Ich bekomme im Error.log folgende Meldung:

[Fri Mar 02 16:32:41 2007] [alert] [client 127.0.0.1] L:/.htaccess: Options not allowed here

PHP Dateien funktionieren im selben Verzeichnis allerdings... oO
Woran kann das liegen?

Grüße, drosan
drosan
 
Posts: 21
Joined: 22. February 2007 17:37

Postby KingCrunch » 02. March 2007 21:41

drosan wrote:[Fri Mar 02 16:32:41 2007] [alert] [client 127.0.0.1] L:/.htaccess: Options not allowed here
;)

Da werden wohl Optionen in der .htaccess genutzt, die an der Stelle nicht erlaubt sind ;)

Zeig am Besten mal deine .htaccess und die Verzeichnis-Definition für das betroffene Verzeichnis
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby drosan » 02. March 2007 22:39

Den Inhalt der htacess hatte ich oben ja schon genannt:

Options -Indexes

ich hab es auch schon mit einem Passwortschutz versucht. Dort kommt die selbe Meldung.

Hier die Verzeichnisdefinition:

Alias /web "L:/"
<Directory "L:/">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
drosan
 
Posts: 21
Joined: 22. February 2007 17:37

Postby KingCrunch » 02. March 2007 22:48

Ah, stimmt, habs oben übersehen.
drosan wrote:Options -Indexes

drosan wrote:Alias /web "L:/"
<Directory "L:/">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
Hab den spannenden Teil mal hervor gehoben. Wie gesagt ist der Befehl aus der .htaccess schlicht und ergreifend nicht erlaubt. AllowOverride erlaubt bei dir nur die Änderung für AuthConfig. Entweder ersetzt du die Zeile durch
Code: Select all
AllowOverride All

damit erlaubst du, dass alles auch per .htaccess überschrieben werden kann, oder durch die Zeile
Code: Select all
AllowOverride AuthConfig Indexes
Naja, selbstredend ^^ Möglicherweise gehört da auch ein Komma dazwischen, bin da grad nich so standfest ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby drosan » 03. March 2007 00:40

Vielen Dank für die ausführliche Antwort. :)
Hat ohne Probleme geklappt. Danke & Gute Nacht! :)
drosan
 
Posts: 21
Joined: 22. February 2007 17:37


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests