Kleiner Bug in Version 1.0 => MySQL als Dienst

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kleiner Bug in Version 1.0 => MySQL als Dienst

Postby kvo » 05. September 2003 17:10

Wer MySQL als Dienst (Service) über die "mysql_installservice.bat" installiert, hat zwar automatisch und korrekt eine C:\my.cnf zu liegen, die aber fehlerhaft ist:

1) Unbedingt die Zeile
innodb_data_file_path=ibdata1:30M
entkommentieren mit Raute (#) also:
# innodb_data_file_path=ibdata1:30M

2) Die C:\my.cnf braucht absolute Pfade, wenn der xampp auf einer anderen Partition liegt.

Eine Beispielkonfiguration einer C:\my.cnf (geeignet für NT), wo das xampp paket unter D:\xampp liegt, wäre:

# The MySQL client
[client]
#password = your_password
port = 3306
socket =D:/xampp/mysql/mysql.sock

# The MySQL server
[mysqld]
port = 3306
socket = D:/xampp/mysql/mysql.sock
skip-locking
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
log-bin
server-id = 1

basedir=D:/xampp/mysql
tmpdir=D:/xampp/tmp
datadir=D:/xampp/mysql/data

#bind-address=192.168.1.1
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable = bdb_cache_size=4M
#set-variable = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = D:/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = D:/xampp/mysql/
#innodb_log_arch_dir = D:/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=D:/xampp/mysql/bin/mysqld-nt.exe


Sorry! Ich werde diesen Fehler im Paket 1.0 alsbald beseitigen.

Euer
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests