XAMPP 1.6.0a unter Vista

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 1.6.0a unter Vista

Postby slackero » 26. February 2007 14:21

Hi,

mir ist folgende Anomalie unter Windows Vista (32Bit) aufgefallen:
(auch schon bei 1.5.5 und 1.6.0)

Die Änderung der Einstellungen in der Datei
Code: Select all
Configuration File (php.ini) Path C:\Program Files\xampp\apache\bin\php.ini

haben nach Neustart des Apache keinerlei Auswirkung auf die PHP Konfiguration.

Es ist immer nur der Standard nutzbar.

Dass das Control Panel nicht nutzbar ist, nur am Rande. Es bleibt also nur, Dienste entweder gleich beim Systemstart mitstarten zu lassen oder aber manuell anzustoßen.

Oliver
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby Wiedmann » 26. February 2007 14:44

Mangels Vista kann ich da nur raten:
Da hat die Dateivirtualisierung zugeschlagen.

Ich würde den XAMPP nochmal neu in C:\ installieren (c.\xampp).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingCrunch » 27. February 2007 21:30

Nich gecheckt, aber isses denn die richtige php.ini? (phpinfo bringt auskunft)

Ansonsten: Ebenfalls mangels Vista keine weitere Idee
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby slackero » 27. February 2007 22:35

es ist die richtige php.ini.

An einer Neuinstallation bin ich nicht wirklich interessiert. Das hatte ich schon nach dem Upgrade auf Vista versucht. Ohne Erfolg. Allerdings habe ich es auch im Programme Verzeichnis installiert.

Es muss doch eine Lösung geben?

Ich habe dem XAMPP Verzeichnis alle Zugriffsrechte gegeben.

Oliver
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby KingCrunch » 27. February 2007 22:44

Was Wiedmann meinte, scheint scho interessant zu sein. Schau doch mal, ob du etwas findest, wie man die Virtualiserung verzeichnisweise deaktiviert.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby slackero » 27. February 2007 22:54

Ihr meint sicher UAC - indem ich mir Vollzugriff gegeben habe, sollte das kein Thema mehr sein.

Ich muss das in einer ruhigen Minute noch mal probieren...
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby Bata » 08. March 2007 21:49

Nicht UAC, das ist die User Account Control

Mit Virtualisierung ist gemeint, das zwar Dein Ordner Programme heisst, das aber nur so angezeigt wird. In Wirklichkeit heisst er Program Files...
Bata
 
Posts: 7
Joined: 08. March 2007 18:11

Postby slackero » 08. March 2007 22:55

Ja weiß ich doch - siehe meine Pfadbeschreibung weiter oben.

Ist ja ein alter Hut, ist halt nun wie beim Mac ;-)
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby Wiedmann » 08. March 2007 22:57

Ist ja ein alter Hut, ist halt nun wie beim Mac

Von was redest du genau?

BZW. Weist du wirklich was die Dateivirtualisierung von Vista macht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby slackero » 09. March 2007 08:15

Ich vermute mal ja, aber ich mag mich natürlich auch irren.

Da dies aber soweit ich nachvollziehen kann, eben vor allem eine Frage der nötigen Rechte ist, dürfte das normalerweise nicht das Problem sein.

Wie gesagt - ist jetzt nicht mehr so wichtig.

So funktioniert es:
Eingabeaufforderung -> "Als Administrator ausführen" und dann dort die php.ini editieren "edit".
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby Bata » 09. March 2007 10:05

Ja Stop, läuft es jetzt bei dir? Wenn ja bitte mal eine Anleitung was du alles wo geschraubt hast!!

Danke
Bata
 
Posts: 7
Joined: 08. March 2007 18:11

Postby slackero » 09. March 2007 11:17

Also als erstes habe ich versucht schlichtweg die Rechte des gesamten XAMPP Ordners so zu ändern, dass auch der "Nicht-Admin-User" alle Rechte erhält.

Rechte Maustaste -> Eigenschaften auf dem Ordner -> Reiter Sicherheit und dann den User gewählt -> Bearbeiten und Vollzugriff. Es dauert eine ganze Weile ehe Vista alle Rechte angepaßt hat - aber dann greift die Dateivirtualisierung nicht mehr.

Zum Editieren der jeweiligen INI-Dateien muss man - zumindest so meine Erfahrung - die "Eingabeaufforderung" als Administrator starten. Siehe mein Post weiter oben. Dann greifen nach Neustart der Dienste auch die Änderungen in der php.ini.

Für die Zukunft ist sicher sinnvoll, die Installation von XAMPP so anzupassen, dass zumindest der htdocs Ordner aus dem Benutzer-Ordner/Dokumente geladen wird.
slackero
 
Posts: 7
Joined: 04. February 2004 06:27

Postby martinpre » 09. March 2007 21:50

slackero wrote:Für die Zukunft ist sicher sinnvoll, die Installation von XAMPP so anzupassen, dass zumindest der htdocs Ordner aus dem Benutzer-Ordner/Dokumente geladen wird.


Denke daran, dass Xampp auch portabel nutzbar sein soll und zB auch für mehrere User. Außerdem kann sich ja jeder das DocumentRoot selbst einstellen ...
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests