XSLT-Processor verursacht absturz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XSLT-Processor verursacht absturz

Postby TriggerTG » 17. February 2007 13:36

Hallo,

ich habe die neuste XAMPP-Version frisch installiert (Windows XP).
Folgendes PHP-Script lässt den Apache abstürzen:

Code: Select all
<?php
$xsltproc = new XsltProcessor();

// DOM Dokument initiieren und xsl-datei laden
$xsl = new DomDocument;
$xsl->load('xsl/default/style.xsl');
$xsltproc->importStylesheet($xsl);

// DOM initiieren und xml-datei laden
$xml_doc = new DomDocument;
$xml_doc->load('xml/guestbook.xml');

// Parameter  setzen (namespace, parameter, wert)
// Arrays werden erst am Version 5.1x unterstützt
//$xsltproc->setParameter('', 'parameter', 'wert');

// Transformation
if ($html = $xsltproc->transformToXML($xml_doc)) {
   echo $html;
}
else
{
    trigger_error('XSL transformation failed.',E_USER_ERROR);
}
?>


soweit ich es beurteilen kann, stürzt der apache immer ab, sobald ich den XsltProcessor() initialisiere (oder DomDocument()).



Die Fehlermeldung ist:

Die Anweisung "[..]" verweist auf Speicher in "[..]". Der Vorgang read konnte nicht auf dem Speicher durchgeführt werden.

Die errorlog meint:

Sat Feb 17 13:29:32 2007] [notice] Server built: Sep 30 2006 21:24:06
[Sat Feb 17 13:29:32 2007] [notice] Parent: Created child process 3012
[Sat Feb 17 13:29:39 2007] [notice] Child 3012: Child process is running
[Sat Feb 17 13:29:39 2007] [notice] Child 3012: Acquired the start mutex.
[Sat Feb 17 13:29:39 2007] [notice] Child 3012: Starting 250 worker threads.
[Sat Feb 17 13:29:39 2007] [notice] Child 3012: Starting thread to listen on port 443.
[Sat Feb 17 13:29:39 2007] [notice] Child 3012: Starting thread to listen on port 80.
[Sat Feb 17 13:34:46 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sat Feb 17 13:34:51 2007] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 mod_perl/2.0.2 Perl/v5.8.8 configured -- resuming normal operations
[Sat Feb 17 13:34:51 2007] [notice] Server built: Sep 30 2006 21:24:06
[Sat Feb 17 13:34:51 2007] [notice] Parent: Created child process 2912
[Sat Feb 17 13:34:57 2007] [notice] Child 2912: Child process is running
[Sat Feb 17 13:34:57 2007] [notice] Child 2912: Acquired the start mutex.
[Sat Feb 17 13:34:57 2007] [notice] Child 2912: Starting 250 worker threads.
[Sat Feb 17 13:34:58 2007] [notice] Child 2912: Starting thread to listen on port 443.
[Sat Feb 17 13:34:58 2007] [notice] Child 2912: Starting thread to listen on port 80.
[Sat Feb 17 13:35:00 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sat Feb 17 13:35:03 2007] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 mod_perl/2.0.2 Perl/v5.8.8 configured -- resuming normal operations
[Sat Feb 17 13:35:03 2007] [notice] Server built: Sep 30 2006 21:24:06
[Sat Feb 17 13:35:03 2007] [notice] Parent: Created child process 5260
[Sat Feb 17 13:35:08 2007] [notice] Child 5260: Child process is running
[Sat Feb 17 13:35:08 2007] [notice] Child 5260: Acquired the start mutex.
[Sat Feb 17 13:35:08 2007] [notice] Child 5260: Starting 250 worker threads.
[Sat Feb 17 13:35:08 2007] [notice] Child 5260: Starting thread to listen on port 443.
[Sat Feb 17 13:35:08 2007] [notice] Child 5260: Starting thread to listen on port 80.
mfg,
triggerle
TriggerTG
 
Posts: 7
Joined: 16. March 2003 11:07

Postby TriggerTG » 17. February 2007 15:56

Okay Lösung gefunden:

Die aktuelle PHP-Version behebt das Problem. Ich habe einfach das aktuelle package* geladen und - bis auf die php.ini - mit den alten dateien ersetzt.


*http://www.php.net/get/php-5.2.1-Win32.zip/from/a/mirror

e\ achso, laut php.net war das wohl irgendeinfehler in der libxml o.Ä.
mfg,
triggerle
TriggerTG
 
Posts: 7
Joined: 16. March 2003 11:07


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests