localhost/index.php nach neuinstallation: error 500

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

localhost/index.php nach neuinstallation: error 500

Postby Kataklysm666 » 12. February 2007 13:13

Hi,

Hab nichts konkretes zu meinem Problem gefunden an Search-Post-Anhänger!!
Bin noch relativ neu in sachen PHP und xampp.
Ich hatte warscheinlich das MySQL User/PW geändert und nach vielem Suchen und ändern konnte ich trotzdem nicht auf phpmyadmin zu greifen...

Habe dann irgendwo den Post gelesen, das ich am wenigsten Stress hätte xampp neu zu installieren. Gesagt, getan.

http://localhost/ was normalerweise ja auf ../xampp/ verweist gibt mir nun den Serverfehler... error500 aus.

Meine PHP Scripte die ich wieder rein kopiert habe funktionieren jedoch einwandfrei.

Doch denke ich phpmyasmin zu brauchen. Würde mich gerne in MySQL einarbeiten und alle Funktion von XAMPP nutzen.

Kennt jemand ne schnelle "einfache" Lösung oder soll ich erneut neu installieren?

Danke im vorraus
User avatar
Kataklysm666
 
Posts: 8
Joined: 17. January 2007 19:10

Postby Wiedmann » 12. February 2007 14:05

error 500

Im "error.log" steht, was diesen Fehler auslöst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kataklysm666 » 12. February 2007 19:22

Hi,

../xampp/apache/logs/error.log
liefert:

[alert] [client 127.0.0.1] C:/Programme/xampp/htdocs/xampp/.htaccess: Invalid file path C:\\ProgrammeC:\\Programme\\xampp\\security\\xampp.users

Das doppelte C:\\Programme is ja wohl verkehrt aber wieso steht das dort??
Kann ich das irgendwo korrigieren oder erneute neuinstallation?
User avatar
Kataklysm666
 
Posts: 8
Joined: 17. January 2007 19:10

Postby Wiedmann » 12. February 2007 19:56

Kann ich das irgendwo korrigieren

Yup. In welcher Datei das falsch drinsteht, steht ja auch in der Fehlermeldung...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kataklysm666 » 13. February 2007 01:18

Danke, das hat geklappt.

Jetzt jedoch: [Tue Feb 13 01:18:03 2007] [error] [client 127.0.0.1] (OS 2)Das System kann die angegebene Datei nicht finden. : Could not open password file: C:/Programme/xampp/security/xampp.users

die datei existiert nirgends....
User avatar
Kataklysm666
 
Posts: 8
Joined: 17. January 2007 19:10

Postby Wiedmann » 13. February 2007 01:27

die datei existiert nirgends....

Dann hast du sie gelöscht...

... oder du hast das "htdocs/xampp" Verzeichnis aus einem Backup wiederhergestellt auf einem frischen XAMPP? In dem Fall lösche einfach die ".htaccess".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kataklysm666 » 13. February 2007 01:42

ohh stimmt: hatte htdocs verzeichnis nicht mitgelöscht...

XAMPP zeigt er mir nun wieder an doch phpmyadmnin geht immernoch nicht.


Fehler

MySQL meldet:
Die Verbindung konnte aufgrund von ungültigen Einstellungen nicht hergestellt werden.
User avatar
Kataklysm666
 
Posts: 8
Joined: 17. January 2007 19:10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests