CSS Fehler in der PHPMyAdmin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

CSS Fehler in der PHPMyAdmin

Postby Mythology » 19. January 2007 15:41

Hallo,

bin etwas verzweifelt, da ich seit heute morgen ein sehr hartnäckiges Problem habe. Gestern hat noch alles wunderbar funktioniert und ich bin mir keiner Änderung bewusst, die ich vorgenommen haben könnte.

Also:

Ich hab XAMPP auf einem XP rechner installiert. Wenn ich von diesem Rechner die PHPMyAdmin aufrufe läuft alles Problemlos. (Unter Firefox 2.0)

Wenn ich aber die PHPMyAdmin von einem anderen Rechner im Netzwerk aufrufe, wird (seit heute Morgen) der CSS Style im Content Frame nicht richtig eingefügt. Gestern hat das alles auch noch wunderbar funktioniert.

Es ist jetzt nicht so, dass das CSS Syle überhaupt nicht gefunden wird, sonder es wird teilweise gefunden. so ca. nach jedem 4-6 Seitenaufruf. Mir kommt es so vor als wird das CSS manchmal auch nur teilweise umgesetz, so sind zum Beispiel die icons richtig formatiert, die tabs werden aber nach wievor als liste angezeigt. Selten wird es auch komplett richtig angezeigt.

Folgendes habe ich unternommen um das Problem in den Griff zu bekommen:

- XAMPP neuinstalliert
- Firefox auf den PCs neuinstalliert
- Ältere PHPMyADmin Version installiert.

Geholfen hat das aber nicht. Nach wievor wird auf dem Server alles richtig angezeigt und auf anderen Rechnern treten oben genannte Phänomene auf.

Ich hoffe Ihr könnt mir helfen!
Leider hab ich keinen ähnlichen dokumentierten Fehlerbericht gefunden.
Mythology
 
Posts: 4
Joined: 19. January 2007 15:23

Postby deepsurfer » 19. January 2007 16:27

Benutzt du die Aktuelle XAMPP-Version oder eine Version 1.4.xx ?

Wenn du die Aktuelle benutzt, so editiere mal die httpd.conf und füge an letzter stelle folgendes Wort ein:
Win32DisableAcceptEx

Abspeichern, xampp-apache neu starten, testen und melden.


Solltest du einen XAMPP vor 1.5x benutzen (also alle 1.4.x abwärts)
So schau dort in der httpd.conf nach:

#EnableMMAP off
#EnableSendfile off
und
#Win32DisableAcceptEx

bei allen drei die raute entfernen, abspeichern, xampp-apache neu starten, testen und melden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mythology » 19. January 2007 17:29

Ich benutze die Version 1.5.5

Ich hab die httpd.conf bearbeitet. Alles neugestartet, aber der Fehler tritt immer noch auf.

Ich verstehs eben nicht weil es sonst auch immer funktioniert hat und ich gestern den ganzen Tag mit gearbeitet hab.
Mythology
 
Posts: 4
Joined: 19. January 2007 15:23

Postby deepsurfer » 20. January 2007 00:32

lösche mal deinen Browser-Cache.

Kannst den zusatz in der httpd.conf wieder löschen (neustart apache dann durchführen, damit Änderung wieder angenommen wird)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mythology » 20. January 2007 13:05

Ich hab den Cache schon mehrfach gelöscht, hab ja sogar auch den Browser neu installiert, um hier die Fehlerquelle auszuschließen.

Im IE auf dem nicht Server bekomme ich sogar den Content Frame überhaupt nicht angezeigt. (Seite nicht gefunden)

Im IE auf dem Server findet er die Seite manchmal auch nicht.

Grüße

Denis
Mythology
 
Posts: 4
Joined: 19. January 2007 15:23

Postby deepsurfer » 20. January 2007 13:23

So...nun kommt der berühmte umkehr weg (schielt zu Wiedmann rüber):

In der httpd.conf die

EnableMMAP off
EnableSendfile off


jeweils eine raute davor setzen (auskommentieren), abspeichern, apache neu starten, testen und melden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mythology » 21. January 2007 14:42

auch diese veränderung scheint leider nichts zu verändern. (hab auch brav den cache gelöscht).
Mythology
 
Posts: 4
Joined: 19. January 2007 15:23

Postby sari42 » 26. January 2007 15:36

irgendwas im apache error log?
meistens verhindern irgendwelche win security setting den zugriff auf einige pfade aus php.ini (upload_tmp_dir, session.save_path z.b.)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests