Fehlermeldung bei Aufrufen von XAMPP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung bei Aufrufen von XAMPP

Postby hutchy71 » 19. January 2007 14:29

Hallo, bin neu hier, nach der Installation von XAMPP kommt folgende Fehlermeldung:


Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: No such file or directory in C:\Programme\xampp\htdocs\xampp\index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at C:\Programme\xampp\htdocs\xampp\index.php:2) in C:\Programme\xampp\htdocs\xampp\index.php on line 4

Einer eine Idee wo es dran liegen oder wie mans beheben kann, hatte XAMPP schon einmal am laufen, hab bis auf die Sicherheit nix verstellt, nun klappst nicht mehr...?
hutchy71
 
Posts: 3
Joined: 19. January 2007 14:21

Postby deepsurfer » 19. January 2007 14:58

Du hast ein Systemprogramm am laufen gehabt das dir so genannte TEMPfiles von der Platte löschen soll.

Eben dieses Programm hat die lang.tmp von XAMPP gelöscht.

rufe http://localhost/xampp/langsettings.php auf.
Wähle erneut deine Sprache, damit wird eine neue lang.tmp erstellt und der XAMPP-Willkommenscreen funktioniert wieder.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hutchy71 » 19. January 2007 17:26

Ja stimmt, hab so ein Reinigungsprogramm zwischenzeitlich laufen lassen. Dein Lösungsvorschlag klingt auch logisch, nur wenn ich den von Dir eingegebenen Pfad eingebe, passiert nichts, d. h. ich komme in kein Menü, wo ich die Sprache einstellen kann ? der php code in dem file sieht so aus:

<?php
$lang=@file_get_contents("lang.tmp");
@include("lang/languages.php");
@include("lang/en.php");
@include("lang/$lang.php");
if($lang=="zh")
{
header("Content-Type: text/html; charset=gb2312");
}
else if($lang=="jp")
{
header("Content-Type: text/html; charset=shift-jis");
}
?>
hutchy71
 
Posts: 3
Joined: 19. January 2007 14:21

Postby deepsurfer » 20. January 2007 00:29

upppss... sorry, mein fehler...

http://localhost/xampp/lang.php

habs soeben gegengecheckt, damit funktioniert es.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hutchy71 » 20. January 2007 07:10

Supi! Hat Geklappt! Vielen Dank! :-)
hutchy71
 
Posts: 3
Joined: 19. January 2007 14:21


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests