VHost eingestellt danach keinen mucks mehr von apache

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

VHost eingestellt danach keinen mucks mehr von apache

Postby Dothacker » 15. January 2007 09:45

morgen

hab meinen vhost mal eingestellt (sufu benutzt) und hab alles so gemacht und verglichen mit anderen beiträgen aus dem forum. aber nun hab ich ein problem ist das # bei den einträgen in der httpd-vhosts drinne läuft apache aber ist das # drausen startet apache nicht und starte ich ihn unter dem apache-start.bat kommt dies hier

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
Syntax error on line 20 of C:/Server Sql/xampp/apache/conf/extra/httpd-vhosts.co
nf:
DocumentRoot takes one argument, Root directory of the document tree

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


jetzt weis ich nicht was grad in der http-vhosts los is und wieso es nicht klappt hier ma die ganze zum durchlesen

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
ServerAdmin webmaster@localhost
DocumentRoot C:/Server Sql/xampp/htdocs
<Directory "c:/Server Sql/xampp/htdocs">
AllowOverride All
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName chaosrebelion.de.ms
ServerAlias chaosrebelion
ServerAdmin dothacker2@web.de
DocumentRoot c:/Server Sql/xampp/htdocs
<Directory "c:/Server Sql/xampp/htdocs">
AllowOverride All
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


hab auch ma was probiert und der server läuft :( das is merkwürdig

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
ServerAdmin webmaster@localhost
# DocumentRoot C:/Server Sql/xampp/htdocs
<Directory "c:/Server Sql/xampp/htdocs">
AllowOverride All
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName chaosrebelion.de.ms
ServerAlias chaosrebelion
ServerAdmin dothacker2@web.de
# DocumentRoot c:/Server Sql/xampp/htdocs
<Directory "c:/Server Sql/xampp/htdocs">
AllowOverride All
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


kann mir jemand helfen was das sein könnte und dieses problem mit mir zu lösen?
Dothacker
 
Posts: 11
Joined: 15. January 2007 09:23

Postby KingCrunch » 15. January 2007 10:01

Syntax error on line 20 of C:/Server Sql/xampp/apache/conf/extra/httpd-vhosts.co
nf:
Zeile 20:
Code: Select all
DocumentRoot c:/Server Sql/xampp/htdocs

DocumentRoot takes one argument, Root directory of the document tree


Oder wem das Rätselraten leid is: In der Pfadangabe ist ein Freizeichen, weswegen der Apache (logisch korrekt) annimmt, dass es sich um zwei Argumente handelt. Nun darf aber beim Doc-Root nur ein Argument stehn ;)

Setz die Pfadangabe mal in Anführungszeichen ("..."). Der Apache dürfte damit eigentlich umgehen können, habs aber nie ausprobiert, bot sich bisher nich an ^^
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Dothacker » 15. January 2007 10:13

Setz die Pfadangabe mal in Anführungszeichen ("..."). Der Apache dürfte damit eigentlich umgehen können, habs aber nie ausprobiert, bot sich bisher nich an ^^


hmm das mit den ("...") vor der pfad angabe bringt es glaub ich ;)

steht bei mir jetzt so
DocumentRoot "C:/Server Sql/xampp/htdocs"


danke werd es gleich ma an einen 2 rechner testen obs auch wirklich online ist. bin wirklich schon am verzweifeln :(


edit: leider geht es nicht das ich die seite auf meinen 2 rechner aufrufen kann

die domain dazu ist www.chaosrebelion.de.ms

bin erlich jetzt wieder am verzweifeln :(
Dothacker
 
Posts: 11
Joined: 15. January 2007 09:23

Postby KingCrunch » 15. January 2007 15:56

Die beiden Rechner befinden sich im selben Netzwerk und die Adresse wird extern über dein DynDNS-Dienst bereit gestellt? Kann nicht klappen, liegt an Routing-Regeln eines Netzwerks und ist insofern auch nicht lösbar ;) Du kannst es etwas umgehen, indem du die Adresse direkt der IP des Server in der HOSTS-Datei aller Rechner im Netzwerk einträgst.

Im Endeffekt ist das Problem: Du kannst keine Adresse aufrufen, die zunächst ausserhalb des Netzwerks führt und von dort aus wieder in das Netzwerk zurück umgeleitet wird.

Aber: Wenn der erste Rechner auf sich bzw von du vom zweiten Rechner über die IP auf den ersten Rechner zugreifen kannst, dann läuft es ja schonmal soweit ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests