Newbie: PHP-Skripte werden gar nicht ausgeführt...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Newbie: PHP-Skripte werden gar nicht ausgeführt...

Postby sunnymay » 14. January 2007 15:08

ich probiere jetzt schon seit Stunden rum und es tut sich gar nichts...

ich hoffe ihr könnte mir helfen.

Wenn ich die php-Seite unter dem IE aufrufe, dann fragt er, ob ich die Datei öffnen oder speichern will :(

Wenn ich die php-Seite unter Opera aufrufe, dann ist der gesamte Quellcode sichtbar :(

Das passiert allerdings nicht nur bei meinen selbst geschriebenen, sondern auch den mitgelieferten php-Dateien.

Laut XAMPP ist die Installation allerdings erfolgreich verlaufen. Ich frage mich gerade nur, ob es falsch war das ganze nicht unter dem C-Laufwerk zu installieren...

Danke schonmal im Vorraus für eure Hilfe,

sunnymay
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby Wiedmann » 14. January 2007 15:18

Laut XAMPP ist die Installation allerdings erfolgreich verlaufen.

Wie hast du denn den XAMPP genau installiert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sunnymay » 14. January 2007 15:20

7-zip selbstextrahierendes Archiv
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby Wiedmann » 14. January 2007 15:33

Schön, jetzt wissen wir mit was du XAMPP installiert hast.

Aber immer noch nicht wie. (die genauen Schritte die du unternommen hast)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sunnymay » 14. January 2007 15:45

ich habe das ganze nach ins H-Laufwerk extrahiert, ist jetzt schon etwas her und habe leider keine Anleitung mitgeschrieben...
Ich bin halt die Schritte durchgegangen die vorgegeben waren, genauer weiß ich es jetzt leider nicht mehr...

ich hoffe ihr könnt mir trotzdem Tipps geben, was ich machen kann...

Gruß, Sunnymay
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby sari42 » 15. January 2007 16:27

rufst du denn auch die scripte mit http://localhost/pfadZumScript/script.php auf?
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby sunnymay » 19. January 2007 19:35

ja natürlich!

was kann ich denn eurer Meinung nach abchecken um rauszufinden woran das liegt?
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby sunnymay » 19. January 2007 22:36

ich habe jetzt nocheinmal neu installiert und

file://localhost/C:/Programme/xampp/htdocs/index.php

aufgerufen. Dabei wird mir dann nur folgendes angezeigt:

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(

Aber wie finde ich denn jetzt heraus woran das liegt und wie ich das beheben kann? Ich hoffe wirklich ihr könnt mir irgendwie helfen...

Danke, sunnymay
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby Wiedmann » 19. January 2007 22:46

ich habe jetzt nocheinmal neu installiert und

file://localhost/C:/Programme/xampp/htdocs/index.php

aufgerufen. Dabei wird mir dann nur folgendes angezeigt:

Die "readme_de.txt" hast du gelesen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sunnymay » 19. January 2007 23:12

ja, habe ich

worauf willst du hinaus? Vielleicht habe ich ja gerade ein Brett vorm Kopf...

Falls du auf den Aufruf anspielst... mit http://localhost/C:/Programme/xampp/htdocs/index.php komme ich auch nicht weiter. Da bekomme ich eine Meldung das der Zugriff verweigert wird...
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53

Postby sari42 » 19. January 2007 23:29

>ja natürlich!
soso

und was ist mit ist http://localhost/index.php

?
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby sunnymay » 20. January 2007 01:40

das war echt ein großes Brett...

ich bin dann doch noch selbst drauf gekommen

trotzdem danke :-)
sunnymay
 
Posts: 9
Joined: 14. January 2007 14:53


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests