Kein Zugriff auf MySQL DB's mit Passwort

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kein Zugriff auf MySQL DB's mit Passwort

Postby luke7479 » 12. January 2007 03:35

Hallo alle zusammen.

Ich habe das Problem, dass ich mit "root" (ohne PW) vollen Zugriff auf alle Funktionen erhalte. Vergebe ich aber "root" ein PW, oder mache ich mir einen User "test" mit PW "test", dann hab ich plötzlich keinen Zugriff mehr.

Wär alles nicht so tragisch, wenn ich nicht eine Apllikation hätte, die es nicht unterstützt ohne Passwort zu laufen.

Heute Mittag ging noch alles. Ich wollte dann die Userliste aufräumen und alle schön brav Passwort schützen, weil ich meinen Homeserver öffentlich zugänglich machen wollte und habe dabei ausversehen den User "PMA" gelöscht. Seit diesem Moment habe ich mit Passwort keinen Zugriff mehr auf die Datenbanken.

Mittlerweile hab ich Xampp 3 mal neuinstalliert, vor und nach jeder de- / installation neu gestartet, aber alles ohne Erfolg. Anfangs hatte ich die neuste Version (1.5.5) von Xampp installiert, bin aber momentan auf 1.5.0, weil ich mir anders nicht mehr zu helfen wusste.

Momentane konfiguration:
User: root
PW:
------
User: test
PW: test

Ich hab von dem Programm aus keinen Zugriff und von meinem kleinen Testskript auch nicht:
Code: Select all
<?php
//if (isset $POST_name) {
   include "wcf\config.inc.php";
   $_dbUser = "test";
   $_dbPassword = "test";

   if ($verbindung = mysql_connect ($dbHost, $_dbUser, $_dbPassword)) {
      $connect = "<img src=\"green.jpg\">";
      } else {
      $connect = "<img src=\"red.jpg\">" . mysql_error();
      }
      if (!mysql_query ("USE kdv_realmd;")) {
      $realmd = "<img src=\"red.jpg\">" . mysql_error();
      } else {
      $realmd = "<img src=\"green.jpg\">";
      }
      mysql_query ("INSERT INTO account (username, password, email) VALUES ('$POST_name', '$POST_pass', '$POST_email');");
      if (!mysql_query ("USE kdv_wcf;")) {
      $forum = "<img src=\"red.jpg\">".mysql_error();
      } else {
      $forum = "<img src=\"green.jpg\">";
      }
      mysql_query ("INSERT INTO wcf1_user (username, email, password) VALUES ('$POST_name', '$POST_email', '$POST_pass');");
echo "<html><body><table align=\"center\">
     <tr><td colspan=\"2\">Account erstellen</td></tr>
     <tr><td>MySQL Verbindung:</td><td> $connect </td></tr>
     <tr><td>Gameaccount angelegt:</td><td> $realmd </td></tr>
     <tr><td>Forenaccount angelegt:</td><td> $forum </td></tr>
     </table></body></html>";
mysql_close ($verbindung);
?>


Ich bin für jeden Tip dankbar. Ich such jetzt mittlerweile fast 12 Stunden nach dem Problem und hoffe, dass ich nur den Wald vor lauter Bäumen nicht mehr sehe. :shock:

Kleiner Anhang noch: Das Ganze läuft auf Win 2003 Server, falls das irgendwie von Interesse sein sollte.
luke7479
 
Posts: 8
Joined: 18. January 2006 17:00

Postby deepsurfer » 12. January 2007 04:00

Du beschreibst das du schon mehrmals den XAMPP De- und wieder Installiert hast. Ähnliche Probleme hatten auch andere User und nachdem mal der PC (Server) komplett neu gestartet hatte, war das Problem behoben.

Was sicherlich Sinn macht, da damit alle Speicherinhalte und gecachte Vorgänge gelöscht werden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 12. January 2007 04:15

Ich habe das Problem, dass ich mit "root" (ohne PW) vollen Zugriff auf alle Funktionen erhalte. Vergebe ich aber "root" ein PW, oder mache ich mir einen User "test" mit PW "test", dann hab ich plötzlich keinen Zugriff mehr.

und wie vergibts du die Passwörter, wie hast du den User erstellt? (genaue Vorgehensweise!)

(Mit dem phpMyAdmin hast es ja anscheinend nicht gemacht. s.u.)

und habe dabei ausversehen den User "PMA" gelöscht.

wenn du mit dem phpMyadmin arbeiten möchtest, solltest du dir diesen User wieder anlegen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby luke7479 » 12. January 2007 18:14

Ich arbeite komplett über phpmyadmin.

Die Benutzer hab ich in mysql.user angelegt und verändert. Mit und ohne verschlüsseltem Passwort.

Der User pma war natürlich nach der ersten neuinstallation wieder da... :P

Ich habe grade eine FRISCHE Installation bei der nur der User test angelegt wurde und es sonst keine Veränderungen gibt.
luke7479
 
Posts: 8
Joined: 18. January 2006 17:00

Postby Wiedmann » 12. January 2007 19:16

Die Benutzer hab ich in mysql.user angelegt und verändert

Das macht man auch nicht... In SQL gibt es dafür das "GRANT" bzw. "SET PASSWORD" Statement.

Ich arbeite komplett über phpmyadmin.

Das bietet dir für diese Arbeiten direkt auf der Hauptseite den Punkt "Rechte" bzw. "Privileges" (je nach Sprache).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests

cron