mod_rewrite auf XAMPP funktioniert nicht?!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mod_rewrite auf XAMPP funktioniert nicht?!

Postby zerko » 02. January 2007 16:32

Mahlzeit zusammen

Also... ich würde gerne die mod_rewrite Funktionen meines lokalen Testservers nutzen, aber irgendwie macht der nicht so richtig mit Ich habe die .htaccess Datei aus einem produktiven Projekte genommen, wo sie funktioniert und wollte aus Testzwecken sämtliche Änderungen vorerst lokal durchführen.


Code: Select all
DirectoryIndex index.php

Options Includes +ExecCGI
AddType text/x-server-parsed-html .htm
AddType application/x-httpd-php .htm

RewriteEngine On
Options +FollowSymlinks

# Folgende Zeile sorgt dafür, daß .htaccess nicht angezeigt werden kann!
RewriteRule ^\.htaccess$ - [F]
RewriteBase /

# Dateien umschreiben
RewriteRule ^(.*)\.html$   index.php?iSite=$1


Habe hierzu die Funktion in der Konfigurationsdatei des XAMPP Apache auskommentiert und den Server neu gestartet.
Leider bekomme ich immerzu eine 404 Meldung.

Die Datei selbst liegt in einem Unterverzeichnis von .... ./htdocs/meine_webseite/.htaccess .
Folgende Fehlermeldung entsteht hierbei

Code: Select all
[Tue Jan 02 16:01:14 2007] [error] [client 127.0.0.1] File does not exist: E:/xampp/htdocs/meine_webseite/coaching_.html, referer: http://localhost/meine_webseite/



Natürlich existiert diese Datei nicht, da Sie - wie in der .htaccess aus der URL Variable index.php?iSite=SEITE gelesen werden soll... Kann mir jemand helfen?!

Gruß
zerko
zerko
 
Posts: 15
Joined: 25. June 2004 11:33

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests