keine datenbank auf lokalen rechner

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

keine datenbank auf lokalen rechner

Postby Thoman » 26. December 2006 22:13

hallo,
ich habe zwar die sufu benutzt aber bin zu keiner lösung gekommen,
mein problem: habe xamp lokal auf rechner ampel ist grün soweit alles gut,
wie erstelle ich eine datenbank ?
im gegensatz zu alten versionen braucht man doch nur einen rechtsklick ins feld machen und create database oder so ähnlich...

mache ich das jetzt fehlt diese einstellung, es steht nur
flush host
flush logs
flush tables
flash threads


auch sehe ich nicht die standart datenbänke wie mysql oder test so wie sie früher hießen nur ein leeres weisses fenster.

ist das neu in der aktuellen version ?
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby Thoman » 27. December 2006 23:32

weiß keiner woran das liegen könnte ?
ich hab nun versch version versucht zu installieren sprich 1.5.5 oder 1.5.4 oder 1.5.3
aber irgendwie kein erfolg die standarteinträge unter "datenbank" fehlen also kein eintrag mit "mysql" oder "test" leeres weisses feld und rechtsklick kein "create database" aber ampel ist grün.

kann es sein das irgendwo was eingetragen ist in der reg welches bei der deinstall übersehen wird ?

anbei mal ein log
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# C:/Programme/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:/Programme/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password = your_password
port = 3306
socket = mysql

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
basedir="C:/Programme/xampp/mysql"
tmpdir="C:/Programme/xampp/tmp"
datadir="C:/Programme/xampp/mysql/data"

port = 3306
socket = mysql

old-passwords
character-set-server = latin1
collation-server = latin1_general_ci

skip-locking
key_buffer = 16K
max_allowed_packet = 1M
table_cache = 4
sort_buffer_size = 64K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 64K

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (using the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking
server-id = 1

# Uncomment the following if you want to log updates
#log-bin=C:/Programme/xampp/mysql/data/mysql-bin

# Uncomment the following if you are NOT using BDB tables
skip-bdb

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:/Programme/xampp/mysql/data/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:/Programme/xampp/mysql/data/
#innodb_log_arch_dir = C:/Programme/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 8M
sort_buffer_size = 8M

[myisamchk]
key_buffer = 8M
sort_buffer_size = 8M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=C:/Programme/xampp/mysql/bin/mysqld-nt.exe
user=xxx
password=xxx
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby deepsurfer » 28. December 2006 02:02

anbei mal ein log

Sorry für Kleinkariertheit, aber das ist kein LOG sondern die my.cnf aus XAMPP.

- Hast du in dieser Datei irgendwas geändert ?
- die in dieser my.cnf zu sehenden Pfade, stimmen diese mit deiner XAMPP Installation überein ? (wenn nicht, dann mal xampp_setup.bat ausführen)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Thoman » 28. December 2006 02:30

ja ich hatte es mehrmals installiert / deinstalliert die pfadangaben waren alle ok.
wahrscheinlich bin nur ein einzelfall wer weiß :-(
also mit der alten version wo winmysqladmin 1.3 vorhanden ist sehe ich die option "create database" aber es kommt "server not connect" oder so ähnlich
obwohl port 80 offen ist.


ich werde aber eh windows neu aufsetzen hoffe das es dann funktioniert.
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby deepsurfer » 28. December 2006 10:15

also mit der alten version wo winmysqladmin 1.3 vorhanden ist sehe ich die option "create database" aber es kommt "server not connect" oder so ähnlich
obwohl port 80 offen ist.


Aaahhhhhh,

dieser mysql-client will sich aber mit Port 3306 verbinden der scheinbar bei dir nicht (wie der port 80) geforwarded wird, auch an die Firewall denken.

Wenn du es local machst muss in der Firewall der Port 3306 frei sein.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Thoman » 28. December 2006 12:20

hmm die firewall ist gänzlich aus zum zeitpunkt wo ich probiert habe, ok muss auch eingestehen ich bin nicht so der pc mann :oops:
aber da der pc eh mal ein frisches windows braucht bin ich sehr zuversichtlich ansonsten meld ich mich hier nochmal :)
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby Thoman » 29. December 2006 18:04

so nach neuen aufspielen von windows xp kein erfolg bei mir :(
nachwievor sehe ich wenn ich auf datenbank drück nicht die option "create database"...

firewall ist aus und habe nur antivir laufen aber das war auch aus.
hatte erst xp aufgespielt gleich dabach xamp die ampel ist grün...unter winmysqladmin und der aufruf von localhost klappt auch sprich bekomme dann die xamps seite angezeigt.
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby martinpre » 29. December 2006 18:18

versuchs mal damit .... http://127.0.0.1/phpMyAdmin/
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby Thoman » 30. December 2006 18:45

mit phpmyadmin habe ich eine datenbank anlegen können jedoch wenn ich das forum lokal installieren möchste kommt


The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
obwohl in der config der korrekte datenbanknamen angegeben wurde.
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby martinpre » 30. December 2006 18:52

Hast du auch den korrekten User/Passwort/Server eingetragen?
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby Thoman » 30. December 2006 19:04

// ****** DATABASE TYPE ******
// This is the type of the database server on which your vBulletin database will be located.
// Valid options are mysql and mysqli, for slave support add _slave. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
$config['Database']['dbtype'] = 'mysql';

// ****** DATABASE NAME ******
// This is the name of the database where your vBulletin will be located.
// This must be created by your webhost.
$config['Database']['dbname'] = 'forum';



// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config['MasterServer']['servername'] = 'localhost';
$config['MasterServer']['port'] = 3306;

// ****** MASTER DATABASE USERNAME & PASSWORD ******
// This is the username and password you use to access MySQL.
// These must be obtained through your webhost.
$config['MasterServer']['username'] = 'thoman';
$config['MasterServer']['password'] = 'xxxxxx';



naja ich werd mich mal an vb wenden, hatte sonst nie probleme mit xamp
:-(
Thoman
 
Posts: 7
Joined: 26. December 2006 22:03

Postby martinpre » 30. December 2006 19:21

der user existiert garantiert? sonst versuchs mal mit root ...
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests