virtuelle Hosts unter Xampp einrichten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

virtuelle Hosts unter Xampp einrichten

Postby madmax00 » 10. December 2006 16:08

Hallo ich habe auf meinem recher Win XP Prof Xampp laufen, dazu einen Account bei DynDNS, den Dyndns Updater installiert und
diese Kombination funktioniert auch. Jetzt habe ich zweite Account bei DynDNS eingerichtet. Dann habe ich zwei VirtuellHost für beide Accounts konfiguriert. Doch leider landet man, wenn man www.Account1.dyndns.org oder www.Account2.dyndns.org nicht im Verzeichnis \Account1 oder \Account2 sondern im htdocs.

bei Xampp habe ich unter apache/conf/ in der Datei httpd.conf folgende Einstellungen
Code: Select all
NameVirtualHost 127.0.0.1:80

<VirtualHost www.Account1.dyndns.org>
ServerAdmin info@Account1.de
DocumentRoot "D:/program files/xampp/htdocs/Account1/"
ServerName www.Account1.dyndns.org
DirectoryIndex index.php
</VirtualHost>

<VirtualHost www.Account2.dyndns.org>
ServerAdmin info@Account2.de
DocumentRoot "D:/program files/xampp/htdocs/Account2/"
ServerName www.Account2.dyndns.org
DirectoryIndex index.php
</VirtualHost>


Dann auch in die HOST Datei unter c:\winnt\system32\drivers\etc
Code: Select all
127.0.0.1       localhost
127.0.0.1       www.Account1.dyndns.org
127.0.0.1       www.Account2.dyndns.org


Wo muss ich denn noch etwas ändern damit es funktioniert

Vielen Dank für Eure Hilfe.

MfG max
madmax00
 
Posts: 11
Joined: 19. October 2006 16:38
Location: monheim

Postby madmax00 » 10. December 2006 16:26

Muss noch was bestiemen. Wenn ich local www.Account1.dyndns.org oder www.Account1.dyndns.org aufrufe, funktioniert alles Super. Ich kann nicht in richtigen Verzeichnis von ein anderen Rechner (aus Netz) landen.
madmax00
 
Posts: 11
Joined: 19. October 2006 16:38
Location: monheim

Postby deepsurfer » 10. December 2006 18:28

Das Testen ob die Anbindung aus dem Internet funktioniert muss ein Bekannter von dir machen (anrufen und er soll deine domain Aufrufen).

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin info@Account1.de
DocumentRoot "D:/program files/xampp/htdocs/Account1/"
ServerName www.Account1.dyndns.org
<Directory "D:/program files/xampp/htdocs/Account1/">
AllowOverride All
        DirectoryIndex index.php
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerAdmin info@Account2.de
DocumentRoot "D:/program files/xampp/htdocs/Account2/"
ServerName www.Account2.dyndns.org
<Directory "D:/program files/xampp/htdocs/Account2/">
AllowOverride All
        DirectoryIndex index.php
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>

chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby madmax00 » 10. December 2006 22:01

Danke für deine Antwort,

nach den Änderungen
Code: Select all
<Directory "D:/program files/xampp/htdocs/Account1/">
AllowOverride All
        DirectoryIndex index.php
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>

kann man jetzt von anderem Rechner auf die beiden Accounts zugreifen, aber local funktioniert gar nicht mehr. Wenn ich auf dem Rechner, wo xampp läuft, die Acconts oder ein andere VHost aufrufe, werden immer nur Daten von Account1 angezeigt. So, dass ich keine andere Sites local testen kann. Was soll ich beachren?

MfG max
madmax00
 
Posts: 11
Joined: 19. October 2006 16:38
Location: monheim

Postby deepsurfer » 11. December 2006 13:05

Fakten des Problems:

a) der Aufruf eines Bekannten über das Internet zeigt das beide Domains funktionieren.

b) der Aufruf beider Domains innerhalb des LAN (sofern jeder PC seine HOSTS datei bearbeitet hat und dort die LAN-IP des XAMPP-PCs steht) funktioniert.

c) der Lokale aufruf auf dem selben PC wo auch XAMPP läuft funktioniert nicht. (es erscheint immer der erste VHOST)

Treffen die drei Fakten zu ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby madmax00 » 11. December 2006 13:19

Woher weist du das? Genau die drei Fakten treffen bei mir.
Und wie kann man Problem "c" beheben?
madmax00
 
Posts: 11
Joined: 19. October 2006 16:38
Location: monheim

Postby deepsurfer » 11. December 2006 14:11

Woher weist du das? Genau die drei Fakten treffen bei mir.

Ich habe einfach deine letzte Antwort in Fakten (also das wesentliche) aufbearbeitet, dazu die Erfahrung hier aus dem Forum.

Und wie kann man Problem "c" beheben?

ich schätze das auf dem XAMPP-PC die HOSTS datei nicht richtig ist, betreffend für domain #2.

Checke bitte nochmal deine HOSTS datei auf dem XAMPP-PC, bestimmt ist nur ein Buchstabe falsch geschrieben.

Kannst auch mal das error.log vom Apache aufrufen, darin sollte der Misslunge Vorgang beschrieben sein.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby madmax00 » 11. December 2006 16:34

Ja, es funktioniert!!!!
Da, ich mehrere VHost habe, hatte ich bei einigen <VirtualHost *:80> und bei anderen <VirtualHost 127.0.0.1> und, seitdem ich alle auf <VirtualHost *:80> gewechselt habe, funktioniert alles super.

Danke dir für deine Hilfe


MfG max
madmax00
 
Posts: 11
Joined: 19. October 2006 16:38
Location: monheim


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 3 guests