Eigene 404 geht nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Paradise » 17. December 2006 11:49

Achso, die Standartfehlermeldung, ja die kommt.

Ich wrote:Also local lässt sich die Seite auf dem Server aufrufen


also http://localhost/inferno/error/404.html. Sie ist definitiv da 8)

Und auch in anderen Verzeichnissen hab ichs schon versucht bzw mit ner anderen Domain. Local ja, über Web nein.

Und vHost
Code: Select all
NameVirtualHost 62.75.139.238:80


<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/bodies"
ServerName www.paradise-bodies.com
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/bodies/cgi-bin/"
<Directory "C:/xampp/htdocs/bodies">
    Options ExecCGI
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/inferno"
ServerName www.paradise-inferno.com
<Directory "C:/xampp/htdocs/inferno">
    Options None
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>


wie kann der da bei http://paradise-inferno.com im bodies verzeichniss landen...
Paradise
 
Posts: 49
Joined: 03. November 2006 04:20

Postby deepsurfer » 17. December 2006 12:12

wie kann der da bei http://paradise-inferno.com im bodies verzeichniss landen...


Weil in deiner VHOST die definition für paradise-inferno.com fehlt..
Daher übergibt der Apache bei einem "nicht auflösbaren HTTP Request"
die Anforderung an den ersten VHOST

Verbesserung:

Code: Select all
NameVirtualHost 62.75.139.238:80


<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/bodies"
ServerName www.paradise-bodies.com
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/bodies/cgi-bin/"
<Directory "C:/xampp/htdocs/bodies">
    Options ExecCGI
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/inferno"
ServerName www.paradise-inferno.com
ServerAlias paradise-inferno.com  #<<<--- dieser Eintrag fehlte
<Directory "C:/xampp/htdocs/inferno">
    Options None
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>


Setz die ERROR Defintion testweise mal in die VHOSTs rein.
http://httpd.apache.org/docs/2.0/mod/co ... ordocument


Code: Select all
NameVirtualHost 62.75.139.238:80


<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/bodies"
ServerName www.paradise-bodies.com
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/bodies/cgi-bin/"
<Directory "C:/xampp/htdocs/bodies">
    Options ExecCGI
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

<VirtualHost 62.75.139.238:80>
DocumentRoot "C:/xampp/htdocs/inferno"
ServerName www.paradise-inferno.com
ServerAlias paradise-inferno.com
<Directory "C:/xampp/htdocs/inferno">
    ErrorDocument 404 ./error/404.html  #<<-- Errorhandling
    Options None
    AllowOverride all
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 17. December 2006 15:33

jo..geht doch... 8)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Paradise » 17. December 2006 15:49

Öh wie? Was geht.

Also paradise-inferno.com geht jetzt wo ich ServerAlias gesetzt hab.

Nur warum die 404.html sich nicht aufrufen lässt versteh ich nicht.
Mal unabhängig von ErrorDocument
Paradise
 
Posts: 49
Joined: 03. November 2006 04:20

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests