Nach Update von 1.5.4 auf 1.5.5 kein ZendOptimizer [edit]

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Nach Update von 1.5.4 auf 1.5.5 kein ZendOptimizer [edit]

Postby Titus » 01. December 2006 14:45

Hallo,

nach dem Update auf die aktuelle Version & troz anschließender Komplettinstallation ist "nur" Zend 2.2 oder sowas in der Richtung intalliert :(
(war ja vorher 3.0.1 bzw lt Auflistung sollte es 3.0.2 sein)

Ist das Absicht, ein Versehen oder Notwendigkeit?

Gruß
Titus
Last edited by Titus on 02. December 2006 16:32, edited 1 time in total.
Titus
 
Posts: 6
Joined: 09. January 2006 15:04

Postby Wiedmann » 01. December 2006 15:09

ist "nur" Zend 2.2 oder sowas in der Richtung intalliert

Was ist "oder sowas" genau?

(war ja vorher 3.0.1 bzw lt Auflistung sollte es 3.0.2 sein)

BTW: Von welcher Zend-Komponente sprichst du hier (und oben) jeweils?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Titus » 01. December 2006 16:34

Zend Optimizer wird ja per PHPinfo am ende des ersten Blocks ausgegeben, dort war in der 1.5.4 "sicher" 3.0.1 installiert, aktuell wird dort aber 2.2 angezeigt
und das skript welche eben min. Zend Opt 2.5 vorraussetzt läuft nicht mehr (was das eigentliche Problem ist :roll: )

Lt eurer Auflistung sollte da aber

Apache HTTPD 2.2.3, MySQL 5.0.27, PHP 5.2.0 + 4.4.4 + PEAR + Switch, MiniPerl 5.8.7, Openssl 0.9.8d, PHPMyAdmin 2.9.1.1, XAMPP Control Panel 2.3, Webalizer 2.01-10, Mercury Mail Transport System für Win32 und NetWare Systems v4.01a, FileZilla FTP Server 0.9.20, SQLite 2.8.15, ADODB 4.93, Zend Optimizer 3.0.2, XAMPP Security. Für Windows 98, 2000, XP.

eben 3.0.2 dabei sein
Titus
 
Posts: 6
Joined: 09. January 2006 15:04

Postby Wiedmann » 01. December 2006 19:53

Zend Optimizer wird ja per PHPinfo am ende des ersten Blocks ausgegeben, dort war in der 1.5.4 "sicher" 3.0.1 installiert, aktuell wird dort aber 2.2 angezeigt

Du musst IMHO schon richtig lesen ;-)

PHP basiert erst einmal auf einer Zend Engine (der Kern von PHP). Die ist bei PHP 5.2 mittlerweile bei Version 2.2 angelangt.

Ein aktivierter/installierter Zend Optimizer würde dort zusätzlich auftauchen (und auch in einem eigenen Block). Und laut readme scheint ja beim XAMPP der Optimizer in Version 3.0.2 beizuliegen.

Und ich gehe jetzt einfach mal davon aus, das bei dir in phpinfo() der Zend Optimizer nicht, wie von dir angegeben, aufgeführt ist, sondern die Zend Engine.

und das skript welche eben min. Zend Opt 2.5 vorraussetzt läuft nicht mehr

Da der Zend Optimizer also offensichtichlich nicht aktiviert ist, musst du diesen noch in der "php.ini" aktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Titus » 02. December 2006 16:30

so nachdem ich mich jetzt wieder stunden damit beschäftigt habe 1.5.4 und 1.5.5 zu testen und die 1.5.5 zu zerpflücken kann ich eigentlich nur feststellen das es nicht geht :x

1.5.5 - PHPinfo wrote:This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
with Zend Extension Manager v1.0.10, Copyright (c) 2003-2006, by Zend Technologies

dazu die 1.5.4
1.5.4 - PHPinfo wrote:This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
with Zend Extension Manager v1.0.10, Copyright (c) 2003-2006, by Zend Technologies
with Zend Optimizer v3.0.0, Copyright (c) 1998-2006, by Zend Technologies


eintrag in der PHP.ini der 1.5.5 lautet

zend_extension_ts = "E:\apf\xampp\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "E:\apf\xampp\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =

ursprünglich waren die ersten beiden zeilen von der reihenfolge vertauscht, was aber keinen einfluss auf das ergebnis hat, auch die angabe im pfad ...dOptimizer\lib\Optimizer-3.0.1 ändert nichts, im Ordner Optimizer finde ich aber auch keine php-5.2.x kann es daran liegen?

EDIT
ohne jetzt klugscheissen zu wollen
NEW Zend Optimizer 3.2 mit PHP 5.2-Unterstützung!
Titus
 
Posts: 6
Joined: 09. January 2006 15:04

Postby Wiedmann » 02. December 2006 17:07

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

Also wie schon vermutet. Die 2.2.0 bezieht sich gar nciht auf den Optimizer, sondern auf die Engine.

with Zend Optimizer v3.0.0, Copyright (c) 1998-2006, by Zend Technologies

Und da diese Zeile (o.ä.) jetzt fehlt, ist der Optimizer also gar nicht aktiviert/geladen.

im Ordner Optimizer finde ich aber auch keine php-5.2.x kann es daran liegen?

Würde ich vermuten. Ohne dieses Verzeichnis wäre ja IMHO nur ein Optimizer für/bis 5.1.x (und 4.4.x) dabei.

NEW Zend Optimizer 3.2 mit PHP 5.2-Unterstützung!

Und das bestätigt diese Vermutung. Da hat es wohl jemand mit dem Testen nicht so genau genommen (und ob die Beta-Tester wirklich Tester waren...?).

Jedenfalls solltest du dir dann dieses Paket holen und die Dateien ins entspr. Verzeichniss(e) vom XAMPP kopieren, wenn du einen laufenden Optimizer benötigst.

BTW:
Unter http://bugs.xampp.org/ solltest du auch diesen Fehler melden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sushimeister » 27. December 2006 15:26

*** BLÖDSINN GELÖSCHT ***

Sorry... also XAMPP 1.5.5 funktioniert SEHR WOHL mit dem ZendOptimizer 3.2.0 !!! Allerdings sollte man genau hinschauen, wo welche php.ini liegt ,-)

However, es funktioniert! Nur sollte die ZendOptimizer DLL im XAMPP Installationsverzeichnis doch besser geupdated werden.


Weiterhin noch ein frohes Restjahr!
Sushimeister
 
Posts: 63
Joined: 30. August 2006 18:05


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests