XAMPP: Neuen VirtualHost erstellen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP: Neuen VirtualHost erstellen

Postby Korn » 12. November 2006 14:10

Schönen Sonntag Forumsgemeinde!

Ich hatte beschlossen, meinen relativ alten Apache v1.3.35 zu deinstallieren und mir XAMPP herunterzuladen - gesagt, getan. Funktioniert alles prächtig.

Jetzt mein Problem:

Ich bin es gewohnt vom alten Apache, dass ich in der httpd.conf einfach einen neuen VirtualHost hinzufüge

Code: Select all
<VirtualHost *>
    ServerAdmin admin@localhost
    DocumentRoot "C:\Dokumente und Einstellungen\* *\Desktop\Apache\test"
    ServerName test

    ErrorLog logs/test.log
    CustomLog logs/test.log common
</VirtualHost>


und dann einfach noch in der HOSTS-Datei von Windows

Code: Select all
127.0.0.1          test


Und im Browser "test" eingeben und schon hab ich meine Seite...

Doch wie mache ich das mit XAMPP?? Das Root-Verzeichnis ist meines Wissens xampp/htdocs. Doch was muss ich alles machen, um ein neues Projekt anzulegen? Wo gebe ich den Ordner der den Namen des Projekts trägt hin? Wo und was muss ich in der httpd.conf ändern? Und was muss ich sonst noch tun?

Danke für eure Hilfe :)

MfG
Korn
Korn
 
Posts: 5
Joined: 12. November 2006 14:05

Postby deepsurfer » 12. November 2006 15:56

Doch wie mache ich das mit XAMPP??

Genauso wie bekannt, die XAMPP Komponente "Apache" ist nicht anders als vorher.

Das Root-Verzeichnis ist meines Wissens xampp/htdocs.

stimmt...
vorher war es bei dir c:/srv/www/htdocs
also was ist nun anders ? ausser das der DocumentRoot innerhalb des XAMPP Pfades liegt.

Doch was muss ich alles machen, um ein neues Projekt anzulegen?

\xampp\htdocs\meinprojekt1 = http://localhost/meinprojekt1
\xampp\htdocs\meinprojekt2 = http://localhost/meinprojekt2
\xampp\htdocs\meinprojekt3 = http://localhost/meinprojekt3

Wo gebe ich den Ordner der den Namen des Projekts trägt hin?

Siehe vorherige Bemerkung
Wenn du aber mit VHOST oder ALIAS arbeiten willst, kannst du auch komplett andere Pfade auf deinem Windowssystem nutzen.

Wo und was muss ich in der httpd.conf ändern? Und was muss ich sonst noch tun?

Nichts !
Für VHOST ist die \xampp\apache\conf\extra\ httpd-vhost.coonf zuständig.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Korn » 12. November 2006 17:34

Hm. Okay, danke!

Was ich jetzt für ein Problem habe:

wenn ich auf localhost/phpmyadmin zugreife, sagt er mir:

Code: Select all
phpMyAdmin - Fehler

Die Erweiterung mysql kann nicht geladen werden. Bitte �berpr�fen Sie Ihre PHP-Konfiguration. - Dokumentation


Woran liegt das? Ich habe die config.inc.php entsprechend konfiguriert.

Thx im Voraus
Korn
Korn
 
Posts: 5
Joined: 12. November 2006 14:05

Postby Korn » 12. November 2006 18:31

So. PHP und MySQL funktionieren jetzt einwandfrei auf einmal... PhpMyAdmin auch. Doch leider kann ich mich nciht einloggen, obwohl ich das korrekte Passwort und Benutzernamen eingegeben habe :(
Korn
 
Posts: 5
Joined: 12. November 2006 14:05

Postby deepsurfer » 12. November 2006 18:33

Hierbei stellt sich nun die Frage was du alles im XAMPP jetzt geändert hast. !?!?!?!?!?!?!?!?!?!?

Wenn du einfach eine httpd.conf von deinem laufendem Server in das XAMPP herüberkopierst, werden unweigerlich einige Einstellungen die XAMPP zum normalen betrieb benötigt einfach überschrieben.

Die mysql module werden in der httpd.conf geladen, der phpmyadmin der beim xampp dabei ist, ist über eine ALIAS Definition (httpd-xampp.conf) definiert.

Was hast du in der config.inc.php vom phpmyadmin geändert ? sofern du den phpmyadmin von XAMPP benutzt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Korn » 12. November 2006 18:39

Ich benutze PhpMyAdmin von XAMPP und das, was nicht funktioniert, ist das Einloggen bei PhpMyAdmin. MySQL läuft (Ampel ist grün). Ich hab die my.ini gelöscht im winows-ordner und dann habe ich mySQL neu gestartet über Winmysqladmin.exe. Da fragt er beim Starten dann natürlich nach einem Passwort und einem BEnutzernamen. Habe ich ihm Root als Benutzernamen gegeben und das Passwort eben. Funktioniert bei PhpMyAdmin aber eben nicht zum Einloggen.

In der httpd.conf hab ich nix verändert.
Korn
 
Posts: 5
Joined: 12. November 2006 14:05


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests