Passwortänderung nach Neustart des MySQL-Servers verworfen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Passwortänderung nach Neustart des MySQL-Servers verworfen

Postby mic_mash » 10. November 2006 11:35

Moin,

wenn ich versuche, das Passwort für root zu ändern, klappt dieses wunderbar und ich kann mich mit dem neuen Passwort verbinden und alle meine Programme funktionieren wie gewohnt. Wenn ich den Server über XAMPP Control jedoch neu starte funktioniert weder das neue noch das alte Passwort.
Dann hilft nur, mittels resetroot.bat das Passwort zurückzusetzen und dann ein neues Passwort zu setzen. Bis zum nächsten Neustart des Servers bzw. des ganzen Rechners, kann ich so damit arbeiten.

Passwort geändert habe ich mittels "mysqladmin -u root password geheim" und per "mysql -> SET PASSWORD = PASSWORD('geheim');". Ergebnis dasselbe.
Was mir auffällt, ist, dass nach dem rücksetzen des Passworts mittels resetroot.bat, ich den Server so oft neu starten kann, wie ich will, ich kann mich immer ohne Passwort einloggen.
Also scheint irgendwas an meiner Methode nicht zu klappen. Wie gesagt, es funktioniert nach dem erneuten Setzen eines Passworts weder das neue noch das alte (in Falle von resetroot.bat also ein leeres Passwort).


Kann es mir nicht erklären, wer kann weiterhelfen?

Danke im vorraus
mfg
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18

Postby deepsurfer » 10. November 2006 13:37

Benutzt du das SecurityScript vom XAMPP um dem MySQL root-User ein Passwort zu vergeben ???
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mic_mash » 10. November 2006 16:32

Wie gesagt, ich habs mit den beiden beschriebenen Methoden probiert.
Habe es grade nochmal über das SecurityScript getestet, wie du es gesagt hast -> genau die selbe Problematik. Das Passwort wird geändert und meine Scripte können wieder auf die DB zugreifen; starte ich den Server neu (so wie es das SecurityScript nach einer Änderung auch empfiehlt) geht nichts mehr.

Scheinbar wird beim Beenden des Servers oder erneutem Starten etwas am PW geändert. Gelöscht wird es jedenfalls nicht, weil wie gesagt ein Einloggen ohne Passwort auch zurückgewiesen wird.


Das Problem tritt übrigens erst auf, seitdem ich gestern einen zweiten MySQL 4.1 Server installiert hatte. Diesen habe ich in einen anderen Ordner installiert und wenig später auch wieder deinstalliert. Es kann sein, dass ich einmal mit der mysql.exe des neu installierten Servers auf den xampp-MySQL zugegriffen habe, da der Port des neuen Servers noch nicht richtig gesetzt war. Kann dabei eine Konfigurationsdatei mit falschen Einstellungen geschrieben worden sein?

Jedoch ist das für mich nicht ganz erklärlich, irgendwine Einstellung scheint nicht zu passen, sodass es mir bei Neustart das Passwort verhaut.

Eine einfache Lösung wäre toll, sonst bliebe mir nichts anderes, als den xampp-MySQL neu zu installieren.
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18

Postby deepsurfer » 10. November 2006 20:57

Schau mal nach ob der Ordner \xampp\mysql und dessen unterpfade mit dateien keinen schreibschutz haben.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mic_mash » 11. November 2006 14:29

Kein Schreibschutz gesetzt. Die Dateien user.myd und user.myi werden beim beenden des Servers geändert, nachdem ich ein Passwort gesetzt habe.
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18

Postby deepsurfer » 11. November 2006 15:45

Benutzt du irgendwelche "SystemTools", es gab hier mal einen User der hatte das Problem das immer wieder seine HOSTS datei überschrieben wurde.
Er hatte ein Tool das Systembezogene Vorgänge überwacht und dafür sorgt das bei Änderungen ein zuvor gespeichertes Backup wieder eingespielt wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mic_mash » 11. November 2006 17:36

Das einzige was bei mir in der Hinsicht läuft ist Ad-Watch. Das überwacht aber nur die Registry.

Ich habe mir nun nochmal die user.myd angeschaut. Wenn ich das Passwort ändere, wird der Hash in die Datei geschrieben. Ich kann mir fortan mit dem neuen Passwort einloggen (ohne den Server neu zu starten). Beim Beenden, wird die Datei laut WinXP-Anzeige zwar geändert, sie ist aber Binär identisch mit der vorigen. Danach kann ich mich aber nicht mehr einloggen.

Für mich ergibt das keinen Sinn. Warum muss ich beim zurück setzen des Passwort mittels resetroot.bat den Server neu starten, beim Ändern jedoch nicht? Beim Ändern ist es sofort aktiv, nach einem Neustart wird es nicht mehr akzeptiert... Ich stehe auf dem Schlauch und ich kann das Problem auch immer nur wiederholen, komme aber kein Stück weiter.

Ich benutze übrigens Version 4.1.13-nt.

Mit Grüßen und Danke für deine geduldige Hilfe. ;)
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18

Postby deepsurfer » 12. November 2006 12:53

Ich benutze übrigens Version 4.1.13-nt.

Jetzt steh ich auf dem Schlauch...
Zu was gehört diese Versionsangabe ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mic_mash » 12. November 2006 14:50

Das ist die MySQL-Server Version. Ich bin auf 4.1 angewiesen, weiß auch, dass es nicht die neuste ist, ich nutze den Server allerdings nur intern.
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18

Postby deepsurfer » 12. November 2006 16:04

Also benutzt du entweder eine XAMPP Version

1.4.10a
1.4.11
1.4.12
1.4.13
1.4.14
1.4.15
1.4.16

oder du benutzt die Aktuelle XAMPP Version 1.5.4a und hast Dir den 4.1.x.x MySQL separat hinzu Installiert.

Hast du den eigenen MySQL einfach in XAMPP\mysql Pfad installiert ???
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mic_mash » 12. November 2006 19:35

XAMPP 1.4.15, MySQL nicht seperat installiert. Es funktionierte auch alles wunderbar, bis ich vor ein paar Tagen die zweite MySQL 4.1-er in einen eigenen Ordner unabhängig von XAMPP installierte.

Ich werde nachher einfach versuchen, die Dateien des mysql-Verzeichnises aus dem XAMPP-Archiv in den bestehenden Pfad zu kopieren.[/b]
mic_mash
 
Posts: 6
Joined: 10. November 2006 11:18


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests