Fehlerseite bei Fehler 404 korrekt angezeigt, bei 500 nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlerseite bei Fehler 404 korrekt angezeigt, bei 500 nicht

Postby forap » 06. November 2006 16:40

Hallo,
ich habe XAMPP auf meinem Rechner installiert.
Wenn ein Fehler 404 o.ä. auftritt, wird meine Fehlerseite korrekt angezeigt:
Es ist ein Fehler aufgetreten

Bei einem Fehler 500 wird der Quellcode (siehe unten) der Fehlerseite angezeigt Dies passiert sowohl bei Netscape als auch bei Opera und Firefox.
Ich habe zum einfacheren Test des Problems für die verschiedenen Fehler die gleiche Fehlerseite definiert.

.htaccess:
ErrorDocument 404 /fehlert.shtml
ErrorDocument 500 /fehlert.shtml

Fehlerdokument fehlert.shtml:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Fehler</title>
</head>
<body>
<h1>Es ist ein Fehler aufgetreten</h1>
</body>
</html>

Den Fehler 404 erzeuge ich einfach durch Aufruf einer nicht vorhandenen Adresse http://www.meine....domain.de/irgendwas.shtml.
Den Fehler 500 durch Aufruf meines Kontaktformulars
http://www.meine....domain.de/cgi-bin/kontakt.pl, in dem ich die Variablendefinitionen my .... weggelassen habe.

Hat jemand eine Idee, woran das liegen könnte bzw. wie ich mich dem Problem nähern kann?
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Postby deepsurfer » 07. November 2006 11:47

setz die gleiche .htaccess mal in \cgi-bin\ verzeichnis rein

testen und melden

Ich gehe davon aus das Du den vorhandenen CGI-BIN Pfad im XAMPP nutzt, dieser ist aber ausserhalb der .htaccess Funktion deines Webcontents.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Fehlerseite bei Fehler 404 korrekt angezeigt, bei 500 nicht

Postby forap » 07. November 2006 17:50

Hi,
der Effekt kommt auch nach der Änderung weiterhin.
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Re: Fehlerseite bei Fehler 404 korrekt angezeigt, bei 500 ni

Postby deepsurfer » 07. November 2006 20:54

forap wrote:Hi,
der Effekt kommt auch nach der Änderung weiterhin.


Sorry, hast du auch die Pfadangabe zu deiner gewünschten errorseite in der .htaccess im \cgi-bin\ Verzeichnis angepasst ????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Fehlerseite bei Fehler 404 korrekt angezeigt, bei 500 nicht

Postby forap » 08. November 2006 09:17

Sorry, hast du auch die Pfadangabe zu deiner gewünschten errorseite in der .htaccess im \cgi-bin\ Verzeichnis angepasst ????


Ja, hatte ich.
forap
 
Posts: 29
Joined: 29. June 2006 12:32


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests