Stylesheet wurde nicht geladen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Stylesheet wurde nicht geladen

Postby burny » 03. November 2006 18:42

Hallo,

ich habe die aktuelle Version von XAMPP 1.5.4a (ZIP-Archiv) installiert und setup_xampp.bat ausgeführt. Über das Controll Panal habe ich Apache und MySQL gestartet. Mit dem Firefox 1.5.0.7 greife ich über http://localhost auf XAMPP zu und bekomme auch die Startseite zu sehen. Wenn ich jetzt auf phpMyAdmin klicke, erhalte ich zwar die erwartete Seite, aber die Darstellung ist sehr einfach. Über die JavaScript-Konsole erhalte ich die Fehlermeldung:

Fehler: Das Stylesheet http://localhost/phpmyadmin/css/phpmyad ... frame=left wurde nicht geladen, weil sein MIME-Typ, "text/html", nicht "text/css" ist.
Quelldatei: http://localhost/phpmyadmin/left.php?to ... cae05e2ec9
Zeile: 0

und

Fehler: Das Stylesheet http://localhost/phpmyadmin/css/phpmyad ... rame=right wurde nicht geladen, weil sein MIME-Typ, "text/html", nicht "text/css" ist.
Quelldatei: http://localhost/phpmyadmin/main.php?to ... cae05e2ec9
Zeile: 0

Über "Oberflächendesign" kann ich auswählen, was ich will, die Darstellung ändert sich nicht. Mit dem IE funktioniert es übrigens auch nicht.

Den Tip aus den FAQ (EnableSendFile usw.) habe ich schon versucht, ohne Erfolg.

Windows XP Prof. mit SP2 und aktuellen Patches, XP Firewall läßt localhost durch, kein Proxy, kein Virusscanner, Cookies für localhost zugelassen.

Danke im voraus,
Burny
burny
 
Posts: 2
Joined: 03. November 2006 18:16

Postby sari42 » 05. November 2006 17:16

>wurde nicht geladen, weil sein MIME-Typ, "text/html", nicht "text/css" ist.
ok, firefox will das, aber dem wird in css/phpmyadmin... rechnung getragen:
// Send correct type:
header('Content-Type: text/css; charset=ISO-8859-1');

auf manchen windozen macht chdir(..) oder zlib.output_compression Probleme.

wie verhält sich opera?
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby deepsurfer » 05. November 2006 18:36

Editiere mal die httpd.conf und füge als neue Zeile ganz unten folgendes hinzu.

Code: Select all
Win32DisableAcceptEx


Speichern, apache neu starten, testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby burny » 20. November 2006 15:56

Win32DisableAcceptEx hat nichts geändert.

Opera habe ich nicht getestet. Auf anderen Rechnern läuft es mit Firefox 1.5.0.7. Muß wohl am Rechner liegen: Dell Latitude D620 mit CoreDuo. Den 2. Kern habe ich zum testen mal im BIOS disabled, hat aber auch nichts gebracht.
burny
 
Posts: 2
Joined: 03. November 2006 18:16

Postby deepsurfer » 21. November 2006 10:56

Schau mal in der Browser Config, ob du JavaScript bzw. JaVa als solches zulässt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests