mySQL ist gestartet - kann jedoch nicht angesprochen werden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mySQL ist gestartet - kann jedoch nicht angesprochen werden

Postby puettologe » 10. October 2006 09:56

Hi -

mit de Nerve zu Fuß.

also - habe XAMPP installiert. Funktioniert super.
MySQL gestartet, gestoppt - alles super.
Doch im Status sagt er mir MySQL-Datenbank DEAKTIVIERT
CD-Verwaltung krigt keinen connect hin:
Fatal error: Call to undefined function: mysql_connect() in D:\xampp\htdocs\xampp\cds.php on line 64

Was habe ich da nur falsch gemacht.


:?
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

Postby deepsurfer » 10. October 2006 10:03

MySQL gestartet, gestoppt - alles super.

Also erst eingeschaltet danach abgeschaltet ==> MySQL aus

Doch im Status sagt er mir MySQL-Datenbank DEAKTIVIERT

Da Du zuvor ja berichtet hast das du den MySQL wieder abgeschaltet hast, so ist diese Statusanzeige richitg und auch die Fehlermeldung von der CDS.PHP
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby puettologe » 10. October 2006 10:53

Formal logisch ist das mit der Reihenfolge richtig.
Also, die Datenbank ist wieder gestartet und dann kommt die Nachricht, dass sie deaktiviert ist.

Tschuldigung, dass ich mich nicht praezise ausdrueckte.
Habe die halbe Nacht mit dem Problemchen verbracht.
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

L

Postby Wiedmann » 10. October 2006 11:55

Fatal error: Call to undefined function: mysql_connect() in D:\xampp\htdocs\xampp\cds.php on line 64

In deinem PHP ist die MySQl-Extension nicht aktiviert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby puettologe » 10. October 2006 12:29

Super erfaßt.
Als Newbee im Bereich config habe ich mich mal schlau gemacht, wie MySQl-Extension aktiviert wird.

Hörma - da siehse den Wald voa lautta Bäume nich mehr.

Auf Deutsch - welche Einstellung ist denn zum aktivieren notwendig, und in welchem ini (ich hab´da mehre )

Danke im Voraus.
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

Postby Wiedmann » 10. October 2006 12:46

Wie (und wo) man eine Extension aktiviert, wird z.B. hier erklärt:
http://www.apachefriends.org/de/faq-xam ... ml#imapphp
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 10. October 2006 12:53

Was mich aber an dieser ganze Fehlermeldung wundert ist, das es von enem Script kommt, das bei einem Lauffähigen und nicht an den config geänderten XAMPPs, eigentlich funktionieren sollte.

Wenn ich den MySQL stoppe und im XAMPP-Willkommscreen die CD-Sammlung anklicke erhalte ich
a) eine andere Fehlermeldung (Can't connect to MySQL server on 'localhost' (10061) in C:\xampp\htdocs\xampp\cds.php on line 64)

b) Die XAMPP-DEVs habe dann auch eine direkte Fehlerhinweismeldung eingebaut.


Daher neige ich nun puettologe zu fragen ob er irgendwelche Config Dateien innerhalb des XAMPPs geändert hat !!!!
Denn die MySQl-Extension sind nach der Installation des XAMPPs eingerichtet .
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby puettologe » 10. October 2006 13:26

Hallo deepsurfer,
die Vermutung ist nachvollziehbar. immerhin sitzen die meisten EDV-Fehler vor der Tastatur.
Ich habe aber keine Config-Dateien geändert. Aus Gründen der Fairness hätte ich das sofort mitgeteilt oder, wenn´s nicht aufgefallen wäre, spätestens hier zugegeben. Nein -kein Änderung.

Und nun nochmal zm Problem:

im ini waren

extension=php_imap.dll
extension=php_mysql.dll
extension=php_mysqli.dll

immer auskommentiert. so solls doch sein ? oder?
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

Postby Wiedmann » 10. October 2006 13:30

im ini waren
Code: Select all
extension=php_mysql.dll

Dann schau mal in phpinfo() nach, welche "php.ini" dein PHP überhaupt benutzt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby puettologe » 10. October 2006 14:09

Super - das war´s.

Ein bißchen tricky. Ich habe erst Zend installiert. Dadurch wurde das ini aus Zend genommen.

Nach einigem hin und her habe ich Zend und xampp deinstalliert und xampp neu installiert -- und jetzt klappts.

Vielen Dank für die Hilfe :lol:
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

Postby deepsurfer » 10. October 2006 16:31

Ein bißchen tricky. Ich habe erst Zend installiert. Dadurch wurde das ini aus Zend genommen.

Nach einigem hin und her habe ich Zend und xampp deinstalliert und xampp neu installiert -- und jetzt klappts.


AHA...

Ich werde bei nächster Gelegenheit meine Fragen bezüglich ändern von Configs erweitern und die "Installation von Programmen nach der XAMPP Install" forcieren..

HAPPY XAMPP
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby puettologe » 11. October 2006 05:43

Hallo deepsurfer,

schön zu erkennen, daß alles, wirklich alles einen großen Nutzen hat.
Bei meinem Fall ist es so, daß ich Zend vor Xampp installiert habe. Das hat das Problem ausgelöst.
be happy !
puettologe
 
Posts: 6
Joined: 10. October 2006 09:41

Postby deepsurfer » 11. October 2006 07:01

Hi puettologe,

no problem.
Ich muss Zugeben das meine letzte Äusserung wohl etwas mehr Erweiterung bedarft hätte.
Sollte kein Angriff an Dich sein. ;)

Es war in den letzten Tagen extrem geworden das einige User auf direkte Fragen nicht Antworten bzw. Informationen dazu einfach unter den Tisch kehren, es sich aber dann nach einigem hin und her herausstellte das derjenige doch etwas gemacht hat das die Situation (Problem) in einem anderen Licht erscheinen lässt.

Das nicht alles im Leben einfach und unbeschwert sein kann ist mir klar, es hatte halt nur Überhand genommen, daher mein vermeindliche Äusserung.

Das Du ja Zend vorher schon Installiert hattest kam in den ersten Texten gar nicht hervor ;)
Wie auch immer.... HAPPY XAMPP

greets
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby a6000000 » 12. October 2007 14:20

hier stehts auch , xampp + mysql + zend , danke
http://forum.finf.uni-hannover.de/print ... 2160406bc6
a6000000
 
Posts: 10
Joined: 13. August 2007 09:35

Postby a6000000 » 12. October 2007 14:53

a6000000
 
Posts: 10
Joined: 13. August 2007 09:35


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests