Sendmail

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Sendmail

Postby Uschi » 06. October 2006 13:34

Wir haben den widiker_chat_4_0 eingebaut, wenn sich jemand anmeldet versendet sendmail eine Mail, die aber beim Emfänger nicht ankommt.

im debug-editor steht folgendes


06.10.06 14:05:41 ** ~~~~~~~ UnserChat ~~~~~~~
06.10.06 14:05:41 **
06.10.06 14:05:41 ** --------------------
06.10.06 14:05:41 ** Diese Email wurde automatisch verschickt. Sollte es sich damit um ein Missverständnis handeln, bitten wir Sie um Entschuldigung. Bei öfterem Missbrauch wenden Sie sich bitte an uschi44@gmx.de, damit Ihre Email-Adresse für die Anmeldung gesperrt werden kann. Vielen Dank!
06.10.06 14:05:41 ** --- MESSAGE END ---
06.10.06 14:05:41 ** Connecting to localhost:25
06.10.06 14:05:41 ** Connected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Connection Closed Gracefully.
06.10.06 14:05:44 ** --- MESSAGE BEGIN ---
06.10.06 14:05:44 ** To: micha@t-online.de
06.10.06 14:05:44 ** Subject: Ihre Anmeldung im UnserChat
06.10.06 14:05:44 ** From: UnserChat <uschi44@gmx.de>
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Hallo!
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Sie haben sich gerade unter den Namen 'herrv49' im UnserChat angemeldet.
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Das sind Ihre Login-Daten:
06.10.06 14:05:44 **
06.10.06 14:05:44 ** USERNAME: mischa
06.10.06 14:05:44 ** PASSWORT: 301c60
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Bitte loggen Sie sich unbedingt innerhalb der nächsten 7 Tage ein, sonst wird Ihr Account automatisch gelöscht.
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Unseren Chat erreichen Sie unter http://dns/index.php
06.10.06 14:05:44 **
06.10.06 14:05:44 ** Mit freundlichen Grüßen

Wer kann helfen?
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby Wiedmann » 06. October 2006 13:44

im debug-editor steht folgendes

Du meinst im "debug.log"? Sieht aber ganz ok aus. Das "error.log" ist soweit auch ok?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Uschi » 06. October 2006 13:52

ja eben ich weiss das aber nicht warum nichts ankommt, es komm auch keine fehlermeldung. ist nur komisch, dass nichts ankommt
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby Wiedmann » 06. October 2006 14:09

Ah. Nochmal genau angeschaut und mal selbst eine Mail mit der sendmail.exe verschickt...

Code: Select all
06.10.06 14:05:41 ** Connecting to localhost:25
06.10.06 14:05:41 ** Connected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Disconnected.
06.10.06 14:05:42 ** Connection Closed Gracefully.

Zu was für einem Mailserver connectest du denn da auf dem "localhost"? Jedenfalls wird da wohl erst eine Verbindung auf diesem Port angenommen ("Connected.") und dann gleich wieder getrennt ("Disconnected.").

Zwischen diesen 2 Zeilen fehlt irgendwie alles. Also alle Komandos/Ausgaben für die Anmeldung und verschicken der Mail beim Server.

(Das "Connection Closed Gracefully." gibts bei mir nicht mal im SourceCode *grübel*)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Uschi » 06. October 2006 14:27

Mercury Mail
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby Uschi » 06. October 2006 14:29

Auf dem Rechner wird nicht gearbeitet, er dient ur als server
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby Wiedmann » 06. October 2006 14:41

Wie gesagt, warum im Log eigentlich die ganze Kommunikation fehlt, weis ich nicht. Theoretisch gibt es dann für den Mailserver auch nichts zu verschicken.
Was steht denn im Log vom Mailserver?

Mercury Mail

- Da gibt es jetzt 2 weitere Fragen. Wenn du schon einen lokalen Mailserver laufen hast, wieso benutzt du dann Sendmail?

- Und wenn schon Sendmail, warum verschickst du dann die Mails nicht gleich über den Mailserver beim Provider oder deiner Email im Log nach über GMX?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Uschi » 06. October 2006 14:46

Und wenn schon Sendmail, warum verschickst du dann die Mails nicht gleich über den Mailserver beim Provider oder deiner Email im Log nach über GMX?

Wie mache ich das?
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby Wiedmann » 06. October 2006 14:59

Hm, wie hast das bisher gemacht?
a) du hast PHP auf Sendmail umgestellt
b) du hast in der "sendmail.ini" die Daten vom Mercury eingetragen

"a)" hast du schon, bleibt also "b)" und du trägst einfach in der "sendmail.ini" die Daten von deinem Provider ein.

(Wird so z.B. auch in der "XAMPP FAQ" erklärt.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Uschi » 06. October 2006 15:14

in der sendmail.ini habe ich die daten von gmx eingetragen wie in der "XAMPP FAQ" erklärt. MercuryMail\LOGS ist leer.

aber da gibt es zwei die sendmail.ini und die sendmail_example da habe ich jetzt auch mal wie in der sendmail.ini eingetragen, aber es ändert sich nichts


; you must change mail.mydomain.com to your smtp server

smtp_server=localhost

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=local

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

;smtp_server=mail.gmx.net
;auth_username=uschi44@gmx.de
;auth_password=********
;force_sender=uschi44@gmx.de

; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines

;pop3_server=pop.gmx.net
:pop3_username=uschi44@gmx.de
:pop3_password=********

; to force the sender to always be the following email address, uncomment and
; populate with a valid email address. this will only affect the "MAIL FROM"
; command, it won't modify the "From: " header of the message content

;force_sender=uschi44@gmx.de

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting. you can manually set the ehlo/helo name if required

;hostname=localhost
Uschi
 
Posts: 44
Joined: 07. March 2005 20:46

Postby lugau45 » 09. October 2006 08:15

smtp_server=mail.gmx.net
auth_username=uschi44@gmx.de
auth_password=********
;force_sender=uschi44@gmx.de

versuche es mal ohne ; dann geht es auch.

und oben steht smtp_server=localhost das ersetzen mit dem was unten steht smtp_server=mail.gmx.net
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby PMGZED » 18. October 2006 13:43

ich glaube du must auch den smtp port nach ausen freigegeben haben mit portforwanding bin mir aber nicht genau sicher und als ich das mal getestet habe wo es funktionierte hat gmx die emails nicht angenommen aber mein kleiner vserver im inet hat das angenommen gmx nimmt die emails nur von ihn bekanten servern an soweit ich weis da deiner ein privater ist so wie ich das mitbekommen habe wird deiner von gmy geblokt so war es bei mir mach dir am besten bei irgen nen kleinen email anbieter ne adresse der anbiter sollte nach möglich keit kein spam filter haben und probier ob das da ankommt
gmx blockt die emails die kommen nichtmal bis zu spam die fliegen da schon vorher raus
PMGZED
 
Posts: 16
Joined: 23. September 2006 10:50


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests