Server zu langsam!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Server zu langsam!

Postby dieterlechner » 02. October 2006 15:50

Server zu langsam!

Hallo!

Ich habe auf meinem Server (2x Intel Xeon DualCore 3,2 Ghz 2Gb Ram Raid 5) XAMPP 1.5.4 installiert.
Auf dem Server läuft „nur“ ein online Shop auf OSCommerce.
Die Mysql Datenbank läuft auf einem eigenem Server (2x Inte Xeon 3,2 Ghz 2GB Ram Raid 5) der ebenfalls nichts anderes zu tun hat.
Der Shop hat derzeit ca. 5000 – 6000 Besucher täglich. Es sind zu spitzenzeiten bis zu 500 Kunden online.
Nun habe ich das Problem, dass die Kunden (ab ca. 200 User online) teilweise bis zu 40 Sekunden auf ihre Webseiten warten müssen, obwohl der Apache Server nur maximal 5% der Serverleistung und ca 400 MB Speicher in Verwendung hat.
Die CPU Nutzung des Mysql Server schwankt zwischen 10% und 80% kurzzeitig (für 5-10 Sekunden) liegt sie auch mal bei 100%.
Im Durchschnitt sind ca. 100 (Max. 400) Connection zum Server in Benutzung im Durchschnitt werden 80 (Max 900) SQL Querries vom Server gleichzeitig bearbeitet.
Wegen des OSCommerce verwende ich Mysql 4.0.13.

Ich habe nun noch die ZendPlatform installiert. Das Problem besteht aber noch immer.

Hat jemand Rat?
Danke Dieter
dieterlechner
 
Posts: 10
Joined: 01. October 2006 19:08

Postby Denis » 02. October 2006 19:00

Ja, auf Linux umsteigen.
User avatar
Denis
 
Posts: 24
Joined: 20. September 2006 15:54
Location: Spanien/Barcelona

Postby kleinweby » 02. October 2006 19:08

naja ich denke kaum das das jetzt an windows liegt (obwohl ich eientlich windows nicht ausstehen kann ;))

Aber man sollte Xampp nicht auf einem Server instalieren der zum Produktiven einstatz gedacht ist!!!!!

Aber zum Thema, ich denke das ein Problem der Configuration ist. (Aber k.a. was man da ändern muss)

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Re: Server zu langsam!

Postby Denis » 02. October 2006 20:00

dieterlechner wrote:Nun habe ich das Problem, dass die Kunden (ab ca. 200 User online) teilweise bis zu 40 Sekunden auf ihre Webseiten warten müssen


Eine frage, wie schnell ist dein Verbindung? (upload)
Bandbreite problem denke ich?
User avatar
Denis
 
Posts: 24
Joined: 20. September 2006 15:54
Location: Spanien/Barcelona

Postby dieterlechner » 02. October 2006 20:21

Hallo!

Eine frage, wie schnell ist dein Verbindung? (upload)
Bandbreite problem denke ich?

Der Server hängt an einr 200 Mbit Internet Leitung (up und down)

Aber man sollte Xampp nicht auf einem Server instalieren der zum Produktiven einstatz gedacht ist!!!!!


Blöde Frage: Warumm nicht?
Da ich mit Apache nicht so vertraut bin (war) habe ich der Einfachheit halber XAMPP installiert.

Ich habe jetzt die Datenbank und Apache gemeinsam auf einen Server verlegt und es läuft alles mit voller Geschwindigkeit.
Jetzt gerade sind 435 user online und es läuft noch alles in normaler Geschwindingkeit (shop.lindinger.at).
Sobald ich die MYSQL Datenbank wieder auf den anderen Server lege, wird es wieder langsam.
Da ich in den nächsten Tagen mit bis zu 1000 User gleichzeitig rechnen muss, möchte ich die Datenbank auf einem eigenen Server laufen lassen.

Dieter
dieterlechner
 
Posts: 10
Joined: 01. October 2006 19:08

Postby kleinweby » 02. October 2006 20:25

weil Xampp nunmal dafür nicht gebaut wurde. Bei der Configuration von Xampp wurde nicht gerade auf sicherheit geachten.

Aber dumer gegen frage. Ich denke du hattest den Shopschon vorher betrieben warum steigst du dann um? wärs nich besser die erstmal mit Apache und Co. zu befassen?

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby dieterlechner » 02. October 2006 20:38

Aber dumer gegen frage. Ich denke du hattest den Shopschon vorher betrieben warum steigst du dann um?


Ich hatte den Shop unter IIS6 mit ZendPlatform seit 07.2006 laufen. Neben den Performance Problemen hatte ich auch Probleme mit der ZendPlatform. Der Support von Zend hat mir empfohlem auf Apache umzusteigen.
wärs nich besser die erstmal mit Apache und Co. zu befassen?

Ich habe mich eine Woche ausführlich mit Apache beschäftigt und in dieser Zeit das Buch "Apache Webserver 2" von Addison - Wesley gelesen.
Nach einem Kurzem Test mit XAMPP möchte ich den IIS nun eigentlich nicht mehr verwenden.
Ich habe mir aber heute auf meiner Testumgebung bereits Apache 2.2.2 mit openssl installiert. Ich denke, dass ich die Nächsten Tage XAMPP entfernen werde.



Dieter
dieterlechner
 
Posts: 10
Joined: 01. October 2006 19:08

Postby Denis » 02. October 2006 21:04

Der Server hängt an einr 200 Mbit Internet Leitung (up und down)

Also gut genug.
Aber für dein Benutzung ich bleibe immer dabei daß mit Linux es wird sicher und mit sichereit besser laüfen.
User avatar
Denis
 
Posts: 24
Joined: 20. September 2006 15:54
Location: Spanien/Barcelona

Postby dieterlechner » 03. October 2006 08:40

Aber für dein Benutzung ich bleibe immer dabei daß mit Linux es wird sicher und mit sichereit besser laüfen.


Ich habe gerade das Paket mit SUSE 10.1 per Post erhalten.
Mal guggen.

Danke Euch
Dieter
dieterlechner
 
Posts: 10
Joined: 01. October 2006 19:08


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests