Problem mit "-k restart"

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit "-k restart"

Postby bigroot » 28. September 2006 23:32

Hi,

Ich bin dabei, ein webhostingscript zu programmieren.

Bis jetzt auch kein problem...

Filezilla account creation funzt
MySQL accoutn creation funzt...
u.s.w.

aber:

wenn ich versuche den apache mit "apache.exe -k restart" zu reloaden,
um die neuen vhosts zu übernehmen,
dann beendet er, startet aber nicht neu.

Es wird keine Fehlermeldung ausgegeben ind der DOS-Konsole...

woran liegt das? kann mir einer helfen?

Ich benutze das aktuelle XAMPP paket.
Ich lasse apache als service laufen.
Betriebssystem ist Win2003 Web Edition

MfG bigroot
bigroot
 
Posts: 5
Joined: 14. August 2006 00:09

Postby deepsurfer » 29. September 2006 13:32

Kannst du den bereich des codes hier mal posten der den " exec() " befehl durchführt.

Läuft der XAMPP-Apache bei dir als DIENST ???, mal gegenchecken ob er ohne DIENST mit deinem Befehl arbeitet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby bigroot » 29. September 2006 15:12

hmm... momentan mache ich das nicht mit einem exec befehl sonder ich gehe per start->ausführen->CMD in die kommandzeile und gebe "apache.exe -k restart" gefolgt von einem "Return" ein... danach ist der server ausgeschaltet und ich muss in mit "apache.exe -k start" wieder einschalten. Ja apache läuft bei mir als Service :)
bigroot
 
Posts: 5
Joined: 14. August 2006 00:09

Postby deepsurfer » 29. September 2006 15:21

Mal gegengetestet...
Code: Select all
C:\xampp\apache>apache_installservice.bat
Installing Apache2 as an Service
Installing the Apache2 service
The Apache2 service is successfully installed.
Testing httpd.conf....
Now we Start Apache2 :)

Apache2 wird gestartet...
Apache2 wurde erfolgreich gestartet.

Drücken Sie eine beliebige Taste . . .

C:\xampp\apache>cd bin
C:\xampp\apache\bin>apache.exe -k restart

C:\xampp\apache\bin>


Wird bei mir einwandfrei durchgeführt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby bigroot » 29. September 2006 15:27

C:\Program Files\xampp\apache>apache_installservice.bat
Installing Apache2 as an Service
[Fri Sep 29 16:26:38 2006] [error] Apache2: Service is already installed.
Now we Start Apache2 :)
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

Drücken Sie eine beliebige Taste . . .

C:\Program Files\xampp\apache>
bigroot
 
Posts: 5
Joined: 14. August 2006 00:09

Postby bigroot » 29. September 2006 15:30

erm... lol... hab direkt danach mal apache -k restart eingegeben und es funzt.. was war denn da gestern los? hatte es dreimal probiert und jedesmal hat der apache eben nicht neu gestartet gehabt...

kann das problem iorgendwie nicht mehr reproduizierne...

also ich sehe das jetzt erst mal als erledigt an..

Da versteh einer PC's....


Trotzdem danke für die Hilfe.,.. :)
bigroot
 
Posts: 5
Joined: 14. August 2006 00:09


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 2 guests