HTML-Mails über Mercury senden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

HTML-Mails über Mercury senden

Postby php » 26. September 2006 18:40

Hallo

Könnte vielleicht mal jemand folgenden Code ausprobieren? Ich versuche schon seit langem über PHP und XAMPP bzw. Mercury ein HTML-Mail zu versenden, aber erhalte immer den Fehler "26 Sep 06 19:35, Servicing job MO000005... 501 <Mein> Invalid mail address, must have a domain part". Text-Mails kann ich senden. Es würde mich deshalb interessieren, ob das überhaupt mit xampp funktioniert. Der Code ist i.O., wenn ich nämlich die PHP-Datei auf den Server hochlade funktioniert es.

Code: Select all
$Empfaenger = "eine@mailadresse.de";
$Betreff = "Meine erste HTML-Mail";
 
$Nachricht = "
<html>
<head>
<title>Meine erste HTML-Mail</title>
</head>
<body bgcolor=\"blue\" text=\"white\">
<font face=\"arial\" size=\"4\">Dies ist meine erste HTML-Nachricht mit PHP</font>
</body>
</html>
";
 
$Header = "MIME-Version: 1.0\n";
$Header .= "Content-type: text/html; charset=iso-8859-1\n";
$Header .= "From: Mein Name <meine@mailadresse.de>\n";
 
mail($Empfaenger, $Betreff, $Nachricht, $Header);


Es nervt gewaltig, dass man diese Scripts nicht lokal ausprobieren kann.
php
 
Posts: 10
Joined: 29. April 2006 18:47

Postby php » 26. September 2006 18:53

Gerade noch was herausgefunden:

funktioniert nicht:
Code: Select all
$Header .= "From: Mein Name <meine@mailadresse.de>\n";


funktioniert:
Code: Select all
$Header .= "From: <meine@mailadresse.de>\n";


Warum funktioniert die erste Variante nicht mit XAMPP? :twisted:
php
 
Posts: 10
Joined: 29. April 2006 18:47


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests