VirualHost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

VirualHost

Postby HiTecK7 » 13. September 2006 07:00

hi,

also langsam werd ich verrückt hier. habe auf nen alten pc xampp laufen gehabt. es läuft darauf eine lokale website.
damals verwendete ich folgende einstellungen:

hosts:
=======================================
127.0.0.1 localhost
127.0.0.2 xampp
127.0.0.3 meine_seite
=======================================


httpd.conf
=======================================
<VirtualHost asvw:80>
DocumentRoot "d:/asvw"
ServerName asvw
</VirtualHost>


<VirtualHost xampp:80>
DocumentRoot "d:/xampp/htdocs"
ServerName xampp
</VirtualHost>
=======================================

jetzt auf den neuen pc krieg ich es einfach nicht zu laufen! selbe einstellungen aber es funzt einfach nicht!!

könnte mir da jemand weiter helfen??
HiTecK7
 
Posts: 7
Joined: 12. October 2005 16:04

Postby deepsurfer » 13. September 2006 10:20

127.0.0.1 localhost
127.0.0.2 xampp
127.0.0.3 meine_seite


Kann so nicht gehen wenn in der Netzwerkkarte diese zwei zusätzlichen IPs nicht eingetragen werden würden.

Alles auf 127.0.0.1 stellen dann geht es.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby HiTecK7 » 23. September 2006 18:02

geht trotzdem nicht!!
HiTecK7
 
Posts: 7
Joined: 12. October 2005 16:04

Postby deepsurfer » 25. September 2006 12:34

Trotzdem alles auf 127.0.0.1 stehe lassen !

Dann folgt das Vervollständigen deiner VHOST einträge, denn diese haben keine Directory Anweisungen womit der XAMPP-Apache arbeiten kann.

Code: Select all
NameVirtualHost *.80

<VirtualHost *:80>
DocumentRoot "d:/asvw"
ServerName asvw
<Directory "d:/asvw">
AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>


<VirtualHost *:80>
DocumentRoot "d:/xampp/htdocs"
ServerName xampp
<Directory "d:/xampp/htdocs">
AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>
Last edited by deepsurfer on 25. September 2006 16:02, edited 2 times in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Termatek » 25. September 2006 13:34

deepsurfer wrote:
127.0.0.1 localhost
127.0.0.2 xampp
127.0.0.3 meine_seite


Kann so nicht gehen wenn in der Netzwerkkarte diese zwei zusätzlichen IPs nicht eingetragen werden würden.

Alles auf 127.0.0.1 stellen dann geht es.


Doch das geht so, es bringt nur nix ...
127.x.x.x ist das lokale Gerät. ob das jetzt .1 oder .99 ist, ist egal

127.0.0.1 localhost
127.0.0.2 localhost2
ping localhost2
antwort von 127.0.0.1
...

die fehlenden VHOST Einträge halte ich schon eher für den Grund, warum es nicht funktioniert (funktionierte?)
Termatek
 
Posts: 20
Joined: 21. August 2006 13:12

Postby Wiedmann » 25. September 2006 14:39

Doch das geht so, es bringt nur nix ...
127.x.x.x ist das lokale Gerät. ob das jetzt .1 oder .99 ist, ist egal

Es gibt nur "127.0.0.1" (hast du ja schon selbst bemerkt).

Aus diesem Grund kannst du für einen Hostnamen nicht 127.0.0.2 zuweisen, und dann einen VHost an diese Hostnamen (IP) binden. Weil es eben diese IP nicht gibt kannst du diese IP keinem Interface zuordnen und der Apache kann nur IP's benutzen, die einem Interface zugeordnet sind.

Unabhängig davon fehlen natürlicht noch die restlichen Einträge von Deepsurfer. (Der zudem die VHosts nicht an eine spezielle IP binden, und damit deinen Fehler von oben eh umgeht.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests