MySQL Running, aber Admin findet nichts...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL Running, aber Admin findet nichts...

Postby megachucky » 11. September 2006 17:48

Hallo.

Habe MySQL installiert (mit Xampp).


im Xampp Controll Panel ist MySQL "running", aber wenn ich auf "Admin" (WinMySQLAdmin) klicke, wird dort kein Server gefunden ?!?

Auch mit mySQLAdmin und QueryBrowser kommen Fehlermeldungen, wenn ich eine Tabelle erstellen will.

Anscheinend irgendein Verbindungsproblem, oder?

Weis jemand eine Lösung?





Mit MySQLadmin und query browser geht es auch nicht richtig:


Evtl verbinde ich mich falsch:

Verbindung: "leer"
Serverhost: localhost Porto 3306
user: root
password: "leer"

Das verbinden klappt damit. Nur das Tabellen erstellen klappt eben nicht so richtig.

Es kommen seltsame Fehler wie "command out of sync, cannot run this command now, fehler 2014", wenn ich die Tabelle erstellen will.
Manchmal erstellt er sie aber trotz der Fehlermeldungen, manchmal aber auch nicht.
Es kommt zb "Mann die Tabelleninformationen nicht holen" wenn ich auf Apply changes drücke, die Tabelle wird aber trotzdem erstellt.


Über die Console klappt es ohne Probleme, aber das ist mir zu aufwendig :-)

Danke.
megachucky
 
Posts: 5
Joined: 11. September 2006 16:51

Postby deepsurfer » 11. September 2006 17:56

Funktioniert die CD-Sammlung DEMO im XAMPP-Willkommenscreen ??
Funktioniert http://localhost/phpmyadmin ?

Wenn ja, dann machst du Connect Fehler zum MySQL-Server

Schau dazu die XAMPP <readme> nochmal an, darin sind die grund Zugangsdaten für den MySQL eingetragen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby megachucky » 11. September 2006 17:58

Ja, die CD Verwaltung klappt. Ok, ich lese mal da drin nach.
megachucky
 
Posts: 5
Joined: 11. September 2006 16:51

Postby megachucky » 11. September 2006 18:01

Also da steht nur root und password leer, genauso wie ich es mache ??!

phpadmin funtioniert auch. verstehe wirklich nicht den fehler?!?

der eine admin geht, der andere nicht ?!?


noch eine frage: was heißt denn eigentlich immer "als Service installieren"?
evtl liegt es ja da dran?
megachucky
 
Posts: 5
Joined: 11. September 2006 16:51

Postby deepsurfer » 12. September 2006 10:02

phpadmin funtioniert auch. verstehe wirklich nicht den fehler?!?

der eine admin geht, der andere nicht ?!?

Dann will auf biegen und brechen der "andere" ein Passwort übergeben.
Also, das SecurityScript von XAMPP ausführen.
Alle PWs die du einträgst notieren !, darunter ist auch das MySQL >root< Passwort.


noch eine frage: was heißt denn eigentlich immer "als Service installieren"?

Wenn du als "Service Installieren zustimmst" so werden diese Programmteile in dein System aufgenommen und beim jedem Neustart deines PCs direkt mit gestartet.

evtl liegt es ja da dran?

Nein ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby megachucky » 12. September 2006 10:15

Also, das SecurityScript von XAMPP ausführen.


Wie führe ich das denn aus?

Und dort meinst du soll ich dann ein Password eingeben, zb "1111" und dieses dann auch beim MySQL Admin bei der Connection eingeben?

Komisch ist allerdings auch, dass der Admin beim Xampp Control Center sich anscheinend ja nicht verbindet. Und hier gibt es ja auch nirgends einen "connect" Button oder Einstelltungen, wo ich password usw eingeben kann, oder übersehen ich den bloß?

Danke für die Hilfe schonmal.
megachucky
 
Posts: 5
Joined: 11. September 2006 16:51

Postby deepsurfer » 12. September 2006 11:43

Huiiii, also............
Wenn man im XAMPP-Willkommenscreen auf den
"Sicherheitscheck" klickt, so öffnet sich ein neuer Browser mit einigen
Statusanzeigen zum Thema Sicherheit, wenn man nun etwas gewillt ist die Text darunter zu lesen so erscheint ein Anklickbarer LINK den man benutzen kann.

Sicherheitscheck des Willkommenscreens von XAMPP wrote:Diese Sicherheitslücken im XAMPP Verzeichnis, dem ROOT Passwort für
MySQL und der Sicherung von PHPMyAdmin können nun einfach über den folgenden Link geschlossen werden:

=> http://localhost/security/xamppsecurity.php <= [nur über localhost möglich]
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby megachucky » 12. September 2006 12:31

Wer lesen kann ist klar im Vorteil :-)


Leider hat das mein Problem noch nicht gelöst, die Fehlermeldungen kommen immer noch bei MySQL Admin und QueryBrowser.

Und der Admin vom Xampp control panel zeigt immer noch keinen Server an.

phpMyAdmin geht einwandfrei.


Seufz...
megachucky
 
Posts: 5
Joined: 11. September 2006 16:51


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests