FormMail unter Win XP mit Apache

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

FormMail unter Win XP mit Apache

Postby Lexl74 » 08. September 2006 23:10

Hallo zusammen,

ich verzweifel nun bald... :cry:

Ich muß gestehen, ich beschäftige mich noch nicht allzu lange mit Apache, PHP, CGI, ect....
Bin nun dabei eine Website für meine Freundin zu erstellen und will da auch ein Kontaktformular einbauen.
Habe das Formular nun fertig erstellt und mir dazu das Script FormMail.pl eingerichtet, das nun im Ordner CGI-BIN liegt.
Wenn ich jedoch im Formular auf abschicken klicke, bekomme ich immer einen "Internal Server Error" ... Wenn ich dann im Error-Log unter Apache nachschaue, stehen folgende Zeilen drin:


[Fri Sep 08 23:43:59 2006] [error] [client 84.56.148.128] Premature end of script headers: FormMail.pl, referer: http://lexl74.homeip.net/feedback.html?subject=Homepage tina-reinhard.de

[Fri Sep 08 23:43:59 2006] [error] [client 84.56.148.128] Array found where operator expected at E:/Programme/xampp/cgi-bin/FormMail.pl line 52, at end of line\r, referer: http://lexl74.homeip.net/feedback.html?subject=Homepage tina-reinhard.de

[Fri Sep 08 23:43:59 2006] [error] [client 84.56.148.128] \t(Missing semicolon on previous line?)\r, referer: http://lexl74.homeip.net/feedback.html?subject=Homepage tina-reinhard.de

[Fri Sep 08 23:43:59 2006] [error] [client 84.56.148.128] syntax error at E:/Programme/xampp/cgi-bin/FormMail.pl line 52, near "@valid_ENV "\r, referer: http://lexl74.homeip.net/feedback.html?subject=Homepage tina-reinhard.de

[Fri Sep 08 23:43:59 2006] [error] [client 84.56.148.128] Execution of E:/Programme/xampp/cgi-bin/FormMail.pl aborted due to compilation errors.\r, referer: http://lexl74.homeip.net/feedback.html?subject=Homepage tina-reinhard.de

Die ersten Zeilen im FormMail.pl sehen so aus:

#!E:/programme/xampp/perl/bin/perl.exe
$mailprog = '/usr/lib/sendmail -i -t';
@referers = ('lexl74.homeip.net' ,'192.168.0.3');
@recipients =('lexl74@hotmail.com')
@valid_ENV = ('REMOTE_HOST','REMOTE_ADDR','REMOTE_USER','HTTP_USER_AGENT');


An was kann das liegen??
Muß ich ein anderes mailprog angeben? Wenn ja welches? Beim XAMPP-Paket ist ein Mail-Prog Namens Mercury dabei gewesen, kann man dieses dazu nutzen??

Bitte um Hilfe.... :(

Gruß
Lexl74
Lexl74
 
Posts: 3
Joined: 20. October 2004 14:17

Postby lugau45 » 13. September 2006 09:47

wenn ich dich richtig verstehe sendet dein script nicht. hast du in der php.ini sendmail aktiviert? wenn nicht mercury geht auch als mailserver. es gibt auch noch einige mehr z.b. hamster landmailserver...
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby deepsurfer » 13. September 2006 10:31

$mailprog = '/usr/lib/sendmail -i -t';

Der Sendmail liegt im XAMPp-Windows unter
Code: Select all
$mailprog ='e:/programme/xampp/sendmail/sendmail.exe -i -t';

Dort die sendmail.ini Editieren und darin die Mailaccountdaten eintragen.

Hinweis: In dieser INI sind textreihen mit einem semikolon " ; "vorhanden, diese Zeilen sind wie bei PHP "//" als Einkommentiert anzusehen und somit werden diese nicht beachtet.
Folglich das semikolon entfernen und die Funktion wird dann vom sendmail annerkannt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests