PHP unter XAMPP ...die fwrite / fread funktion liest nur 8KB

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP unter XAMPP ...die fwrite / fread funktion liest nur 8KB

Postby RDJ » 07. August 2003 08:07

Hallo @all
Ich habe ein problem mit PHP unter XAMMP. Und zwar gehts darum :
Ich hatte früher PHPTriad drauf ... allerdings eine ältere version. Diese hab ich jetzt deinstalliert und XAMPP drauf auf den rechner .... es läuft alles wunderbar ausser bei der fread / fwrite funktion

Diese lesen / schreiben irgendwie nur die ersten 8 KB und dann ist finito .... kann das sein dass noch irgendwelche einstellungen gemacht werden müssen ?


Wenn ja welche ?
Please Help me....es ist echt wichtig

Danke

RDJ
RDJ
 

Postby RDJ » 07. August 2003 09:28

Hier hab ich die PHPINFO von meinem Localen Rechner mal abgebildet

PHP INFO
RDJ
 

Postby nemesis » 07. August 2003 17:16

post_max_size 8M

und

max_execution_time 1200
max_input_time 60

könntest noch anheben, zumindest die input time.

und 8kbyte sind zumindest bei 8mbyte maximalen "speicherverbrauch" doch etwas untertrieben.... hab schon eine 50mbyte datei damit eingelesen, und über 100mbyte ausgeben, wird wenn dann an max post size und input time liegen, je nachdem ob php bei dir über cmd line läuft, also die php.exe, oder per mod_php (wohl eher letzters) musst du die php.ini unter /php, bzw, php.ini unter /apache/bin <-- editieren bei den einstellungen :)
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests