Mailserver - Verzweifle langsam...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mailserver - Verzweifle langsam...

Postby Meister_Max » 29. August 2006 14:30

Folgendes, ich hab nen Server mit Xampp, apache mit vhosts und der mysql server laufen reibungslos...
aber ich bekomme einfach kein mailserver zum laufen.. hamster will nicht und mercury auch net...

Mit mercury bin ich soweit gekommen das ich über dies Software selbst schon erfolgreich eine Mailn verschicken konnte..

Aber mail() von php will einfach nicht.. ich bekomme immer

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\web\test.php on line 9

Jedoch läuft mercury, und der Port ist von der Firewall auch freigegeben... was soll ich bloß tun ? ich versuchs schon seit 5 Tagen, hab hier auch das halbe Forum durchsucht, ich werd bald wahnsinnig, ich brauch unbedingt nen funktionierenden Mailserver - kann meinetwegen auch irgendnen anderer sein, mir total egal, hauptsache es geht.
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby Meister_Max » 29. August 2006 14:59

Probiere es gerade mit dem ArGoSoft Mail Server aber der sagt bei nem Test :

8/29/2006 3:46:41 PM - [ 3] Delivering to Meister_Max@web.de
8/29/2006 3:46:41 PM - [ 3] Attempting to deliver to the domain web.de
8/29/2006 3:46:41 PM - SMTP connection with 127.0.0.1 ended. ID=2
8/29/2006 3:46:41 PM - [ 3] Retrieved 2 MX records for domain web.de
8/29/2006 3:46:42 PM - [ 3] Trying the server mx-ha01.web.de: 217.72.192.149
8/29/2006 3:46:53 PM - [ 3] Fatal SMTP error relaying the message to server mx-ha01.web.de: 217.72.192.149: 501 <Supportmailer>: sender address must contain a domain
8/29/2006 3:46:53 PM - [ 3] Trying the server mx-ha02.web.de: 217.72.192.188
8/29/2006 3:46:53 PM - [ 3] SMTP error relaying the message to server mx-ha02.web.de: 217.72.192.188: 421 mx30.web.de: Too much load; please try again later
8/29/2006 3:46:53 PM - [ 3] Server error: 421 mx30.web.de: Too much load; please try again later. Will retry in 0 hr 10 min

Der User ist angelegt und der Script sieht so aus :
<?PHP
$contact_email="Meister_Max@web.de";
$email_sender="noreply@afawo.de";
$header = "From: Supportmailer <".$email_sender.">\n";
$header.= "Reply-To: <".$email_sender.">\n";
$header.= "X-Mailer: PHP/" . phpversion(). "\n";
$header.= "X-Sender-IP: $REMOTE_ADDR\n";
$header.= "Content-Type: text/html";
mail($contact_email, "Supportmail", "Test...", $header);
?>

Warum sagt er also "sender address must contain a domain" ?
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby Wiedmann » 29. August 2006 15:06

ich brauch unbedingt nen funktionierenden Mailserver

Wieso, oder besser für was?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Meister_Max » 29. August 2006 15:20

Na weils nen kompletter Webserver ist, wie soll ich zum Beispiel Leuten die sich regestrieren ne Bestätigungsmail schicken ? Zu dem soll da auch nen Bestellscript laufen, der Bestellungen per Email an die entsprechende Firma schickt.
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby Wiedmann » 29. August 2006 15:34

Na weils nen kompletter Webserver ist,

Naja, also Webserver != Mailserver ;-)

wie soll ich zum Beispiel Leuten die sich regestrieren ne Bestätigungsmail schicken ? Zu dem soll da auch nen Bestellscript laufen, der Bestellungen per Email an die entsprechende Firma schickt.

Also fassen wir zusammen:
Du möchtest mit diversen Scriptsprachen Mails verschicken.

Gib't den schon einen Mailserver über den du oder deine/die Firma Mails verschickt / erhält?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Meister_Max » 29. August 2006 16:16

Naja, also Webserver != Mailserver ;-)

Naja meine halt mit allem drum und dran ^^

Also fassen wir zusammen:
Du möchtest mit diversen Scriptsprachen Mails verschicken.


Das Trifft den Nagel auf den Kopf

Gib't den schon einen Mailserver über den du oder deine/die Firma Mails verschickt / erhält?

(Nur ich - noch keine Firma)
Nein gibts nicht, ich habe bisher nur Mails normal von meiner web.de Addresse verschickt. Aber auf den Server sollen mit der Zeit so einige Leute rauf und die wollen garantiert ihrname@ihredomain.de haben, was ich im übrigen auch gerne hätte, nur ich bekomms leider nicht gebacken.


Allerdings hab ich beim googlen was zu "address must contain a domain " gefunden, jemmand der meinte das eine der Vaiablen nen CRLF enthällt, was mir nix gesagt hat aber nach nem blick in wikipedia weiß ich nun das das nen Zeilenumbruch ist. Jedoch weiß ich immernoch nicht wo der zuviel sein soll... :(
(http://www.webdeveloper.com/forum/showt ... p?t=117772)
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby Meister_Max » 29. August 2006 23:52

So, fehler gefunden...
irgendwie mag er das so nicht :
$header = "From: Supportmailer <".$email_sender.">\n";

aber so hab ich kein Problem mehr :
$header = "From: ".$email_sender."\n";

kann zwar kein Namen angeben aber das ist mir egal, wenigstens funktionierts jetzt.
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby Meister_Max » 31. August 2006 12:40

- OK - hat sich erledigt..

Und ich möchte mich bei allen fürs generve entschuldigen, jetzt beim 5ten versuch hab ich in der Suche mal "Tutorial" eingegeben und mein Probleme waren gelöst.
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby lugau45 » 01. September 2006 09:03

Meister_Max wrote:So, fehler gefunden...
irgendwie mag er das so nicht :
$header = "From: Supportmailer <".$email_sender.">\n";

aber so hab ich kein Problem mehr :
$header = "From: ".$email_sender."\n";

kann zwar kein Namen angeben aber das ist mir egal, wenigstens funktionierts jetzt.


welchen mailserver nimmst du? wenn es der mercury ist und du willst den mailserver für nen webserver nehmen dann versuche mal mit phpkit oder oscommerce mails zu senden geht nicht.
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Meister_Max » 01. September 2006 16:33

Naja jetzt geht es ja und das reicht mir. Was phpkit oder oscommerce angeht, von den hab ich noch nie gehört, aber ich werds schon aus wissendurst mal googlen ^^

Meine einzige Frage die ich noch hab ist halt wie ich in Mercury sagen kann das ein User nur zu ner bestimmten Domain gehört.
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56

Postby lugau45 » 01. September 2006 17:00

irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Meister_Max » 03. September 2006 14:13

Ich hab das aus Zeitmangel jetzt nur mal überflogen , kann es dein das das sowas wi Xampp nur mit integriertem cms ist ? - Und naja dann brauch ich es ja nicht, hab ja xampp ^^ und nen cms kommt nicht erst in meine nähe... wozu kann ich programmieren :)
Meister_Max
 
Posts: 23
Joined: 26. August 2004 21:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests