Problem mit XAMPP (Internet)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit XAMPP (Internet)

Postby Gramsci » 18. August 2006 10:13

Nach ewigem rumsuchen bin ich zwar etwas schlauer, aber mein XAMMP leider nicht funktionierender geworden...

Windows Firewall ist deaktiviert, auch der Teil vom Service Pack zwei der Port 80 blockiert. Als Firewall läuft Outpost Firewall Pro ver. 3.51.759.6511 (462) funktioniert aber auch nicht bei temporärer Deaktivierung. Antivirus Programm ist Avira Antivir Personal Ed. Classic. Im LAN funktioniert das ganze, nur übers Internet nicht (auch nicht direkt über die IP des DynDNS Updater). Der Server ist hinter einem Router, ist allerdings als Demilitarized Zone eingerichtet.
Folgende Einträge aus den Konfigurationsdateien könnten noch wichtig sein:

seit neurem habe ich folgende Fehlermeldung beim stoppen und starten (nicht das es vorher funktioniert hätte:

httpd:
Code: Select all
Listen 0.0.0.0:80
ServerName domainname.dyndns.org
DocumentRoot "C:\HTTP"

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

<Directory "C:\HTTP">

<Directory "C:/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>


httpd-vhosts:
Code: Select all
NameVirtualHost 127.0.0.1
<VirtualHost 127.0.0.1>
    ServerName localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin email
    DocumentRoot "c:/http"
    ScriptAlias /cgi-bin/ "c:/cgi-bin/"

    <Directory "c:/http/">
    AllowOverride None
    </Directory>

    <Directory "c:/http">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.html index.htm index.php
    </Directory>

</VirtualHost>

<VirtualHost 127.0.0.1>
    ServerName www.domainname.dyndns.org
    ServerAlias domainname.dyndns.org
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin email
    DocumentRoot "c:/http"
    ScriptAlias /cgi-bin/ "c:/cgi-bin/"

    <Directory "c:/http/">
    AllowOverride None
    </Directory>

    <Directory "c:/http/">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.html index.htm index.php
    </Directory>

</VirtualHost>


Code: Select all
D:\Programme\xampp>xampp_stop
MySQL stop ...
Apache killed ...
pv: Access to 'apache.exe' is denied.
pv: Access to 'apache.exe' is denied.
Attention: Cannot delete the httpd.pid!
Apache pid delete ... SHUTDOWN COMPLETE!

D:\Programme\xampp>xampp_start
Diese Eingabeforderung nicht waehrend des Runnings beenden ...
Zum stoppen bitte die xampp_stop benutzen!
Please do not close this window while running ...
Use the xampp_stop for shutdown!

Please wait [Bitte warten] (OS 10048)Normalerweise darf jede Socketadresse (Prot
okoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden.  : m
ake_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
...

### APACHE + MYSQL IS STARTING NOW ###


Portscan:
Code: Select all
Service              Port   Status
==============================================================================
Apache (HTTP)          80   D:\Programme\xampp\apache\bin\apache.exe
Apache (WebDAV)        81   free
Apache (HTTPS)        443   D:\Programme\xampp\apache\bin\apache.exe

MySQL                3306   D:\Programme\xampp\mysql\bin\mysqld.exe

FileZilla (FTP)        21   D:\Programme\xampp\FileZillaFTP\FileZillaServer.exe
FileZilla (Admin)   14147   D:\Programme\xampp\FileZillaFTP\FileZillaServer.exe

Mercury (SMTP)         25   free
Mercury (POP3)        110   free
Mercury (IMAP)        143   free


DynDNS Updater:
Image
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

...

Postby Gramsci » 18. August 2006 10:20

Achso, es laufen noch Hamachi und eMule(mit aktiviertem Internetportal, aber über Port 47irgendwas)
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 18. August 2006 11:31

D:\Programme\xampp>xampp_stop
pv: Access to 'apache.exe' is denied.

Irgendeines deiner AV-Programme hat den Zugriff auf diese Datei (pv.exe) gesperrt.
--> der Apache wird nicht beendet

D:\Programme\xampp>xampp_start
(OS 10048)Normalerweise darf jede Socketadresse ...
...
Portscan:
Apache (HTTP) 80 D:\Programme\xampp\apache\bin\apache.exe

Da der Apache noch/schon läuft (s.o.), bekommt du hier eine Fehlermeldung wenn du ihn noch einmal starten willst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 18. August 2006 16:58

Wiedmann wrote:
D:\Programme\xampp>xampp_stop
pv: Access to 'apache.exe' is denied.

Irgendeines deiner AV-Programme hat den Zugriff auf diese Datei (pv.exe) gesperrt.
--> der Apache wird nicht beendet


Die Fehlermeldung ist immer noch da, wenn ich die Firewall und den AntivirGuard deaktivire. Beim XAMPP-ControlPanel scheint aber alles einwandfrei zu laufen, was es wie gesagt im Intranet auch tut. Nur eben im Internet nicht :roll:
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 18. August 2006 17:20

Die Fehlermeldung ist immer noch da, wenn ich die Firewall und den AntivirGuard deaktivire.

Nur weil das AV-Programm nicht mehr läuft, heisst das ja nicht das du Zugriff hast...
--> Dieser wurde ja gesperrt als es noch lief. Und jetzt ist es halt so, ausser du hebst diese Sperre wieder auf.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 18. August 2006 17:26

Leider weiß ich cnith wie ich das mache, aber das ist eigentlich auch nicht so wichtig, da XAMPP ja im Intranet läuft, nur nicht im Internet, warum wüsste ich gerne?
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 18. August 2006 17:34

da XAMPP ja im Intranet läuft, nur nicht im Internet, warum wüsste ich gerne?

Wenn hier jemand wüsste, was bei dir mit "Internet" und mit "Intranet" genau gemeint ist, sowie was genau nicht funktioniert, bzw. was passiert, könnte man dir evtl. hefen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 18. August 2006 17:44

Wiedmann wrote:
da XAMPP ja im Intranet läuft, nur nicht im Internet, warum wüsste ich gerne?

Wenn hier jemand wüsste, was bei dir mit "Internet" und mit "Intranet" genau gemeint ist, sowie was genau nicht funktioniert, bzw. was passiert, könnte man dir evtl. hefen.


Also der (potentielle) Server geht über einen Router zusammen mit anderen PCs ins Netz, ist allerdings Routerseits als Demilitarized Zone eingerichtet, sollte also alles durchgehen. Von Allen Netzwerkrechner lässt sich auf den HTTP-Ordner von Apache zugreifen, nur über die DynDNS-Domain funktioniert es leider nicht?
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 18. August 2006 17:52

nur über die DynDNS-Domain funktioniert es leider nicht?

Wenn der Server die LAN-IP "192.168.0.10" hat, tut doch alles? *grübel*
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 19. August 2006 11:02

Wiedmann wrote:
nur über die DynDNS-Domain funktioniert es leider nicht?

Wenn der Server die LAN-IP "192.168.0.10" hat, tut doch alles? *grübel*


Ja das ist die Netwerk IP des Servers, aber gehen tut´s trotzdem nicht :shock:
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 19. August 2006 15:46

Ja das ist die Netwerk IP des Servers, aber gehen tut´s trotzdem nicht

Das ist eine Logik *H*
--> Wenn es nciht gehen würde, wüsste ich ja die LAN-IP nicht...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 20. August 2006 10:17

Wiedmann wrote:
Ja das ist die Netwerk IP des Servers, aber gehen tut´s trotzdem nicht

Das ist eine Logik *H*
--> Wenn es nciht gehen würde, wüsste ich ja die LAN-IP nicht...


Hallo Wiedmann, erstmal danke für deine Hilfe. Vielleicht kannst du mir noch sagen, wie du an die LAN-IP gekommen bist? Wenn ich die LAN-IP in den Browser tippe, dann kommt die typische "It works!" Seite, versuche ich das über die DynDNS URL (die ist übrigens nicht www.domainname.dyndns.org), dann komm eine Fehlermeldung wegen Zeitüberschreitung?
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12

Postby Wiedmann » 20. August 2006 13:18

versuche ich das über die DynDNS URL (...), dann komm eine Fehlermeldung wegen Zeitüberschreitung?

Du hast doch bestimmt den obersten Thread hier im Forum gelesen?

Jedenfalls kannst du das in der "XAMPP FAQ" nachlesen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gramsci » 17. September 2006 18:08

Wiedmann wrote:Jedenfalls kannst du das in der "XAMPP FAQ" nachlesen.


Hab das leider nicht in der XAMPP FAQ (http://faq.kwm-web.info/doku.php?id=xampp) gefunden.
Gramsci
 
Posts: 8
Joined: 18. August 2006 09:12


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests