mysql als dienst laufen lassen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mysql als dienst laufen lassen

Postby thimberwolf » 05. August 2003 08:41

hallo ihr lieben !
ich arbeite mit winXp prof und habe xampp auf laufwerk f weil dort auch xp läuft.
habe mir die neueste xampp version runtergeladen funktioniert auch wunderbar. den apache lass ich als dienst laufen funktioniert auch bestens. ich kann aber mysql nicht als dienst starten .. unter systemsteuerung/verwaltung/dienste ist mysql aufgeführt. nun gibt es die möglichkeit dort den dienst von hand zu starten dann kommt folgende meldung: "der Dienst MySql auf lokaler computer kontte nicht gestartet werden. Fehler 1067: der Prozess wurde unerwartet beendet"
was kann ich machen ?
die datei "mysql_installservice.bat" liegt nicht wie in der beschreibung xampp_man.txt unter xampp\apache sondern in xampp\mysql liegt es vieleicht daran das mysql nicht als diesnt startet ?
noch einen schönen tag ..
thimberwolf
ps . phpMyAdmin-2.5.3 ist raus
thimberwolf
 
Posts: 11
Joined: 03. May 2003 14:46
Location: bremerhaven

Postby Thhunder » 05. August 2003 08:50

wenn ich das MySQL als dienst starte gehts bei mir auch nicht... dann kommt:

Code: Select all
der Dienst MySql auf lokaler computer kontte nicht gestartet werden. Fehler 3: das systhem kann den angegebenen Pfad nicht finden


dabei hab ich den apache server nie verschoben....
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby Kristian Marcroft » 05. August 2003 13:20

Thhunder hat folgendes geschrieben::
wenn ich das MySQL als dienst starte gehts bei mir auch nicht... dann kommt:

Code:
der Dienst MySql auf lokaler computer kontte nicht gestartet werden. Fehler 3: das systhem kann den angegebenen Pfad nicht finden


dabei hab ich den apache server nie verschoben....


Hi,

hier erstmal dienst deinstlliert, und ncohmal versuchen...
ggf. mal mySQl übers Batchfile starten... geht das?
geht das fenster gleich wieder zu etc...
Was kommen da für fehler?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby thimberwolf » 05. August 2003 13:31

hallo,
auch nach mehrmaligen versuchen mit neustart des rechners funktioniert der dienst für mysql nicht. er wird zwar in der liste angezeigt aber funktioniert nicht. auch in der msconfig wird er als dienst angezeigt.
in den windows task manager wird er auch angezeigt.
wenn ich msql normal starte dann läuft es , aber das fesnter bleibt offen.
mfg
thimberwolf
in den windows task manage wird bei mir der apache zwei mal angezeigt . ist das richtich ?
thimberwolf
 
Posts: 11
Joined: 03. May 2003 14:46
Location: bremerhaven

Postby Thhunder » 05. August 2003 13:31

also bei mir lässt es sich auf die art starten... nur ich kann dann (siehe anderen Threat) nicht richtig damit arbeiten.....
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby thimberwolf » 05. August 2003 17:53

hallo ihr lieben
esläuft.. lag an der my datei :-( hoffe ich zumindest
mfg thimberwolf
thimberwolf
 
Posts: 11
Joined: 03. May 2003 14:46
Location: bremerhaven

Postby nemesis » 05. August 2003 19:30

hi....

wenn du mysql als dienst unter win nt installieren willst, dann MUSST du die my.cnf aus dem Xampp/ Verzeichnis nach C:\ kopieren!

Steht aber auch in der Readme, also bitte nicht nach dem genauen namen fragen, ich weiß das die Datei anders heißt :) (was angelegt wird)
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby Haue » 05. August 2003 20:46

Hi, ich habe das gleiche Problem wie Timberwolf, obwohl ich die "my" nach C: kopiert habe. Immer wieder die Meldung:
Prozess wurde unerwartet beendet.
Gruß Haue
User avatar
Haue
 
Posts: 41
Joined: 25. February 2003 16:17
Location: Emsland

Postby Thhunder » 05. August 2003 22:43

@ timberwolf und @ Haue

versucht mal MySQL mit der Mysql_strat.bat datei im Xampp verzeicniss zu starten! das sollte jedenfalls funktioniern... und ob da ne cmd in das Taskleiste auf is oder ob das im hintergrund is ist eigentli egal find ich....
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby Haue » 06. August 2003 08:52

mit dem offenen dos-fenster geht's bei mir aber auch nicht?
Gruß Haue
User avatar
Haue
 
Posts: 41
Joined: 25. February 2003 16:17
Location: Emsland

Postby thimberwolf » 06. August 2003 10:27

hallo ihr lieben,
bei mir ist die my datei in "F:\xampp\mysql\bin" da win xp auf der partition "F" liegt. habe eine verknüpfung von der my erstellt und dann diese dann in "F:\" gelegt. und siehe da es funzt :-)
hat einer eine deutschsprachige beschreibung von Mercury ?
mfg thimberwolf
thimberwolf
 
Posts: 11
Joined: 03. May 2003 14:46
Location: bremerhaven

Postby Thhunder » 08. August 2003 08:35

bei mir startet MySQL immernoch nich troz das die "my" datei auf der windows platte is....

fehler sieht so aus:

Code: Select all

Der Dienst "MySQL" auf "Lokaler Computer" konnte nicht gestartet werden.
Fehler 1067: Der Prozess wurde unerwartet beendet.



wie bekomm ich das "weg" sodass mySQL auch als Dienst läuft??

P.S.: habe windows XP mit SP1 instaliert falls es einen Weiter bringt ;)
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby thimberwolf » 09. August 2003 12:09

hallo,
wo hast du die "My" datei abegelgt, in C:/ ? auf welcher partition hast du dein xp ?
mfg.thimberwolf
thimberwolf
 
Posts: 11
Joined: 03. May 2003 14:46
Location: bremerhaven

Postby TwentyOne » 15. August 2003 23:13

nemesis wrote:hi....

wenn du mysql als dienst unter win nt installieren willst, dann MUSST du die my.cnf aus dem Xampp/ Verzeichnis nach C:\ kopieren!

Steht aber auch in der Readme, also bitte nicht nach dem genauen namen fragen, ich weiß das die Datei anders heißt :) (was angelegt wird)


hääää????
könntest du mal bitte deutsch reden!!!!

1. im XAMPP-Verzeichnis gibt es keine my.cnf Datei nicht mal ne *.cnf!
2. es gibt eine my.cnf Datei im xampp/mysql/bin Verzeichnis, die kann es aber wohl nicht sein, da die als server nicht den nt-service setzt:

[WinMySQLadmin]
Server=E:/Entwicklung/xampp/xampp/mysql/bin/mysqld.exe

Bei mir läuft der Service einwandfrei! Leider blickt die xampp oberfläche den Zugriff darauf überhaupt nicht!!! Der MySql Test sagt mir immer, das der Dienst nicht gestertet/installiert is und PHPMyAdmin meldet:

Can't connect to MySQL server on 'localhost' (10061)

Super!!! Ich kann den Dienst aber gut über das mitgelieferte Tool winmysqladmin.exe erreichen. Dieses erzeugt mir auch eine my.ini datei, die es in D:\WINNT speichert. Mittlerweile habe ich diese Datei unter my.cnf in C:\ D:\ sowie D:\WINNT liegen (Auf D:\ ist mein Win2k installiert) und immer noch geht nichts!!!!

Wie bekomme ich diesen Scheissdre*** zum laufen?!!!??? Mein Gott ich mache jetzt schon 4 Stunde an diesem Müll rum - in der Zeit programmiere ich einen ganzen Webshop fertig. Und ich hatte gedacht XAMPP stellt eine Erleichterung dar!

Also könnte sich Jemand vielleicht herablassen und eine einigermassen verständliche und nachvollziehbare Installationsanweisung schreiben? Ja?

Danke!
TwentyOne
 

Postby nemesis » 16. August 2003 03:38

nochmal gaaanz langsam zum mitlesen:

Nach installieren (ist nur pfad anpassen in den jeweiligen configs)
über die setup_xampp.bat wird am ende im selben Verzeichnis eine my_example.cnf datei angelegt, diese muss als my.cnf nach C:\ kopiert werden.

Für den nicht möglichen Fall das die Installation fehlschlägt:
basedir=H:/test/xampp/mysql
datadir=H:/test/xampp/mysql/data
tmpdir=H:/test/xampp/tmp
Server=H:/test/xampp/mysql/bin/mysqld.exe


so in der Richtung müsste der Inhalt aussehen (nur die Pfadangaben)
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests