Probleme mit Dateigrößen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit Dateigrößen

Postby oschmidt » 09. August 2006 09:01

Hallo Ihr,

ich habe eigentlich nur ein kleines Problem. Beim suchen leider nix passendes gefunden. Als erstes: ich benutze XAMPP (die neueste Version). Mein Problem ist, das folgender Download-Verweis zwar funktioniert, ab irgendwie doch fehlerhaft ist.

echo "<a href='test.rar'>Datei downloaden</a>";

Problem: Die Datei hat meinetwegen 1 MB Größe. Ich klicke auf den Link, der Dateidownload beginnt, wird jedoch als scheinbar erfolgreich beendet, mit der Meldung, dass 128 KB gedownloaded wurden. Die Datei ist auch tatsächlich nur 128 KB groß, ob die Quelle nun 1, 100 oder 1.000 MB groß ist.

Das selbe Problem habe ich mit Bildern, die Größer 128 KB sind. Können einfach nicht angezeigt werden. Selbiges Problem mit PDF-Dateien.

Vermutung: Ich denke mal, dass liegt an einer Apache- oder PHP-Einstellung. Denn wenn ich diesen Link in einem HTML-File ausserhalb des PHP-File-Root-Verzeichnisses anwende, funktioniert diese Variante problemlos.

Hat vieleicht jemand eine Lösung!
oschmidt
 
Posts: 4
Joined: 09. August 2006 08:49

Postby Wiedmann » 09. August 2006 12:34

Ändere maöl in der Apache-Config die Einstellung für "EnableSendfile".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby oschmidt » 09. August 2006 20:01

Danke für den Tipp. Habe ich geändert. Leider immer noch ohne Erfolg.
oschmidt
 
Posts: 4
Joined: 09. August 2006 08:49

Re: Probleme mit Dateigrößen

Postby martinpre » 10. August 2006 02:45

oschmidt wrote:echo "<a href='test.rar'>Datei downloaden</a>";


ich würd mal echo '<a href="test.rar">xyz</a>'; versuchen ...
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby Wiedmann » 10. August 2006 02:53

oschmidt wrote:Danke für den Tipp. Habe ich geändert. Leider immer noch ohne Erfolg.

Dann gäbe es da noch EnableMMAP und Win32DisableAcceptEx.

martinpre wrote:ich würd mal echo '<a href="test.rar">xyz</a>'; versuchen ...

Ist im Prinzip das Selbe was er schon hatte und erzeugt beides korrektes HTML.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby oschmidt » 10. August 2006 08:25

EnableMMAP hab ich probiert. Funnzt leider auch net. Aber es ist schon richtig, das ich "on" eintragen muss, oder???

Und die Variable Win32DisableAcceptEx kann ich gar nicht finden.
oschmidt
 
Posts: 4
Joined: 09. August 2006 08:49

Postby Wiedmann » 10. August 2006 13:48

Aber es ist schon richtig, das ich "on" eintragen muss, oder???

Kann ich so nciht sagen. Was steht denn bisher da?


Und die Variable Win32DisableAcceptEx kann ich gar nicht finden.

Directive, nicht Variable. Und finden kannst sie nicht, da es halt bisher nicht benutzt wurde... Schreibs einfach rein zum Testen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby oschmidt » 11. August 2006 08:00

Tschuldige, falsche Wortwahl...

Bisher stand hinter EnableMMAP und EnableSendfile nur das Wörtchen "off".

Das mit der Directive Win32DisableAcceptEx werde ich heute abend probieren.

Danke erstmal für eure Hilfestellungen.

Notfalls werde ich xampp neu installieren. Allerdings interessiert mich brennend, woran es liegen könnte...
oschmidt
 
Posts: 4
Joined: 09. August 2006 08:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests