xampp verzeichniss passwort geschützt...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp verzeichniss passwort geschützt...

Postby weimat4 » 03. August 2006 01:50

Hy...

Nach stündigem nachlesen und Probierens, werde ich doch mal meine Frage stellen..
Ich bin z.z am tüffteln, zwecks Sicherheit meines XAMPP.

Meine grund Idee ist, das haubt Verzeichniss http://localhost/ so
wie- oder http://rechner_ip/ mit einem passwort zu schützten.
quasie das verzeichniss C:/../xampp/htdocs/ .

(http://localhost/ ist bei mir die Startseite von XAMPP)

denn Sicherheitscheck hab ich schon gemacht und es wird nur http://localhost/security/index.php durch .htaccess gschützt.

ich möchte aber auch die "Startseite von XAMPP" sowie das verzeichniss "htdocs" per passwort schützten.
geht das?

wenn ja dann würde ich mich sehr um eine antwort freuen denn ich weiß einfach nicht weiter :cry:

danke im voraus

mfg weimat4
weimat4
 
Posts: 8
Joined: 21. July 2006 00:49

Postby Wiedmann » 03. August 2006 02:08

denn Sicherheitscheck hab ich schon gemacht und es wird nur http://localhost/security/index.php durch .htaccess gschützt.

ich möchte aber auch die "Startseite von XAMPP" ... per passwort schützten

Der Sicherheitscheck sollte eingentlich auch die "Startseite von XAMPP" mit einem Passwort schützen? *grübel*

Ansonsten:
Nach stündigem nachlesen und Probierens,

Was ist dir denn nach diesem noch genau unklar, was das Schützen eines Verzeichnisses angeht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby weimat4 » 03. August 2006 02:24

Hui das ging ja schnell...

Naja eben nicht. Ich kann auf der "Startseite von XAMPP" ohne weiteres zugreifen....mhm... komisch

Naja meinte nur, ob jemand das selbe Problem schon mal hatte...
Frage kannst du mir ne Seite empfehlen über .htaccess ec. weil das ist npch neu Land für mich...


hab dank für die Antwort

mgf weimat4
weimat4
 
Posts: 8
Joined: 21. July 2006 00:49

Postby Wiedmann » 03. August 2006 03:56

Naja meinte nur, ob jemand das selbe Problem schon mal hatte...

Nicht beim aktuellen XAMPP. Von dem geh ich jetzt mal aus, da du nichts abweichendes geschrieben hast...

Frage kannst du mir ne Seite empfehlen über .htaccess

Vielleicht überraschend ;-) Aber als naheliegensde würde ich jetzt mal das Apache-Manual erwähnen. Da steht eigentlich alles zu diesem Thema drin.

IMHO gibt's auch was in der "XAMPP FAQ" dazu. Und als Vorlage natürlich die ".htaccess" die XAMPP selbst anlegt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby weimat4 » 03. August 2006 12:04

Meinst du das es vieleicht an der Version liegt? ich hab die Version 1.5.1...
weimat4
 
Posts: 8
Joined: 21. July 2006 00:49

Postby Wiedmann » 03. August 2006 12:09

ich hab die Version 1.5.1...

Bei dem fehlt ein "AllowOverride All" für's DocumentRoot in der "httpd.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby weimat4 » 03. August 2006 12:23

und wie kann ich das ganze beheben? soll ich etwas in der "httpd.conf" verändern oder gleich ein Update meines XAMPP ziehen?

mfg weimat4
weimat4
 
Posts: 8
Joined: 21. July 2006 00:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests