deinstallation von apache server

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

deinstallation von apache server

Postby nina » 01. August 2006 14:28

hallo miteinander,

habe vor nem jahr xampp für windows installiert.aus irgendeinem grund hat es nicht mehr funktioniert. jetzt habe ich es deinstalliert und nochmals neu raufgegeben, jedoch hat es mir anscheinend den apache nicht runtergelöscht. wie kann ich den jetzt im nachhinein löschen, wo die uninstall weg ist? es erkennt glaub ich auch bei der neuen installation, dass apache oben ist, erkennt aber den richtigen pfad nicht mehr. :cry:

vielen dank für eure hilfe
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby cpoint » 01. August 2006 14:44

Hallo,

ich hatte ein ähnliches problem, und habe xampp neu aufgezogen, danach wieder deinstalliert. zur vorsicht habe ich nochmal den xampp-ordner gelöscht (von hand), weil der immer noch mit resten vorhanden war.

dann hab ichs wieder neu aufgezogen, und alles funktionierte wieder fehlerfrei, vielleicht hilfts dir auch.

gruss Cpoint
cpoint
 
Posts: 43
Joined: 17. November 2004 18:21

deinstallation von apache

Postby nina » 02. August 2006 09:43

hallo

das habe ich eben schon alles versucht, habe da wirklich alles weggelöscht...und die installation an sich funktioniert, nur der apache lässt sich ja wirklich nicht deinstallieren, da ich den ordner komplett gelöscht habe, weiß ich nicht, wie ich den apache wirklich deinstallieren kann.....

weißt du das vielleicht?

vielen dank für die bemühungen.
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby cpoint » 02. August 2006 10:10

moin,

Also, wenn Xampp installiert ist, sollte im Ordner:

/xampp/apache/

diese datei sein:

apache_uninstallservice.bat => Apache deinstallieren als Dienst

damit sollte es eigentlich gehen, also damit soll der dienst wieder deinstalliert werden.

hast du mal versucht den dienst in windows zu stoppen und dann zu löschen?
system - verwalten - dienste

vielleicht kann man da was machen.

gruss
cpoint
 
Posts: 43
Joined: 17. November 2004 18:21

Postby nina » 02. August 2006 12:24

hallo nochmal

also stimmt in der systemsteuerung unter den diensten kann ich den apache wirklich finden...jedoch ist er nicht gestartet und kann auch nicht starten, weil er den pfad nicht mehr erkennen kann....kann ich das einfach rauslöschen?

glg
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby cpoint » 02. August 2006 12:53

Ich denke schon, wenn er ihn eh nicht mehr erkennt ... deswegen auch nicht startet, wirst den wohl löschen können, sofern windows diese entscheidung zulässt.
cpoint
 
Posts: 43
Joined: 17. November 2004 18:21

Postby KingCrunch » 02. August 2006 17:39

Jo, Dienst stoppen, Dienst löschen, Verzeichniss entfernen. Der Apache frisst sich nich so tief ins System, so dass diese Variante (noch?) funktioniert.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby cpoint » 02. August 2006 17:59

Zur not gibts noch die "gefährlichere" Variante das ganze in der Registrierung zu machen/löschen.

@KingCrunch

Lob für Deine HP. Hatte ähnliches auch schon mal gemacht, leider ohne Erfolg. Werde mal bei Dir näher schauen.
Ich hats mal mit http://u1200.de probiert, werds aber wieder aufgeben.

Gruss
cpoint
 
Posts: 43
Joined: 17. November 2004 18:21

Postby nina » 03. August 2006 15:38

hallo ihr beiden,

habe das über die registry gelöscht....bei der systemsteuerung lässt sich nichts löschen...der apache ist gelöscht und kann gar nicht mehr gestartet werden....jetzt habe ich das alles geschafft....neu installiert und dann bringt er mir die meldung dass port 80 bei apache geblockt wird.....was kann ich jetzt noch tun..... :roll:

vielen dank euch

ihr habt wirklich schöne hp´s

lg
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby Wiedmann » 03. August 2006 15:47

und dann bringt er mir die meldung dass port 80 bei apache geblockt wird.....

Je genauer und vollständig (also 1:1) du Fehlermeldungen postest, desto eher können wir eine korrekte Lösung nennen.

So stochere ich mal im Nebel:
benutz die "xampp-portcheck.exe"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nina » 03. August 2006 16:06

hallo

tja ich kann dir ja leider keinen screenshot senden. beim Port 80 steht vorne Apache (http) aber beim Status steht dann noch D:\Programme\skype.exe (das habe ich ja auch installiert, könnte das was ausmachen?)

könnte es eventuell auch etwas auf sich haben, dass ich das antivir installiert habe und da ev. die firewall blockt?

danke und lg
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby Wiedmann » 03. August 2006 16:11

tja ich kann dir ja leider keinen screenshot senden.

Die "xampp-portcheck.exe" gibt reinen Text aus, den man mit Copy 'n Paste ins Forum tun kann...

beim Port 80 steht vorne Apache (http) aber beim Status steht dann noch D:\Programme\skype.exe

Du meinst so?
Code: Select all
Service              Port   Status
==============================================================================
Apache (HTTP)          80   D:\Programme\skype.exe


(das habe ich ja auch installiert, könnte das was ausmachen?)

Also wenn Skype bereits den Port 80 belegt, kann der Apache diesen nicht auch noch benutzen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nina » 03. August 2006 16:19

ja genauso...der port 81 ist frei...dh ich muss den apache irgendwie dort hin bringen :-)

lg
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17

Postby Wiedmann » 03. August 2006 16:23

dh ich muss den apache irgendwie dort hin bringen :-)

z.B.

innervoller wäre es aber, Skype nicht diesen Port 80 benutzen zu lassen. Port 80 ist halt einfach der Port für Webserver.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nina » 03. August 2006 16:25

ok danke, das versuch ich das gleich, vielen dank erst mal

ganz liebe grüße
nina
nina
 
Posts: 7
Joined: 01. August 2006 14:17


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests