XAMPP 1.5.3a Windows: PHP Code wird ignoriert

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 1.5.3a Windows: PHP Code wird ignoriert

Postby rkp » 31. July 2006 04:09

Hallo Forum,

ich habe Win XAMPP 1.5.3a auf Win XP Pro SP1a installiert. Die Konfiguration ist unverändert.

Der Status wird wie folgt angezeigt:

MySQL-Datenbank = DEAKTIVIERT
PHP = AKTIVIERT
HTTPS (SSL) = AKTIVIERT
Common Gateway Interface (CGI) = AKTIVIERT
Server Side Includes (SSI) = AKTIVIERT
SMTP Server = DEAKTIVIERT
FTP Server = DEAKTIVIERT

Nun habe ich eine index.htm in das htdocs Verzeichnis kopiert und über http://localhost/index.htm aufgerufen. Alles wird angezeigt und nur nicht der PHP Code. Es erscheint keine Fehlermeldung.

Ein Beispiel für das PHP:

<?php
$PHPVersion = phpversion();
echo "Auf diesem Server läuft die PHP-Version " . $PHPVersion;
?>

Nicht mal der echo führt zu irgendeinem Ergebnis.

Bin ratlos, an der Berechtigung für das Verzeichnis kann es wohl nicht liegen.

Bitte um Unterstützung, was mache ich falsch?

Danke
rkp
 
Posts: 21
Joined: 31. July 2006 03:42

Postby Wiedmann » 31. July 2006 12:40

Nun habe ich eine index.htm in das htdocs Verzeichnis kopiert und über http://localhost/index.htm aufgerufen. Alles wird angezeigt und nur nicht der PHP Code.

PHP-Scripte haben normal die Endung "*.php".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

PHP Datei sollte mit .php enden

Postby rkp » 31. July 2006 14:25

Hallo Wiedmann,

meinst Du wirklich, dass es daran liegen könnte? :mrgreen:

Aber natürlich, wie konnte ich nur so blind sein? Auf einmal funzzt alles so wie es soll. :oops:

Danke und Gruss
rkp
 
Posts: 21
Joined: 31. July 2006 03:42


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests